summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-09 21:18:45 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-09 21:24:24 +0100
commit1ca076ad98100f78fd72d9eb99652d064408d6f9 (patch)
treee2cc67c4eb610969a12ddb5f33c53cdfdcc182a0
parent96ec78e0ae607e5e0732a4af08a204499b879f02 (diff)
downloadaur-packages-1ca076ad98100f78fd72d9eb99652d064408d6f9.tar.gz
aur-packages-1ca076ad98100f78fd72d9eb99652d064408d6f9.tar.xz
apache update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--apache/PKGBUILD17
-rwxr-xr-x[-rw-r--r--]apache/httpd12
2 files changed, 16 insertions, 13 deletions
diff --git a/apache/PKGBUILD b/apache/PKGBUILD
index 58eec71..6e0ee50 100644
--- a/apache/PKGBUILD
+++ b/apache/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: PKGBUILD 53935 2009-10-04 02:14:40Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
@@ -13,15 +13,12 @@ license=('APACHE')
backup=(etc/httpd/conf/httpd.conf
etc/httpd/conf/extra/httpd-{autoindex,dav,default,info,languages}.conf
etc/httpd/conf/extra/httpd-{manual,mpm,multilang-errordoc}.conf
- etc/httpd/conf/extra/httpd-{ssl,userdir,vhosts}.conf)
-depends=('openssl' 'zlib' 'apr-util' 'pcre' 'libldap>=2.4.18-1')
+ etc/httpd/conf/extra/httpd-{ssl,userdir,vhosts}.conf
+ etc/logrotate.d/httpd)
+depends=('openssl' 'zlib' 'apr-util' 'pcre')
optdepends=('lynx: apachectl status')
source=("http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2"
'httpd.logrotate' 'httpd' 'arch.layout')
-md5sums=('8d8d904e7342125825ec70f03c5745ef'
- 'f4d627c64024c1b7b95efb5ffbaa625e'
- 'bddd84dafa770d74df1dc1f96bd71823'
- '3d659d41276ba3bfcb20c231eb254e0c')
build() {
cd ${srcdir}/httpd-${pkgver}
@@ -83,5 +80,9 @@ build() {
}
md5sums=('a5226203aaf97e5b941c41a71c112704'
'f4d627c64024c1b7b95efb5ffbaa625e'
- 'bddd84dafa770d74df1dc1f96bd71823'
+ 'ac992b7d9f6dfc71a75e56a8e33f6ca8'
'3d659d41276ba3bfcb20c231eb254e0c')
+sha1sums=('eacd04c87b489231ae708c84a77dc8e9ee176fd2'
+ '1fd10ad14347de56a8250039000626a318e6e4b8'
+ 'acf63ea85776100725ab918001e1b7546e200db6'
+ '22da55836c6d15e4f94064177ff02c8e56c0a53f')
diff --git a/apache/httpd b/apache/httpd
index fa84eff..46ead71 100644..100755
--- a/apache/httpd
+++ b/apache/httpd
@@ -8,7 +8,7 @@ daemon_name=httpd
case "$1" in
start)
- stat_busy "Starting $daemon_name daemon"
+ stat_busy "Starting Apache Web Server"
# RUN
/usr/sbin/apachectl start &>/dev/null
#
@@ -22,7 +22,7 @@ case "$1" in
;;
stop)
- stat_busy "Stopping $daemon_name daemon"
+ stat_busy "Stopping Apache Web Server"
# KILL
/usr/sbin/apachectl stop &>/dev/null
#
@@ -36,7 +36,8 @@ case "$1" in
;;
reload)
- stat_busy "Reloading $daemon_name daemon"
+ apachectl -t || exit 1
+ stat_busy "Reloading Apache Web Server"
/usr/sbin/apachectl graceful &>/dev/null
if [ $? -gt 0 ]; then
stat_fail
@@ -48,7 +49,8 @@ case "$1" in
;;
restart)
- stat_busy "Restarting $daemon_name daemon"
+ apachectl -t || exit 1
+ stat_busy "Restarting Apache Web Server"
/usr/sbin/apachectl restart &>/dev/null
if [ $? -gt 0 ]; then
stat_fail
@@ -60,7 +62,7 @@ case "$1" in
;;
status)
- stat_busy "Checking $daemon_name status";
+ stat_busy "Checking Apache Web Server status";
ck_status $daemon_name
;;