summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2013-05-28 20:45:23 +0200
committerFlorian Pritz <bluewind@xinu.at>2013-05-28 20:45:23 +0200
commit7071c6fff1e0e4a3159f088a5a30d0fb2c32a997 (patch)
treeed0b8ee6d7f9590f343d03e63881a7e3ddb5286e
parentc6000c9d9949b3326fb82f02431899ab6774b960 (diff)
downloadaur-packages-7071c6fff1e0e4a3159f088a5a30d0fb2c32a997.tar.gz
aur-packages-7071c6fff1e0e4a3159f088a5a30d0fb2c32a997.tar.xz
spampd: some fixes for perl 5.18
Signed-off-by: Florian Pritz <bluewind@xinu.at>
-rw-r--r--spampd/PKGBUILD20
-rw-r--r--spampd/fix-pod.patch42
-rw-r--r--spampd/spampd.install2
-rw-r--r--spampd/untaint-pidfile.patch28
4 files changed, 83 insertions, 9 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
index 4aa2e11..84e4950 100644
--- a/spampd/PKGBUILD
+++ b/spampd/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Florian "Bluewind" Pritz <flo@xssn.at>
pkgname=spampd
pkgver=2.30
-pkgrel=7
+pkgrel=8
pkgdesc="Spamassassin Proxy Daemon"
arch=('any')
url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
license=('GPL')
depends=('perl' 'perl-net-server' 'spamassassin')
-backup=(etc/conf.d/spampd)
install=spampd.install
source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
- rc-script rc-config spampd.service)
+ spampd.service untaint-pidfile.patch fix-pod.patch)
md5sums=('742c6f2cb75db54e59d044a8ee40445f'
- 'da17b3904a63252931cfb5f02e6a089f'
- 'f452cf5046abc218bffb1e951485d8f0'
- 'f29bea0766c07a18f6dc0a496a79e0ac')
+ 'f29bea0766c07a18f6dc0a496a79e0ac'
+ '41f9dc41a42f3b82fdeadfe8943ee0a3'
+ 'cb5832fd21d3a8aa7fbe188d79c04147')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p1 -i "$srcdir/untaint-pidfile.patch"
+ patch -p1 -i "$srcdir/fix-pod.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -26,8 +32,6 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm755 spampd "$pkgdir/usr/bin/spampd"
- install -Dm755 "$srcdir/rc-script" "$pkgdir/etc/rc.d/spampd"
- install -Dm644 "$srcdir/rc-config" "$pkgdir/etc/conf.d/spampd"
install -Dm644 spampd.8.gz "$pkgdir/usr/share/man/man8/spampd.8.gz"
install -Dm644 "$srcdir/spampd.service" "$pkgdir/usr/lib/systemd/system/spampd.service"
}
diff --git a/spampd/fix-pod.patch b/spampd/fix-pod.patch
new file mode 100644
index 0000000..c3b343a
--- /dev/null
+++ b/spampd/fix-pod.patch
@@ -0,0 +1,42 @@
+commit 7b409a8f7132bd731fad017e13ad1229a09a37b7
+Author: Florian Pritz <bluewind@xinu.at>
+Date: Tue May 28 20:42:30 2013 +0200
+
+ fix text before =item after =over
+
+ Signed-off-by: Florian Pritz <bluewind@xinu.at>
+---
+ spampd | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/spampd b/spampd
+index 53161d9..fca23e4 100644
+--- a/spampd
++++ b/spampd
+@@ -1149,10 +1149,10 @@ L<http://www.WorldDesign.com/index.cfm/rd/mta/spampd.htm>.
+
+ =head1 Requires
+
+-=over 5
+-
+ Perl modules:
+
++=over 5
++
+ =item B<Mail::SpamAssassin>
+
+ =item B<Net::Server::PreForkSimple>
+@@ -1480,11 +1480,11 @@ Prints usage information.
+
+ =head2 Deprecated Options
+
+-=over 5
+-
+ The following options are no longer used but still accepted for backwards
+ compatibility with prevoius I<spampd> versions:
+
++=over 5
++
+ =item B<--dead-letters>
+
+ =item B<--heloname>
diff --git a/spampd/spampd.install b/spampd/spampd.install
index edf6d27..d1393ec 100644
--- a/spampd/spampd.install
+++ b/spampd/spampd.install
@@ -1,5 +1,5 @@
post_install() {
- useradd -m -d /home/spampd -r spampd
+ useradd -m -d /home/spampd -r spampd
}
post_remove() {
diff --git a/spampd/untaint-pidfile.patch b/spampd/untaint-pidfile.patch
new file mode 100644
index 0000000..cd93ad0
--- /dev/null
+++ b/spampd/untaint-pidfile.patch
@@ -0,0 +1,28 @@
+commit 662d82ec2badc34f4de561021ea714afe1e1bddc
+Author: Florian Pritz <bluewind@xinu.at>
+Date: Tue May 28 20:20:44 2013 +0200
+
+ untaint $pidfile to prevent errors when opening it
+
+ For some reason that worked before perl 5.18, but I don't care enough
+ to figure out why. Since we trust the CLI args untaining anything
+ should be ok.
+
+ Signed-off-by: Florian Pritz <bluewind@xinu.at>
+---
+ spampd | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/spampd.pl b/spampd.pl
+index 7b1f234..53161d9 100644
+--- a/spampd
++++ b/spampd
+@@ -937,6 +937,8 @@ if ( !$options{logsock} ) {
+ };
+ }
+
++# untaint pidfile
++($pidfile) = ($pidfile =~ /^(.+)$/);
+
+ my $server = bless {
+ server => {host => $host,