summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-22 21:42:30 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-22 21:42:30 +0100
commit7155de6730bac6549b53cb08b746581d5ce4fa50 (patch)
treeba3f486c77c0608a2a108047cde2eeb612901d90
parentac2be60a6f3e6805f9c4a5986fc9bdc67798f4c5 (diff)
downloadaur-packages-7155de6730bac6549b53cb08b746581d5ce4fa50.tar.gz
aur-packages-7155de6730bac6549b53cb08b746581d5ce4fa50.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--ffmpeg-svn/PKGBUILD58
-rw-r--r--gadmin-samba/PKGBUILD10
-rw-r--r--gtknetcat/PKGBUILD7
-rw-r--r--mplayer-vdpau-nogui/PKGBUILD10
-rw-r--r--opencore-amr/no_segfault_configure.diff11
-rw-r--r--thunderbird3/PKGBUILD57
-rw-r--r--thunderbird3/default_locale.patch11
-rw-r--r--thunderbird3/mozconfig36
-rw-r--r--thunderbird3/thunderbird3.desktop10
-rw-r--r--x264-git/PKGBUILD50
10 files changed, 243 insertions, 17 deletions
diff --git a/ffmpeg-svn/PKGBUILD b/ffmpeg-svn/PKGBUILD
new file mode 100644
index 0000000..ae596b5
--- /dev/null
+++ b/ffmpeg-svn/PKGBUILD
@@ -0,0 +1,58 @@
+# Contributor: raubkopierer <mail[dot]sensenmann[at]googlemail[dot]com>
+
+pkgname=ffmpeg-svn
+pkgver=20578
+pkgrel=1
+pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
+arch=('i686' 'x86_64')
+url="http://ffmpeg.mplayerhq.hu/"
+license=('GPL')
+depends=('lame' 'sdl' 'faad2' 'faac' 'zlib' 'imlib2' 'x264' 'libtheora')
+makedepends=('subversion')
+provides=("ffmpeg=`date +%Y%m%d`")
+conflicts=('ffmpeg')
+source=()
+md5sums=()
+
+_svntrunk=svn://svn.ffmpeg.org/ffmpeg/trunk
+_svnmod=ffmpeg
+
+build() {
+ cd "$srcdir"
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$_svnmod-build"
+ mkdir "$_svnmod-build"
+ cd "$_svnmod-build"
+
+ "$srcdir/$_svnmod/configure" \
+ --prefix=/usr \
+ --enable-gpl \
+ --enable-nonfree \
+ --enable-libmp3lame \
+ --enable-libfaac \
+ --enable-libfaad \
+ --enable-libx264 \
+ --enable-libtheora \
+ --enable-postproc \
+ --enable-shared \
+ --enable-pthreads \
+ --enable-x11grab \
+ --arch=`uname -m` \
+ || return 1
+
+ make || return 1
+ make doc/ff{mpeg,play,server}.1 || return 1
+
+ make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install-man || return 1
+
+}
diff --git a/gadmin-samba/PKGBUILD b/gadmin-samba/PKGBUILD
index 06dbf6a..7f19861 100644
--- a/gadmin-samba/PKGBUILD
+++ b/gadmin-samba/PKGBUILD
@@ -3,10 +3,10 @@
# Contributor: Marcin Kaczorek <kaczus@karek.pl>
pkgname=gadmin-samba
-pkgver=0.2.7
+pkgver=0.2.8
pkgrel=1
pkgdesc="An easy to use GTK+ frontend for the SAMBA file and print server"
-url="http://85.214.17.244/gadmintools/index.php?option=com_content&task=view&id=16&Itemid=30"
+url="http://gadmintools.flippedweb.com/index.php?option=com_content&task=view&id=16&Itemid=30"
arch=('i686' 'x86_64')
license=('GPL')
depends=('gtk2' 'samba')
@@ -25,7 +25,7 @@ build() {
install -D -m644 desktop/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
}
-md5sums=('3cbe8828c766cae8651b7059367b3f02'
+md5sums=('28b92f17f69ca589bd3a2b6674f428b6'
'23582cbe1716d3683b96987547fa7724')
-sha256sums=('e791c51a110a8861f658d150913a6db46c8f9b931756423482aa654614479521'
- '665d4aa296b0d1a0dc5b469b37383b169262c8cdcb31bcc5785908dc0cac9397')
+sha1sums=('b6d4a5e958210ffe2c4e9f6d473a6854ab5eef14'
+ 'a2c7b7d0e5d8080a8adb11d41466253cbc63be43')
diff --git a/gtknetcat/PKGBUILD b/gtknetcat/PKGBUILD
index 9b6a277..fb795f0 100644
--- a/gtknetcat/PKGBUILD
+++ b/gtknetcat/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=gtknetcat
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc="GUI for netcat"
-arch=('i686')
+arch=('i686' 'x86_64')
url="http://lxde.org"
license=('GPL')
-depends=('gnu-netcat' 'gawk')
+depends=('gnu-netcat' 'gawk' 'python')
+makedepends=('intltool')
source=(http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz)
build() {
diff --git a/mplayer-vdpau-nogui/PKGBUILD b/mplayer-vdpau-nogui/PKGBUILD
index f519722..3296729 100644
--- a/mplayer-vdpau-nogui/PKGBUILD
+++ b/mplayer-vdpau-nogui/PKGBUILD
@@ -1,7 +1,7 @@
#Contributor: Reiser <metal@pop3.ru>
pkgname=mplayer-vdpau-nogui
-pkgver=29794
+pkgver=29962
pkgrel=1
pkgdesc="Famous multimedia player, dev. version, without its GUI and support for nvidia VDPAU"
arch=('i686' 'x86_64')
@@ -27,14 +27,6 @@ build() {
cd $_svnmod-build
patch -p1 < ../no_segfault_configure.diff
-# svn checkout svn://svn.ffmpeg.org/soc/wmapro wmapro
-# cp wmapro/wma* libavcodec
-# patch -p0 <wmapro/audioframesize.patch
-# patch -p0 <wmapro/mplayer.patch
-# patch -p0 <wmapro/wmapro_ffmpeg.patch
-#
-# cp -v wmapro/wma3dec.c wmapro/wma3data.h wmapro/wma3.h libavcodec
-
./configure --prefix=/usr --confdir=/etc/mplayer --disable-gui \
--enable-ossaudio --disable-alsa --disable-pulse --enable-pthreads \
--enable-runtime-cpudetection --enable-largefiles --enable-menu \
diff --git a/opencore-amr/no_segfault_configure.diff b/opencore-amr/no_segfault_configure.diff
new file mode 100644
index 0000000..2dd5fe4
--- /dev/null
+++ b/opencore-amr/no_segfault_configure.diff
@@ -0,0 +1,11 @@
+--- a/configure.old 2008-11-15 23:27:59.000000000 +0100
++++ b/configure 2008-11-15 23:28:26.000000000 +0100
+@@ -79,7 +79,7 @@
+ }
+
+ tmp_run() {
+- "$TMPEXE" >> "$TMPLOG" 2>&1
++ :
+ }
+
+ # Display error message, flushes tempfile, exit
diff --git a/thunderbird3/PKGBUILD b/thunderbird3/PKGBUILD
new file mode 100644
index 0000000..4e1a659
--- /dev/null
+++ b/thunderbird3/PKGBUILD
@@ -0,0 +1,57 @@
+# Contibutor: Andreas Schönfelder <passtschu at freenet dot de>
+
+pkgname=thunderbird3
+pkgver=3.0b4
+pkgrel=5
+pkgdesc="Standalone Mail/News reader (installs besides thunderbird2)"
+arch=('i686' 'x86_64')
+license=('MPL' 'GPL')
+url="http://www.mozilla.org/projects/thunderbird"
+depends=('gtk2>=2.14.7' 'gcc-libs>=4.3.3' 'libidl2' 'mozilla-common' 'libxt' 'shared-mime-info')
+makedepends=('zip' 'pkgconfig' 'imagemagick' 'libgnomeui' 'dbus' 'python')
+options=('!ccache' '!distcc')
+source=(ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${pkgver}/source/thunderbird-${pkgver}.source.tar.bz2
+ mozconfig
+ thunderbird3.desktop
+ default_locale.patch)
+md5sums=('0f7c7cdfebd8948b7e3fe835773b072d'
+ '8a3b273574d76f6cb3a255afce84e00c'
+ 'da268f4dbf6fbb8efa13221f39d9fb32'
+ '39fe15f99264dc1b6776059de87dfa88')
+
+build() {
+ cd "${srcdir}"
+ cp "${srcdir}/mozconfig" comm-central/.mozconfig
+ cd comm-central/
+
+ patch -Np1 -i "${srcdir}/default_locale.patch" || return 1
+
+ unset CFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+
+ if [ "${CARCH}" = "x86_64" ]; then
+ echo "ac_cv_visibility_pragma=no" >> .mozconfig
+ fi
+
+ export MOZ_PROJECT=mail
+
+ make -f client.mk build || return 1
+ make -j1 DESTDIR="${pkgdir}" -C objdir-tb install|| return 1
+
+ rm -rf "${pkgdir}/usr/bin/defaults"
+
+ mv "${pkgdir}/usr/bin/thunderbird"{,3}
+ install -m755 -d "${pkgdir}/usr/share/applications"
+ install -m755 -d "${pkgdir}/usr/share/pixmaps"
+ install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${pkgdir}/usr/share/pixmaps/thunderbird3.png"
+
+ #Is this a bug??? What happened to default.xpm?!
+ convert "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm"
+
+ install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm" \
+ "${pkgdir}/usr/lib/thunderbird-${pkgver}/icons/" || return 1
+ install -m644 "${srcdir}/thunderbird3.desktop" "${pkgdir}/usr/share/applications/"
+
+ rm -f ${pkgdir}/usr/lib/pkgconfig/thunderbird-ns{s,pr}.pc
+}
diff --git a/thunderbird3/default_locale.patch b/thunderbird3/default_locale.patch
new file mode 100644
index 0000000..6b903cd
--- /dev/null
+++ b/thunderbird3/default_locale.patch
@@ -0,0 +1,11 @@
+--- comm-central/mozilla/modules/libpref/src/init/all.js 2009-10-11 02:12:44.000000000 +0200
++++ comm-central/mozilla/modules/libpref/src/init/all.js 2009-09-16 02:56:45.000000000 +0200
+@@ -890,7 +890,7 @@
+ pref("intl.charset.detector", "chrome://global/locale/intl.properties");
+ pref("intl.charset.default", "chrome://global-platform/locale/intl.properties");
+ pref("intl.ellipsis", "chrome://global-platform/locale/intl.properties");
+-pref("intl.locale.matchOS", false);
++pref("intl.locale.matchOS", true);
+ // fallback charset list for Unicode conversion (converting from Unicode)
+ // currently used for mail send only to handle symbol characters (e.g Euro, trademark, smartquotes)
+ // for ISO-8859-1
diff --git a/thunderbird3/mozconfig b/thunderbird3/mozconfig
new file mode 100644
index 0000000..db7abae
--- /dev/null
+++ b/thunderbird3/mozconfig
@@ -0,0 +1,36 @@
+mk_add_options MOZ_CO_PROJECT=mail
+ac_add_options --enable-application=mail
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-tb/
+mk_add_options AUTOCONF=autoconf-2.13
+
+ac_add_options --prefix=/usr --libdir=/usr/lib
+
+#ac_add_options --with-system-nspr
+#ac_add_options --with-system-nss
+#ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --disable-installer
+ac_add_options --enable-optimize
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --enable-official-branding
+ac_add_options --disable-xprint
+ac_add_options --disable-strip
+ac_add_options --disable-install-strip
+ac_add_options --enable-pango
+ac_add_options --enable-system-cairo
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --disable-crashreporter
+ac_add_options --enable-static
+ac_add_options --enable-calendar
+
+mk_add_options MOZ_MAKE_FLAGS=-j3
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
diff --git a/thunderbird3/thunderbird3.desktop b/thunderbird3/thunderbird3.desktop
new file mode 100644
index 0000000..619f6f9
--- /dev/null
+++ b/thunderbird3/thunderbird3.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Thunderbird3
+Comment=Mail & News Reader
+Exec=thunderbird3
+Icon=thunderbird3.png
+Terminal=false
+Type=Application
+Categories=Application;Network;
+StartupNotify=true
diff --git a/x264-git/PKGBUILD b/x264-git/PKGBUILD
new file mode 100644
index 0000000..5b43dab
--- /dev/null
+++ b/x264-git/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: zhuqin <zhuqin83@gmail.com>
+
+pkgname=x264-git
+pkgver=20091122
+pkgrel=1
+pkgdesc="free library for encoding H264/AVC video streams"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libx11')
+makedepends=('git' 'yasm' 'gettext')
+url="http://www.videolan.org/developers/x264.html"
+conflicts=('x264')
+replaces=(x264-svn)
+provides=("x264=$pkgver")
+source=()
+md5sums=()
+
+_gitroot="git://git.videolan.org/x264.git"
+_gitname="x264"
+
+build() {
+ cd $srcdir
+ msg "Connecting to the GIT server...."
+
+ if [[ -d $srcdir/$_gitname ]] ; then
+ cd $_gitname
+ git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done"
+ msg "Starting make..."
+
+ rm -rf $srcdir/$_gitname-build
+ git clone $srcdir/$_gitname $srcdir/$_gitname-build
+
+ cd $srcdir/$_gitname-build
+
+ ./configure --prefix=/usr \
+ --enable-visualize \
+ --enable-shared \
+ --enable-pic || return 1
+
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+ rm -rf $srcdir/$_gitname-build
+}