summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-05-09 17:54:10 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-05-09 17:55:06 +0200
commitac57415603ea60e9af632e70827dffa22cfff584 (patch)
treebbb94687951aab970d1ec711f14a5d5bc5225281
parent9d1a5d07d1b35b7d75904802e04be6544265e413 (diff)
downloadaur-packages-ac57415603ea60e9af632e70827dffa22cfff584.tar.gz
aur-packages-ac57415603ea60e9af632e70827dffa22cfff584.tar.xz
tipp10: add patch
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--tipp10/PKGBUILD15
-rw-r--r--tipp10/gcc-4.5.patch99
2 files changed, 108 insertions, 6 deletions
diff --git a/tipp10/PKGBUILD b/tipp10/PKGBUILD
index d37bd47..04ff601 100644
--- a/tipp10/PKGBUILD
+++ b/tipp10/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=tipp10
pkgver=2.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="intelligent typing tutor (german only)"
arch=('i686' 'x86_64')
url="http://www.tipp10.de/"
license=('GPL2')
depends=('qt>=4.2.2')
makedepends=('unzip' 'make')
-source=(tipp10.desktop tipp10.png defines.h.patch \
+source=(tipp10.desktop tipp10.png defines.h.patch gcc-4.5.patch \
"http://www.tipp10.de/download_hidden/tipp10_source_v2-0-3.zip")
build() {
@@ -18,6 +18,7 @@ build() {
cd $srcdir/tipp10
patch -p0 < "$srcdir/defines.h.patch" || return 1
+ patch -p0 < "$srcdir/gcc-4.5.patch" || return 1
qmake
make || return 1
install -D tipp10 $pkgdir/usr/bin/tipp10
@@ -28,8 +29,10 @@ build() {
md5sums=('e0d6c26220396551386f91ce893e040c'
'ff788e726d357370df1e7c8b19d38fd4'
'ce67b64cb3a1d25119acd1a43804304d'
+ 'a9d388ddb17ae93f13acb915bc8eba57'
'bac29896ec992496f7e0aab992993004')
-sha256sums=('ed18e5cb625463595ca4d84c9e4576d42af407c31a29a76e2bc7a8538288d35d'
- '83c2574c3ba23b3344669bf15cbd618dfe8ddc3863bdfce1d70ba22200bd8ff0'
- '02e5791a64b4881d0edd87e28d1f161aba228ac77b1d657814c105c2c4eba88f'
- 'bf44edc1524b8dac07c0d501368411cc13e5c1a2a6ffb0d1b4d576ba1ad80fd5')
+sha1sums=('c0f9f6dab87ed2cc0557bd0bc29a102f8f4483b7'
+ '42cc902010030dcea92dd64053523e24028b2dae'
+ '340aa263721b9fc1df74a1cc828c990061c7d625'
+ '3eb601ab7c1d68d8c64e949e7e4f8a83b06a518e'
+ 'faf8c7799c934eaca83a0e077cf9ba458334680b')
diff --git a/tipp10/gcc-4.5.patch b/tipp10/gcc-4.5.patch
new file mode 100644
index 0000000..dfff820
--- /dev/null
+++ b/tipp10/gcc-4.5.patch
@@ -0,0 +1,99 @@
+--- sql/chartablesql.cpp 2010-05-08 14:53:48.000000000 +0200
++++ sql/chartablesql.cpp 2010-05-08 14:53:59.000000000 +0200
+@@ -50,7 +50,7 @@
+ // Read the unicode value
+ unicode = value.toInt();
+ // Convert unicode to a char
+- unicodeToChar = QString::QString(QChar(unicode)); //"\'" + QString::QString(QChar(unicode)) + "\'";
++ unicodeToChar = QString(QChar(unicode)); //"\'" + QString::QString(QChar(unicode)) + "\'";
+ return unicodeToChar;
+ } else {
+ // Last column (error weight)
+--- sql/startsql.cpp 2010-05-08 14:54:24.000000000 +0200
++++ sql/startsql.cpp 2010-05-08 14:54:49.000000000 +0200
+@@ -338,7 +338,7 @@
+ for (i = 0; i < content.size(); i++) {
+ //simplifiedContent = QString::QString(
+ // content.at(i)).replace(QChar(0x27), "''", Qt::CaseSensitive).simplified();
+- simplifiedContent = trim(QString::QString(
++ simplifiedContent = trim(QString(
+ content.at(i)).replace(QChar(0x27), "''", Qt::CaseSensitive));
+
+ if (!query.exec("INSERT INTO own_content VALUES(NULL,'" +
+--- widget/lessondialog.cpp 2010-05-08 14:52:48.000000000 +0200
++++ widget/lessondialog.cpp 2010-05-08 14:53:11.000000000 +0200
+@@ -89,7 +89,7 @@
+ *lessonData = lineLessonContent->toPlainText().split("\n", QString::SkipEmptyParts);
+ // Delete empty lines
+ for (int i = 0; i < lessonData->size(); i++) {
+- if (QString::QString(lessonData->at(i).toLocal8Bit().constData()).simplified() == "") {
++ if (QString(lessonData->at(i).toLocal8Bit().constData()).simplified() == "") {
+ lessonData->removeAt(i);
+ }
+ }
+@@ -268,7 +268,7 @@
+ contentList = lineLessonContent->toPlainText().split("\n", QString::SkipEmptyParts);
+ // Delete empty lines
+ for (i = 0; i < contentList.size(); i++) {
+- if (QString::QString(contentList.at(i).toLocal8Bit().constData()).simplified() == "") {
++ if (QString(contentList.at(i).toLocal8Bit().constData()).simplified() == "") {
+ contentList.removeAt(i);
+ }
+ }
+--- widget/settingspages.cpp 2010-05-08 14:45:41.000000000 +0200
++++ widget/settingspages.cpp 2010-05-08 14:45:57.000000000 +0200
+@@ -617,7 +617,7 @@
+ QSettings settings;
+ #endif
+ settings.beginGroup("database");
+- settings.setValue("pathpro", lineDatabasePath->text() + "/" + QString::QString(APP_USER_DB));
++ settings.setValue("pathpro", lineDatabasePath->text() + "/" + QString(APP_USER_DB));
+ settings.endGroup();
+ }
+
+--- widget/tickerboard.cpp 2010-05-08 14:28:38.000000000 +0200
++++ widget/tickerboard.cpp 2010-05-08 14:44:11.000000000 +0200
+@@ -96,7 +96,7 @@
+
+ if (tickerSpeed == 50) {
+ scrollOffset = 290;
+- scroll(-290, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
++ scroll(-290, 0, QRect(10, 15, 590, 35)); //contentsRect());
+ }
+
+ startFlag = true;
+@@ -150,7 +150,7 @@
+ scrollOffset = 0;
+ } else {
+ scrollOffset = 290;
+- scroll(-290, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
++ scroll(-290, 0, QRect(10, 15, 590, 35)); //contentsRect());
+ }
+ splitLesson();
+ }
+@@ -239,7 +239,7 @@
+
+ // Move ticker 1 pixel to left
+ scrollOffset++;
+- scroll(-1, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
++ scroll(-1, 0, QRect(10, 15, 590, 35)); //contentsRect());
+
+ if ((lessonOffset - scrollOffset) <= 30) {
+ setSpeed(tickerSpeed);
+@@ -262,14 +262,14 @@
+ // 160 pixels overage (because the user must see at least the next word)
+ if ((lessonOffset - scrollOffset) > 200) {
+ scrollOffset += (lessonOffset - scrollOffset) - 200;
+- scroll(-((lessonOffset - scrollOffset) - 200), 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
++ scroll(-((lessonOffset - scrollOffset) - 200), 0, QRect(10, 15, 590, 35)); //contentsRect());
+ }
+ } else {
+ // If the user types faster than the ticker, move ticker faster after
+ // 160 pixels overage (because the user must see at least the next word)
+ if ((lessonOffset - scrollOffset) > 280) {
+ scrollOffset += 570;
+- scroll(-570, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
++ scroll(-570, 0, QRect(10, 15, 590, 35)); //contentsRect());
+ }
+
+ }