summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-01-17 11:58:41 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-01-17 11:58:41 +0100
commitf56ccc71f9d5d564bdbed1946732a456f4a52a63 (patch)
treeeab8a63d31800d37a54c709f1ac2435e7be80693
parent2f9f502d10d7ac92f051b40a71b31998c93e2607 (diff)
downloadaur-packages-f56ccc71f9d5d564bdbed1946732a456f4a52a63.tar.gz
aur-packages-f56ccc71f9d5d564bdbed1946732a456f4a52a63.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--ack/PKGBUILD37
-rw-r--r--inxi/PKGBUILD2
-rw-r--r--mplayer-vdpau-nogui/PKGBUILD7
-rw-r--r--portbunny/PKGBUILD19
-rw-r--r--portbunny/timespec.patch20
5 files changed, 61 insertions, 24 deletions
diff --git a/ack/PKGBUILD b/ack/PKGBUILD
index 5fe7b01..4472bae 100644
--- a/ack/PKGBUILD
+++ b/ack/PKGBUILD
@@ -1,16 +1,25 @@
-# Maintainer: Michael S. Walker <barrucadu@localhost>
-pkgname=ack
-pkgver=1.90
-pkgrel=1
-pkgdesc="A tool like grep, aimed at programmers with large trees of heterogeneous source code."
-url="http://ack.googlecode.com"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('perl')
-source=(http://ack.googlecode.com/svn/tags/$pkgver/$pkgname)
-md5sums=('d15d059166beff6103d2401aa2d783c7')
+# Maintainer: TDY <tdy@gmx.com>
+# Contributor: Michael S. Walker <barrucadu@localhost>
+
+pkgname=ack
+pkgver=1.92
+pkgrel=1
+pkgdesc="A Perl-based grep replacement, aimed at programmers with large trees of heterogeneous source code"
+arch=('any')
+url="http://betterthangrep.com/"
+license=('GPL' 'PerlArtistic')
+depends=('perl-file-next')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/$pkgname-$pkgver.tar.gz)
+md5sums=('c25b5a16d0a27386a75c91d531b86cea')
build() {
- cd $startdir/src
- install -D -m755 ack ${pkgdir}/usr/bin/ack
-} \ No newline at end of file
+ cd "$srcdir/$pkgname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/inxi/PKGBUILD b/inxi/PKGBUILD
index 3014b8f..96baf59 100644
--- a/inxi/PKGBUILD
+++ b/inxi/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Florian Pritz <f-p@gmx.at>
pkgname=inxi
-pkgver=1.2.5
+pkgver=1.3.1
pkgrel=1
pkgdesc="script to get system information"
arch=('any')
diff --git a/mplayer-vdpau-nogui/PKGBUILD b/mplayer-vdpau-nogui/PKGBUILD
index f59dfd3..78587d0 100644
--- a/mplayer-vdpau-nogui/PKGBUILD
+++ b/mplayer-vdpau-nogui/PKGBUILD
@@ -1,13 +1,13 @@
#Contributor: Reiser <metal@pop3.ru>
pkgname=mplayer-vdpau-nogui
-pkgver=29964
+pkgver=30337
pkgrel=1
pkgdesc="Famous multimedia player, dev. version, without its GUI and support for nvidia VDPAU"
arch=('i686' 'x86_64')
url="http://www.mplayerhq.hu/"
license=('GPL')
-depends=('ttf-dejavu' 'nvidia' 'opencore-amr' 'libdvdnav>=4.1.3' 'lame' 'xvidcore' 'libvdpau')
+depends=('ttf-dejavu' 'nvidia>=190.42' 'libvdpau' 'opencore-amr' 'libdvdnav>=4.1.3' 'lame' 'xvidcore')
makedepends=('subversion')
conflicts=('mplayer')
provides=(mplayer=$pkgver)
@@ -28,8 +28,7 @@ build() {
patch -p1 < ../no_segfault_configure.diff
./configure --prefix=/usr --confdir=/etc/mplayer --disable-gui \
- --enable-ossaudio --disable-alsa --disable-pulse --enable-pthreads \
- --enable-runtime-cpudetection --enable-largefiles --enable-menu \
+ --disable-runtime-cpudetection --enable-largefiles --enable-menu \
--disable-libdv --disable-aa --disable-liblzo --disable-speex \
--disable-fribidi --disable-arts --disable-esd --disable-smb --enable-dvdnav \
--disable-openal --disable-faad-internal --disable-directfb \
diff --git a/portbunny/PKGBUILD b/portbunny/PKGBUILD
index 5f16fa0..fad01b9 100644
--- a/portbunny/PKGBUILD
+++ b/portbunny/PKGBUILD
@@ -11,10 +11,11 @@ license=('GPL')
depends=('python>=2.4')
makedepends=('make' 'gcc' 'kernel-headers')
install=portbunny.install
-source=("http://portbunny.recurity.com/tarballs/PortBunny050109-dev.tar.gz" "installpath.patch")
+source=("http://portbunny.recurity.com/tarballs/PortBunny050109-dev.tar.gz" "installpath.patch" "timespec.patch")
build() {
cd "$startdir/src/PortBunny050109-dev"
- patch -p1 < ../installpath.patch
+ patch -p1 < $srcdir/installpath.patch
+ patch -p1 < $srcdir/timespec.patch
make || return 1050109_dev
mkdir -p $startdir/pkg/lib/modules/$(uname -r)/kernel/ $startdir/pkg/usr/share/portbunny || return 1
mkdir -p $startdir/pkg/usr/bin || return 1
@@ -23,6 +24,14 @@ build() {
# vim:set ts=2 sw=2 et:
md5sums=('792ceed6d20e5035f9dc1fcc318d2bbe'
- 'd056310ab5b14b6f859907b6fac7ae5d')
-sha256sums=('e916e93a562315e5dc9f35693d4f08720865e36676590da6742226bd80dfd13f'
- 'fba5c7a24181d9066c03a94dc106208bdf183724e7cdd85948094a9c31dc23b8')
+ 'd056310ab5b14b6f859907b6fac7ae5d'
+ '42164c0e7d477538074afe942731bb8f')
+sha1sums=('829a3c39bc021d81c600899cd4b25de2f01cce32'
+ 'd765395cda24edea41c66d213b14973a62e88e48'
+ 'c290f52d41abb64acceae8a1eec84ffac59febe9')
+md5sums=('792ceed6d20e5035f9dc1fcc318d2bbe'
+ 'd056310ab5b14b6f859907b6fac7ae5d'
+ '4c1d452b454d78d36ce90f60a6c7ce90')
+sha1sums=('829a3c39bc021d81c600899cd4b25de2f01cce32'
+ 'd765395cda24edea41c66d213b14973a62e88e48'
+ '8f4f93aeab397f39e5408d6090d34af73330c09c')
diff --git a/portbunny/timespec.patch b/portbunny/timespec.patch
new file mode 100644
index 0000000..6ac01ae
--- /dev/null
+++ b/portbunny/timespec.patch
@@ -0,0 +1,20 @@
+--- PortBunny050109-dev/timespec_utils.c 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev/timespec_utils.c.new 2010-01-08 13:08:48.000000000 +0100
+@@ -53,7 +53,7 @@
+
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,16)
+-
++#if false
+ void set_normalized_timespec(struct timespec *ts, time_t sec, long nsec)
+ {
+ while (nsec >= NSEC_PER_SEC) {
+@@ -67,7 +67,7 @@
+ ts->tv_sec = sec;
+ ts->tv_nsec = nsec;
+ }
+-
++#endif
+ #endif
+
+