summaryrefslogtreecommitdiffstats
path: root/btnx/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
committerFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
commit3232f9d90114778cb8d38cc1bc8477435dc65259 (patch)
tree0eb9ffafbe853c84b9ad6b808d86a00d44668392 /btnx/PKGBUILD
downloadaur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.gz
aur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.xz
initial commit
Diffstat (limited to 'btnx/PKGBUILD')
-rw-r--r--btnx/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/btnx/PKGBUILD b/btnx/PKGBUILD
new file mode 100644
index 0000000..d81c0a4
--- /dev/null
+++ b/btnx/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Florian Pritz <f-p@gmx.at>
+# Contributor: Graziano Giuliani <graziano.giuliani@poste.it>
+
+pkgname=btnx
+pkgver=0.4.11
+pkgrel=3
+pkgdesc="Button Extension- a GNU/GPL mouse tool for GNU/Linux"
+arch=('i686' 'x86_64')
+url="http://www.ollisalonen.com/btnx/"
+license=('GPL')
+groups=(daemons)
+depends=('btnx-config' 'libdaemon')
+options=('!libtool' '!emptydirs')
+source=(http://www.ollisalonen.com/btnx/${pkgname}-${pkgver}.tar.gz
+ btnx)
+md5sums=('8216a84f8fe873ddc97afbfccfc2d254'
+ '4c9ff4950bc766002e34e53bffc61521')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure || return 1
+ make || return 1
+
+ mkdir -p ${pkgdir}/etc/btnx
+
+ install -Dm 755 src/btnx ${pkgdir}/usr/sbin/btnx || return 1
+ install -Dm 644 data/events -p ${pkgdir}/etc/btnx/events || return 1
+ install -Dm 755 ${srcdir}/btnx ${pkgdir}/etc/rc.d/btnx || return 1
+}
+
+# vim:set ts=2 sw=2 et: