summaryrefslogtreecommitdiffstats
path: root/codecs
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 00:51:51 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 00:51:51 +0200
commit168118db7c4b1fd03547440cc5359a6d1a2f4fd4 (patch)
tree6f2521b0d50d70a396dc969e803d0d11f8d33eeb /codecs
parent702a3d5b092feb07625958a31dc225863319a10e (diff)
downloadaur-packages-168118db7c4b1fd03547440cc5359a6d1a2f4fd4.tar.gz
aur-packages-168118db7c4b1fd03547440cc5359a6d1a2f4fd4.tar.xz
mass update
Diffstat (limited to 'codecs')
-rw-r--r--codecs/PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/codecs/PKGBUILD b/codecs/PKGBUILD
index aae74b6..ee6114d 100644
--- a/codecs/PKGBUILD
+++ b/codecs/PKGBUILD
@@ -2,32 +2,37 @@
pkgname=codecs
pkgver=20071007
-pkgrel=4
-pkgdesc="Non-linux native codec pack. (Win32, Real9, QuickTime)"
+pkgrel=6
+pkgdesc="Non-linux native codec pack."
arch=('i686' 'x86_64')
url="http://www.mplayerhq.hu/design7/dload.html"
license=('unknown')
+conflicts=('codecs-extra')
+replaces=('codecs-extra')
# The codec packages are different
# only the 32 bit package needs legacy libstdc++
[ "$CARCH" = "i686" ] && depends=('libstdc++5')
[ "$CARCH" = "x86_64" ] && depends=('gcc-libs')
-optdepends=('codecs-extra: additional codecs (i686 only)')
options=('!strip')
-
-md5sums=('4ea9c2dbd0945c83af1a8d0dd363993c')
-_arch=""
if [ "${CARCH}" = "x86_64" ]; then
- _arch="-amd64"
+ source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/essential-amd64-${pkgver}.tar.bz2)
md5sums=('8e1ceeec51469f5baac65e56fac709e8')
+else
+ source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/all-${pkgver}.tar.bz2)
+ md5sums=('0407e8ad132e37ccd3f932448ca201c5')
fi
-source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/essential${_arch}-${pkgver}.tar.bz2)
+
build() {
install -d ${pkgdir}/usr/lib/codecs
cd ${pkgdir}/usr/lib
- ln -s codecs win32
- install -m644 ${srcdir}/essential${_arch}-${pkgver}/* ${pkgdir}/usr/lib/codecs
+ if [ "${CARCH}" = "x86_64" ]; then
+ install -m644 ${srcdir}/essential-amd64-${pkgver}/* ${pkgdir}/usr/lib/codecs
+ else
+ ln -s codecs win32
+ install -m644 ${srcdir}/all-${pkgver}/* ${pkgdir}/usr/lib/codecs
+ fi
rm ${pkgdir}/usr/lib/codecs/README
}