summaryrefslogtreecommitdiffstats
path: root/codecs
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-06-18 19:18:48 +0200
committerFlorian Pritz <f-p@gmx.at>2009-06-18 19:18:48 +0200
commit488d3624be68a1655fc8b40241f514e52855d18b (patch)
tree92b5edbd9e5193c188cca3dd7b6e92ae562312b3 /codecs
parentf15be7756cf924b6b116655846804d45d971581e (diff)
downloadaur-packages-488d3624be68a1655fc8b40241f514e52855d18b.tar.gz
aur-packages-488d3624be68a1655fc8b40241f514e52855d18b.tar.xz
update
Diffstat (limited to 'codecs')
-rw-r--r--codecs/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/codecs/PKGBUILD b/codecs/PKGBUILD
new file mode 100644
index 0000000..aae74b6
--- /dev/null
+++ b/codecs/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Babets
+
+pkgname=codecs
+pkgver=20071007
+pkgrel=4
+pkgdesc="Non-linux native codec pack. (Win32, Real9, QuickTime)"
+arch=('i686' 'x86_64')
+url="http://www.mplayerhq.hu/design7/dload.html"
+license=('unknown')
+# The codec packages are different
+# only the 32 bit package needs legacy libstdc++
+[ "$CARCH" = "i686" ] && depends=('libstdc++5')
+[ "$CARCH" = "x86_64" ] && depends=('gcc-libs')
+optdepends=('codecs-extra: additional codecs (i686 only)')
+options=('!strip')
+
+
+md5sums=('4ea9c2dbd0945c83af1a8d0dd363993c')
+_arch=""
+if [ "${CARCH}" = "x86_64" ]; then
+ _arch="-amd64"
+ md5sums=('8e1ceeec51469f5baac65e56fac709e8')
+fi
+source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/essential${_arch}-${pkgver}.tar.bz2)
+
+build() {
+ install -d ${pkgdir}/usr/lib/codecs
+ cd ${pkgdir}/usr/lib
+ ln -s codecs win32
+ install -m644 ${srcdir}/essential${_arch}-${pkgver}/* ${pkgdir}/usr/lib/codecs
+ rm ${pkgdir}/usr/lib/codecs/README
+}
+