summaryrefslogtreecommitdiffstats
path: root/firefox-hg
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2011-10-23 22:01:53 +0200
committerFlorian Pritz <bluewind@xinu.at>2011-10-23 22:02:18 +0200
commitebc82b27288df5c58194083ead4a6e6de7f52d21 (patch)
tree30d4e874cc19a03dfc62a0ee7c6c5e6c9756d4ec /firefox-hg
parent44c6e7dfa4967843b05ee961fd243f655ed31717 (diff)
downloadaur-packages-ebc82b27288df5c58194083ead4a6e6de7f52d21.tar.gz
aur-packages-ebc82b27288df5c58194083ead4a6e6de7f52d21.tar.xz
mass update (again :( )
Signed-off-by: Florian Pritz <bluewind@xinu.at>
Diffstat (limited to 'firefox-hg')
-rw-r--r--firefox-hg/100-system-hunspell-corrections.patch116
-rw-r--r--firefox-hg/PKGBUILD59
-rw-r--r--firefox-hg/firefox-hg-safe.desktop12
-rw-r--r--firefox-hg/firefox-hg.desktop84
-rw-r--r--firefox-hg/firefox.install21
-rw-r--r--firefox-hg/firefox.sh3
-rw-r--r--firefox-hg/mozconfig43
7 files changed, 0 insertions, 338 deletions
diff --git a/firefox-hg/100-system-hunspell-corrections.patch b/firefox-hg/100-system-hunspell-corrections.patch
deleted file mode 100644
index 5533e10..0000000
--- a/firefox-hg/100-system-hunspell-corrections.patch
+++ /dev/null
@@ -1,116 +0,0 @@
---- ./extensions/spellcheck/hunspell/src/mozHunspell.cpp.orig 2008-02-15 19:21:21.000000000 +0000
-+++ ./extensions/spellcheck/hunspell/src/mozHunspell.cpp 2008-02-15 19:23:20.000000000 +0000
-@@ -63,6 +63,9 @@
- #include "nsISimpleEnumerator.h"
- #include "nsIDirectoryEnumerator.h"
- #include "nsIFile.h"
-+#ifdef MOZ_NATIVE_HUNSPELL
-+#include "nsILocalFile.h"
-+#endif
- #include "nsDirectoryServiceUtils.h"
- #include "nsDirectoryServiceDefs.h"
- #include "mozISpellI18NManager.h"
-@@ -307,7 +310,16 @@
- return;
-
- nsCOMPtr<nsIFile> dictDir;
-- rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
-+ #ifdef MOZ_NATIVE_HUNSPELL
-+ nsCOMPtr<nsILocalFile> localFile;
-+ rv = NS_NewNativeLocalFile(nsDependentCString("/usr/share/myspell"),PR_TRUE, getter_AddRefs(localFile));
-+ if (localFile && NS_SUCCEEDED(rv)) {
-+ localFile->QueryInterface(NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
-+ LoadDictionariesFromDir(dictDir);
-+ }
-+ else {
-+ #endif
-+ rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
- NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
- if (NS_SUCCEEDED(rv)) {
- LoadDictionariesFromDir(dictDir);
-@@ -332,6 +344,9 @@
- LoadDictionariesFromDir(appDir);
- }
- }
-+#ifdef MOZ_NATIVE_HUNSPELL
-+ }
-+#endif
-
- nsCOMPtr<nsISimpleEnumerator> dictDirs;
- rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY_LIST,
---- ./extensions/spellcheck/src/Makefile.in.orig 2008-02-15 19:25:58.000000000 +0000
-+++ ./extensions/spellcheck/src/Makefile.in 2008-02-15 19:28:36.000000000 +0000
-@@ -63,9 +63,16 @@
- txtsvc \
- uconv \
- unicharutil \
-+ xulapp \
- $(NULL)
-
--CPPSRCS = \
-+ifdef MOZ_NATIVE_HUNSPELL
-+CPPSRCS += mozHunspell.cpp
-+ifdef MOZ_XUL_APP
-+CPPSRCS += mozHunspellDirProvider.cpp
-+endif
-+endif
-+CPPSRCS += \
- mozSpellCheckerFactory.cpp \
- mozSpellChecker.cpp \
- mozPersonalDictionary.cpp \
-@@ -80,8 +87,14 @@
- SHARED_LIBRARY_LIBS += ../osxspell/src/$(LIB_PREFIX)osxspell_s.$(LIB_SUFFIX)
- LOCAL_INCLUDES += -I$(srcdir)/../osxspell/src
- else
-+ifndef MOZ_NATIVE_HUNSPELL
- SHARED_LIBRARY_LIBS += ../hunspell/src/$(LIB_PREFIX)hunspell_s.$(LIB_SUFFIX)
- LOCAL_INCLUDES += -I$(srcdir)/../hunspell/src
-+else
-+LOCAL_INCLUDES += $(MOZ_HUNSPELL_CFLAGS) \
-+ -DMOZ_NATIVE_HUNSPELL \
-+ $(NULL)
-+endif
- endif
-
- EXTRA_DSO_LDOPTS = \
-@@ -96,3 +112,18 @@
- LOCAL_INCLUDES += \
- -I$(topsrcdir)/xpcom/io \
- $(NULL)
-+
-+ifdef MOZ_NATIVE_HUNSPELL
-+export:: $(srcdir)/../hunspell/src/mozHunspell.cpp
-+ $(INSTALL) $(srcdir)/../hunspell/src/mozHunspell.* .
-+GARBAGE += mozHunspell.$(OBJ_SUFFIX) mozHunspell.cpp
-+clean::
-+ rm -f mozHunspell.*
-+ifdef MOZ_XUL_APP
-+export:: $(srcdir)/../hunspell/src/mozHunspellDirProvider.cpp
-+ $(INSTALL) $(srcdir)/../hunspell/src/mozHunspellDirProvider.* .
-+GARBAGE += mozHunspellDirProvider.$(OBJ_SUFFIX) mozHunspellDirProvider.cpp
-+clean::
-+ rm -f mozHunspellDirProvider.*
-+endif
-+endif
---- ./extensions/spellcheck/Makefile.in.orig 2008-02-15 19:23:39.000000000 +0000
-+++ ./extensions/spellcheck/Makefile.in 2008-02-15 19:24:34.000000000 +0000
-@@ -42,13 +42,19 @@
- include $(DEPTH)/config/autoconf.mk
-
- MODULE = spellchecker
--DIRS = idl locales
-+ifndef MOZ_NATIVE_HUNSPELL
-+DIRS = idl locales
-+else
-+DIRS = idl
-+endif
-
- ifeq (camino,$(MOZ_BUILD_APP))
- DIRS += osxspell
- else
-+ifndef MOZ_NATIVE_HUNSPELL
- DIRS += hunspell
- endif
-+endif
-
- DIRS += src
diff --git a/firefox-hg/PKGBUILD b/firefox-hg/PKGBUILD
deleted file mode 100644
index d36858f..0000000
--- a/firefox-hg/PKGBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# Contributor: MutantMonkey <mutantmonkey@gmail.com>
-pkgname=firefox-hg
-pkgver=42124
-pkgrel=1
-_ffver="3.7a4pre"
-pkgdesc="Standalone web browser from mozilla.org, latest development version"
-url="http://www.mozilla.org/projects/firefox/"
-arch=('i686' 'x86_64')
-license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2>=2.16.2' 'gcc-libs>=4.4.0' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.3' 'nspr>=4.8' 'libxt' 'hunspell>=1.2.8' 'startup-notification>=0.10' 'pango>=1.24.0' 'desktop-file-utils' 'cairo>=1.8.0' 'libpng>=1.2.24-3' 'libjpeg' 'lcms')
-makedepends=('mercurial' 'zip' 'pkgconfig' 'diffutils' 'imagemagick' 'python' 'xorg-server' 'autoconf2.13')
-provides=("firefox=${_ffver}")
-install=firefox.install
-source=(mozconfig
- 100-system-hunspell-corrections.patch
- firefox-hg.desktop
- firefox-hg-safe.desktop
- firefox.sh)
-md5sums=('36a05c10f79b03287f76ed4da3f6c7b4'
- '5efd6772ed0ecf8eddec5d5650191d3c'
- '4022581eb05405b82c489d5ea16b1a17'
- '9271601e9b9837c8f3fc3a35367ea3aa'
- '9f89ce44e4202783779c4bc33f10c176')
-sha256sums=('f6f1d56cc7a3d9142b03823c5b9531ec841bcbce212181285f45ea1ed035f18d'
- '00c854d817b878270f9362c0ab432e210f8d4b5a01a1b8b68c17012c16c7a77e'
- '5e805fd15d9937ed219afbf3e30c7d39dd613733f6e60d011e6087f765765d10'
- 'e6d3f3ba8b8c3340de1f2456e6812084a379c521bb01965b34f9559b59a6f05a'
- '5e2cbdf36bb021504e2e8fd8400637301237f12d62820a9d0359ee5e68591609')
-
-_hgroot="http://hg.mozilla.org"
-_hgrepo=mozilla-central
-
-build() {
- cd ${srcdir}/mozilla-central
- cp ${srcdir}/mozconfig .mozconfig
-
- # update firefox.sh launcher with proper Firefox version
- sed -i "s/firefox-hg/firefox-${_ffver}/g" ${srcdir}/firefox.sh
-
- #fix build with system hunspell - gentoo
- #patch -Np0 -i "${srcdir}/100-system-hunspell-corrections.patch" || return 1
-
- unset CFLAGS
- unset CXXFLAGS
- export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-${_ffver}"
-
- make -j1 -f client.mk MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
- make -j1 DESTDIR=${pkgdir} -C ff-opt-obj install || return 1
-
- rm -f ${pkgdir}/usr/bin/firefox
- install -m755 ${srcdir}/firefox.sh ${pkgdir}/usr/bin/firefox-hg || return 1
-
- install -m755 -d ${pkgdir}/usr/share/applications
- install -m755 -d ${pkgdir}/usr/share/pixmaps
- install -m644 ${srcdir}/mozilla-central/browser/branding/nightly/default48.png ${pkgdir}/usr/share/pixmaps/firefox-hg.png || return 1
- install -m644 ${srcdir}/firefox-hg.desktop ${pkgdir}/usr/share/applications/ || return 1
- install -m644 ${srcdir}/firefox-hg-safe.desktop ${pkgdir}/usr/share/applications/ || return 1
-
-}
diff --git a/firefox-hg/firefox-hg-safe.desktop b/firefox-hg/firefox-hg-safe.desktop
deleted file mode 100644
index 492c083..0000000
--- a/firefox-hg/firefox-hg-safe.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=firefox-hg -safe-mode %u
-Icon=firefox-hg
-Type=Application
-Terminal=false
-MultipleArgs=false
-Name=Firefox (hg) - Safe Mode
-GenericName=Web Browser - Safe Mode
-StartupNotify=false
-Categories=Application;Network;
-
diff --git a/firefox-hg/firefox-hg.desktop b/firefox-hg/firefox-hg.desktop
deleted file mode 100644
index 124ba28..0000000
--- a/firefox-hg/firefox-hg.desktop
+++ /dev/null
@@ -1,84 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=firefox-hg %u
-Icon=firefox-hg
-Type=Application
-Terminal=false
-MultipleArgs=false
-Name=Firefox (hg)
-Name[bn]=ফায়ারফক্স3
-Name[eo]=Fajrovulpo (hg)
-Name[fi]=Firefox (hg)
-Name[pa]=ਫਾਇਰਫੋਕਸ3
-Name[tg]=Рӯбоҳи оташин3
-GenericName=Web Browser
-GenericName[af]=Web Blaaier
-GenericName[ar]=متصفح ويب
-GenericName[az]=Veb Səyyahı
-GenericName[bg]=Браузър
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[br]=Furcher ar Gwiad
-GenericName[bs]=WWW Preglednik
-GenericName[ca]=Fullejador web
-GenericName[cs]=WWW prohlížeč
-GenericName[cy]=Porydd Gwe
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής Ιστού
-GenericName[eo]=TTT-legilo
-GenericName[es]=Navegador web
-GenericName[et]=Veebilehitseja
-GenericName[eu]=Web arakatzailea
-GenericName[fa]=مرورگر وب
-GenericName[fi]=WWW-selain
-GenericName[fo]=Alnótsfar
-GenericName[fr]=Navigateur web
-GenericName[gl]=Navegador Web
-GenericName[he]=דפדפן ××™× ×˜×¨× ×˜
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hr]=Web preglednik
-GenericName[hu]=Webböngésző
-GenericName[is]=Vafri
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[ko]=웹 ë¸Œë¼ìš°ì €
-GenericName[lo]=ເວັບບຣາວເຊີ
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Web Pārlūks
-GenericName[mk]=Прелистувач на Интернет
-GenericName[mn]=Веб-Хөтөч
-GenericName[nb]=Nettleser
-GenericName[nds]=Nettkieker
-GenericName[nl]=Webbrowser
-GenericName[nn]=Nettlesar
-GenericName[nso]=Seinyakisi sa Web
-GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
-GenericName[pl]=PrzeglÄ…darka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador Web
-GenericName[ro]=Navigator de web
-GenericName[ru]=Веб-браузер
-GenericName[se]=Fierpmádatlogan
-GenericName[sk]=Webový prehliadač
-GenericName[sl]=Spletni brskalnik
-GenericName[sr]=Веб претраживач
-GenericName[sr@Latn]=Veb pretraživač
-GenericName[ss]=Ibrawuza yeWeb
-GenericName[sv]=Webbläsare
-GenericName[ta]=வலை உலாவி
-GenericName[tg]=Тафсиргари вэб
-GenericName[th]=เว็บบราวเซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[uz]=Веб-браузер
-GenericName[ven]=Buronza ya Webu
-GenericName[vi]=Trình duyệt Web
-GenericName[wa]=Betchteu waibe
-GenericName[xh]=Umkhangeli zincwadi we Web
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_TW]=ç¶²é ç€è¦½å™¨
-GenericName[zu]=Umcingi we-Web
-MimeType=text/html
-StartupNotify=true
-Categories=Application;Network;
-
diff --git a/firefox-hg/firefox.install b/firefox-hg/firefox.install
deleted file mode 100644
index 9a7af59..0000000
--- a/firefox-hg/firefox.install
+++ /dev/null
@@ -1,21 +0,0 @@
-
-post_install() {
- echo ">>> Firefox (hg) is installed in "
- echo ">>> /usr/lib/firefox-hg/"
- echo ">>>"
- echo ">>> Start Firefox (hg) by running the command: "
- echo ">>> 'firefox-hg'"
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- /bin/true
-}
-
-op=$1
-shift
-
-$op $*
diff --git a/firefox-hg/firefox.sh b/firefox-hg/firefox.sh
deleted file mode 100644
index 7ca384c..0000000
--- a/firefox-hg/firefox.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-exec /usr/lib/firefox-hg/firefox $*
-
diff --git a/firefox-hg/mozconfig b/firefox-hg/mozconfig
deleted file mode 100644
index 4a2b843..0000000
--- a/firefox-hg/mozconfig
+++ /dev/null
@@ -1,43 +0,0 @@
-. $topsrcdir/browser/config/mozconfig
-
-ac_add_options --prefix=/usr
-ac_add_options --libdir=/usr/lib
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-jpeg
-ac_add_options --with-system-zlib
-ac_add_options --with-system-bz2
-#ac_add_options --with-system-png
-ac_add_options --enable-system-lcms
-#ac_add_options --enable-system-hunspell
-#ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-cairo
-ac_add_options --with-pthreads
-ac_add_options --enable-strip
-ac_add_options --disable-tests
-ac_add_options --disable-mochitest
-ac_add_options --disable-installer
-ac_add_options --disable-debug
-ac_add_options --enable-optimize
-#ac_add_options --enable-optimize="#CFLAGS#"
-ac_add_options --enable-default-toolkit=cairo-gtk2
-ac_add_options --enable-pango
-ac_add_options --enable-svg
-ac_add_options --enable-canvas
-ac_add_options --disable-xprint
-ac_add_options --disable-javaxpcom
-ac_add_options --disable-crashreporter
-ac_add_options --enable-safe-browsing
-ac_add_options --enable-startup-notification
-ac_add_options --disable-necko-wifi
-
-#ac_add_options --with-branding=browser/branding/nightly
-
-mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/ff-opt-obj
-#mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) $(MOZ_OBJDIR)/_profile/pgo/profileserver.py'
-
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-mk_add_options BUILD_OFFICIAL=1
-mk_add_options MOZILLA_OFFICIAL=1
-