summaryrefslogtreecommitdiffstats
path: root/firefox-nightly/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-05-05 14:03:15 +0200
committerFlorian Pritz <f-p@gmx.at>2009-05-05 14:03:15 +0200
commitaed08f01f8e6b0de458181975c14efe8b89c418f (patch)
tree3f73ca7d67c1098486ec780134d93a7888d0af0f /firefox-nightly/PKGBUILD
parentd0233c8e0b47beedff2c9ece475db86e1a6a9653 (diff)
downloadaur-packages-aed08f01f8e6b0de458181975c14efe8b89c418f.tar.gz
aur-packages-aed08f01f8e6b0de458181975c14efe8b89c418f.tar.xz
forgot to update some time
Diffstat (limited to 'firefox-nightly/PKGBUILD')
-rw-r--r--firefox-nightly/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/firefox-nightly/PKGBUILD b/firefox-nightly/PKGBUILD
new file mode 100644
index 0000000..9d84ecf
--- /dev/null
+++ b/firefox-nightly/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: coderoar <coderoar@gmail.com>
+
+arch=('i686' 'x86_64')
+depends=('desktop-file-utils' 'libxt' 'mime-types' 'nss' 'shared-mime-info')
+license=('MPL' 'GPL' 'LGPL')
+md5sums=('940233ba24a2de784ea6c610872f01e4' '488e66c72fb678d2b99a22fe87bc5974' '')
+pkgdesc='Standalone web browser from mozilla.org, nightly build.'
+pkgname=firefox-nightly
+pkgrel=1
+pkgver=3.6a1pre
+if [[ ${CARCH} = 'i686' ]]; then
+ source=('firefox-nightly.desktop' 'firefox-nightly-safe.desktop' 'ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/firefox-3.6a1pre.en-US.linux-i686.tar.bz2')
+else
+ source=('firefox-nightly.desktop' 'firefox-nightly-safe.desktop' 'ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/firefox-3.6a1pre.en-US.linux-x86_64.tar.bz2')
+fi
+url='http://www.mozilla.org/projects/firefox'
+
+build() {
+ cd ${srcdir}
+
+# uncomment this line to remove them if you want
+# rm -rf firefox/{extensions,plugins,searchplugins} || return 1
+
+ mkdir -p ${pkgdir}/{usr/{bin,share/{applications,pixmaps}},opt} || return 1
+ cp -r firefox ${pkgdir}/opt/firefox-${pkgver} || return 1
+
+ ln -s /opt/firefox-${pkgver}/firefox ${pkgdir}/usr/bin/firefox-nightly || return 1
+ install -m644 ${srcdir}/{firefox-nightly.desktop,firefox-nightly-safe.desktop} ${pkgdir}/usr/share/applications/ || return 1
+ install -m644 ${srcdir}/firefox/icons/mozicon128.png ${pkgdir}/usr/share/pixmaps/${pkgname}-icon.png || return 1
+}