summaryrefslogtreecommitdiffstats
path: root/firefox-qt
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-08-22 19:33:54 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-08-22 19:34:46 +0200
commite3c21a8456cf86bf955262b71af2bfe4afd25ccc (patch)
treebe697394b748089d193ba3d78a56a8c0efc96345 /firefox-qt
parent14264bcaec8be85c4c7c6440bfa6ae3d3c449d8c (diff)
downloadaur-packages-e3c21a8456cf86bf955262b71af2bfe4afd25ccc.tar.gz
aur-packages-e3c21a8456cf86bf955262b71af2bfe4afd25ccc.tar.xz
mass commit everything
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'firefox-qt')
-rw-r--r--firefox-qt/PKGBUILD54
-rw-r--r--firefox-qt/browser-defaulturls.patch26
-rw-r--r--firefox-qt/firefox-qt-safe.desktop11
-rw-r--r--firefox-qt/firefox-qt.desktop81
-rw-r--r--firefox-qt/firefox-version.patch11
-rw-r--r--firefox-qt/firefox.install12
-rw-r--r--firefox-qt/mozconfig35
-rw-r--r--firefox-qt/mozilla-firefox-1.0-lang.patch12
8 files changed, 242 insertions, 0 deletions
diff --git a/firefox-qt/PKGBUILD b/firefox-qt/PKGBUILD
new file mode 100644
index 0000000..f8b69ae
--- /dev/null
+++ b/firefox-qt/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id: PKGBUILD 73155 2010-03-23 10:23:39Z jgc $
+# Contributor: Jakub Schmidtke <sjakub@gmail.com>
+
+pkgname=firefox-qt
+pkgver=3.6.3
+pkgrel=2
+_xulver=1.9.2.3
+pkgdesc="Standalone web browser from mozilla.org"
+arch=(i686 x86_64)
+license=('MPL' 'GPL' 'LGPL')
+depends=("xulrunner-qt=${_xulver}" 'desktop-file-utils')
+makedepends=('zip' 'pkgconfig' 'diffutils' 'qt' 'python' 'wireless_tools' 'patch')
+replaces=('firefox3')
+install=firefox.install
+url="http://www.mozilla.org/projects/firefox"
+source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}.source.tar.bz2
+ mozconfig
+ firefox-qt.desktop
+ firefox-qt-safe.desktop
+ mozilla-firefox-1.0-lang.patch
+ browser-defaulturls.patch
+ firefox-version.patch)
+
+md5sums=('5e4541ab23084b7b14ba228291ce2688'
+ 'c3a62a73278a069fff0f16e391f79670'
+ '55d930b5bec8778d222d0a7946bdd676'
+ 'a2958ad90a26e16f66508d91b43d2683'
+ 'bd5db57c23c72a02a489592644f18995'
+ '8bf21158090c89fd834bb711aae0602e'
+ '78b9b0bded64cff20a73d8a3ad3fc38b')
+
+build() {
+ cd "${srcdir}/mozilla-1.9.2"
+ patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch"
+ patch -Np0 -i "${srcdir}/browser-defaulturls.patch"
+ patch -Np1 -i "${srcdir}/firefox-version.patch"
+
+ cp "${srcdir}/mozconfig" .mozconfig
+ unset CFLAGS
+ unset CXXFLAGS
+
+ export LDFLAGS="-Wl,-rpath,/opt/ffqt/lib/firefox-3.6"
+
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
+ make -j1 DESTDIR="${pkgdir}" install || return 1
+
+ rm -f ${pkgdir}/opt/ffqt/lib/firefox-3.6/libjemalloc.so
+
+ install -m755 -d ${pkgdir}/opt/ffqt/share/applications
+ install -m755 -d ${pkgdir}/opt/ffqt/share/pixmaps
+ install -m644 ${srcdir}/mozilla-1.9.2/browser/branding/unofficial/default48.png ${pkgdir}/opt/ffqt/share/pixmaps/firefox.png || return 1
+ install -m644 ${srcdir}/firefox-qt.desktop ${pkgdir}/opt/ffqt/share/applications/ || return 1
+ install -m644 ${srcdir}/firefox-qt-safe.desktop ${pkgdir}/opt/ffqt/share/applications/ || return 1
+}
diff --git a/firefox-qt/browser-defaulturls.patch b/firefox-qt/browser-defaulturls.patch
new file mode 100644
index 0000000..a7bb845
--- /dev/null
+++ b/firefox-qt/browser-defaulturls.patch
@@ -0,0 +1,26 @@
+--- browser/branding/unofficial/locales/browserconfig.properties~ 2009-06-13 17:04:42.000000000 +0200
++++ browser/branding/unofficial/locales/browserconfig.properties 2009-06-13 17:05:28.000000000 +0200
+@@ -1,3 +1,3 @@
+ # Do NOT localize or otherwise change these values
+-browser.startup.homepage=http://www.mozilla.org/projects/namoroka/
++browser.startup.homepage=http://www.google.com/firefox
+
+--- browser/branding/unofficial/pref/firefox-branding.js~ 2009-06-13 16:57:53.000000000 +0200
++++ browser/branding/unofficial/pref/firefox-branding.js 2009-06-13 16:59:17.000000000 +0200
+@@ -1,5 +1,5 @@
+-pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/");
+-pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
++pref("startup.homepage_override_url","http://www.mozilla.com/%APP%/%VERSION%/whatsnew/");
++pref("startup.homepage_welcome_url","http://www.mozilla.com/%APP%/%VERSION%/firstrun/");
+ // The time interval between checks for a new version (in seconds)
+ // nightly=8 hours, official=24 hours
+ pref("app.update.interval", 28800);
+@@ -11,7 +11,7 @@
+ pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/");
+
+ // Release notes URL
+-pref("app.releaseNotesURL", "http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/");
++pref("app.releaseNotesURL", "http://www.mozilla.com/%APP%/%VERSION%/releasenotes/");
+
+ // Search codes belong only in builds with official branding
+ pref("browser.search.param.yahoo-fr", "");
diff --git a/firefox-qt/firefox-qt-safe.desktop b/firefox-qt/firefox-qt-safe.desktop
new file mode 100644
index 0000000..6b1d0a6
--- /dev/null
+++ b/firefox-qt/firefox-qt-safe.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=/opt/ffqt/bin/firefox -safe-mode %u
+Icon=/opt/ffqt/share/pixmaps/firefox-qt
+Type=Application
+Terminal=false
+MultipleArgs=false
+Name=Firefox Qt - Safe Mode
+GenericName=Web Browser - Safe Mode
+StartupNotify=false
+Categories=Application;Network;
diff --git a/firefox-qt/firefox-qt.desktop b/firefox-qt/firefox-qt.desktop
new file mode 100644
index 0000000..0547f9e
--- /dev/null
+++ b/firefox-qt/firefox-qt.desktop
@@ -0,0 +1,81 @@
+[Desktop Entry]
+Exec=/opt/ffqt/bin/firefox %u
+Icon=/opt/ffqt/share/pixmaps/firefox-qt
+Type=Application
+Terminal=false
+Name=Firefox Qt
+Name[bn]=ফায়ারফক্স3
+Name[eo]=Fajrovulpo3
+Name[fi]=Firefox3
+Name[pa]=ਫਾਇਰਫੋਕਸ3
+Name[tg]=Рӯбоҳи оташин3
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Qt Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+MimeType=text/html;
+StartupNotify=true
+Categories=Network;WebBrowser;
diff --git a/firefox-qt/firefox-version.patch b/firefox-qt/firefox-version.patch
new file mode 100644
index 0000000..5f35d85
--- /dev/null
+++ b/firefox-qt/firefox-version.patch
@@ -0,0 +1,11 @@
+--- mozilla-1.9.1/browser/installer/Makefile.in.ver 2009-07-18 13:32:35.000000000 +0200
++++ mozilla-1.9.1/browser/installer/Makefile.in 2009-07-18 13:33:12.000000000 +0200
+@@ -43,6 +43,8 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++MOZ_APP_VERSION="qt-3.6"
++
+ NO_PKG_FILES = \
+ $(MOZ_APP_NAME)-config \
+ $(MOZ_APP_NAME)-bin.elf \
diff --git a/firefox-qt/firefox.install b/firefox-qt/firefox.install
new file mode 100644
index 0000000..7463b6e
--- /dev/null
+++ b/firefox-qt/firefox.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
diff --git a/firefox-qt/mozconfig b/firefox-qt/mozconfig
new file mode 100644
index 0000000..793d9ee
--- /dev/null
+++ b/firefox-qt/mozconfig
@@ -0,0 +1,35 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/opt/ffqt
+ac_add_options --libdir=/opt/ffqt/lib
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-png
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --enable-optimize
+ac_add_options --disable-installer
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-qt
+ac_add_options --disable-xprint
+ac_add_options --enable-strip
+ac_add_options --enable-pango
+ac_add_options --disable-system-cairo
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --enable-startup-notification
+ac_add_options --enable-libxul
+ac_add_options --disable-crashreporter
+ac_add_options --with-libxul-sdk=/opt/ffqt/lib/xulrunner-devel-qt-1.9.2
+ac_add_options --enable-safe-browsing
+#ac_add_options --with-branding=browser/branding/unofficial
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export USE_SHORT_LIBNAME=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+mk_add_options USE_SHORT_LIBNAME=1
diff --git a/firefox-qt/mozilla-firefox-1.0-lang.patch b/firefox-qt/mozilla-firefox-1.0-lang.patch
new file mode 100644
index 0000000..f0f7325
--- /dev/null
+++ b/firefox-qt/mozilla-firefox-1.0-lang.patch
@@ -0,0 +1,12 @@
+--- mozilla/browser/app/profile/firefox.js.lang 2005-01-13 15:32:03.509282726 +0100
++++ mozilla/browser/app/profile/firefox.js 2005-01-13 15:33:40.220914789 +0100
+@@ -253,6 +253,9 @@
+ pref("font.language.group", "chrome://global/locale/intl.properties");
+ pref("intl.menuitems.alwaysappendaccesskeys","chrome://global/locale/intl.properties");
+
++// Use LANG environment variable to choose locale
++pref("intl.locale.matchOS", true);
++
+ // 0=lines, 1=pages, 2=history , 3=text size
+ pref("mousewheel.withcontrolkey.action",3);
+ pref("mousewheel.withshiftkey.action",2);