summaryrefslogtreecommitdiffstats
path: root/foo2zjs
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-01 11:45:31 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-01 11:48:26 +0100
commit84f2ca8a80d6a9bc12020bcd21c836c74c5240da (patch)
treea56106f8c1540c99b51b5d769e90934cdabff793 /foo2zjs
parent27a87d5d108490d90b6be4e0003bcd2f6320b3ce (diff)
downloadaur-packages-84f2ca8a80d6a9bc12020bcd21c836c74c5240da.tar.gz
aur-packages-84f2ca8a80d6a9bc12020bcd21c836c74c5240da.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'foo2zjs')
-rw-r--r--foo2zjs/PKGBUILD58
-rw-r--r--foo2zjs/foo2zjs.install31
2 files changed, 37 insertions, 52 deletions
diff --git a/foo2zjs/PKGBUILD b/foo2zjs/PKGBUILD
index 43c0f94..55f4efb 100644
--- a/foo2zjs/PKGBUILD
+++ b/foo2zjs/PKGBUILD
@@ -1,31 +1,45 @@
-#Contributor: Stefan Lohmaier <noneus@noneus.de>
-#Contributor: hubert_star
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
pkgname=foo2zjs
-pkgver=20090424
-pkgrel=1
+pkgver=20091017
+pkgrel=3
pkgdesc="ZJStream Printer Drivers."
url="http://foo2zjs.rkkda.com/"
-license="GPL"
-depends=(psutils cups foomatic-db-engine)
-makedepends=(wget unzip patch vim)
-arch=(i686 x86_64)
+license=('GPL' 'custom')
+depends=('psutils' 'cups' 'foomatic-db-engine')
+makedepends=('unzip')
+conflicts=('foomatic-db')
+optdepends=('tix: required by hplj10xx_gui.tcl')
+arch=('i686' 'x86_64')
+options=('!emptydirs')
install=foo2zjs.install
-source=(makefile.patch)
-md5sums=('46042339057e6390c98236a9da8b01ee')
+source=(http://foo2zjs.rkkda.com/foo2zjs.tar.gz
+ foo2zjs-20091017-Makefile.patch
+ foo2zjs-20091017-udevfwld.patch)
+md5sums=('66413683916d4103d9bd1068b6fc2da6'
+ 'b5584b05d86f5587fa9d635956dd40c6'
+ 'd547a4f67d91f96a58ae2d565f54210e')
build() {
- cd "$srcdir"
- rm -f $pkgname.tar.gz
- wget "http://foo2zjs.rkkda.com/$pkgname.tar.gz"
- tar xfz $pkgname.tar.gz
- cd $pkgname
- patch -Np1 < ../makefile.patch || return 1
+ cd "${srcdir}/${pkgname}"
+ patch -Np1 -i ${srcdir}/foo2zjs-20091017-Makefile.patch || return 1
+ patch -Np1 -i ${srcdir}/foo2zjs-20091017-udevfwld.patch || return 1
+
make || return 1
+
./getweb all || return 1
- mkdir -p $pkgdir/usr/bin $pkgdir/etc/udev/rules.d $pkgdir/bin
- mkdir -p $pkgdir/usr/share/{foomatic/db/source/opt,/cups/model}
- make DESTDIR=$pkgdir install || return 1
- make DESTDIR=$pkgdir install-hotplug || return 1
-
- chmod 755 $pkgdir/usr/share/{foo2oak/icm,foo2hp/icm,foo2zjs/crd,foo2zjs/firmware,foo2zjs/icm,foo2hiperc/icm,foo2lava/icm,foo2xqx/firmware,foo2qpdl/crd,foo2qpdl/icm,foo2slx/icm}
+
+ install -d ${pkgdir}/usr/share/{applications,pixmaps,cups/model}
+ install -d ${pkgdir}/usr/share/foomatic/db/source/{driver,opt,printer}
+
+ make DESTDIR=${pkgdir} install install-udev
+
+ install -m755 getweb ${pkgdir}/usr/bin
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+md5sums=('303d7849dcbfbe89d12b1cf30351500d'
+ 'b5584b05d86f5587fa9d635956dd40c6'
+ 'd547a4f67d91f96a58ae2d565f54210e')
+sha1sums=('dd9256ae008e16e7b0f9eddce787ff13fe82c1f6'
+ '2154a87f53fc0b9a899511fcf3ed88eb38757427'
+ '12eb107069b61ff2d702dcfacb033d8e251da057')
diff --git a/foo2zjs/foo2zjs.install b/foo2zjs/foo2zjs.install
index 284f90b..e7a45ec 100644
--- a/foo2zjs/foo2zjs.install
+++ b/foo2zjs/foo2zjs.install
@@ -1,48 +1,19 @@
-# This is a default template for a post-install scriptlet. You can
-# remove any functions you don't need (and this header).
-
-# arg 1: the new package version
-pre_install() {
- /bin/true
-}
-
-# arg 1: the new package version
post_install() {
echo "-------------------------"
echo "You need to restart cups."
echo "-------------------------"
echo
- echo "You need to add your user to the group \"lp\"."
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- /bin/true
+ echo "You need to add your user to the lp group."
}
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
echo "-------------------------"
echo "You need to restart cups."
echo "-------------------------"
-
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
}
-# arg 1: the old package version
post_remove() {
echo "-------------------------"
echo "You need to restart cups."
echo "-------------------------"
-
}
-
-op=$1
-shift
-$op $*