summaryrefslogtreecommitdiffstats
path: root/gvim
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-03-01 20:37:34 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-03-01 20:39:39 +0100
commit351991ce3e10dfae9cf57e7cf79fcca9b01c585b (patch)
treeb04cbcb9316474b71c8ba8570661cacee07dcb2d /gvim
parentfb7ca9fcebda89c0f78dbc8200e35c4dd5d7c71d (diff)
downloadaur-packages-351991ce3e10dfae9cf57e7cf79fcca9b01c585b.tar.gz
aur-packages-351991ce3e10dfae9cf57e7cf79fcca9b01c585b.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'gvim')
-rw-r--r--gvim/PKGBUILD17
-rw-r--r--gvim/fetch_patches.sh23
2 files changed, 24 insertions, 16 deletions
diff --git a/gvim/PKGBUILD b/gvim/PKGBUILD
index 6d48d95..47e42f5 100644
--- a/gvim/PKGBUILD
+++ b/gvim/PKGBUILD
@@ -1,22 +1,25 @@
-# $Id$
+# $Id: PKGBUILD 53532 2009-10-02 06:43:56Z francois $
# Maintainer: tobias [ tobias at archlinux org ]
pkgname=gvim
_srcver=7.2
-_patchlevel=218
+_patchlevel=359
pkgver=${_srcver}.${_patchlevel}
-pkgrel=1
+pkgrel=2
pkgdesc="the vim text editor with advanced features enabled, such as a gui mode"
arch=(i686 x86_64)
license=('custom:vim')
url="http://www.vim.org"
-depends=("vim=${pkgver}" 'perl' 'python' 'libxt' 'desktop-file-utils' 'gtk2')
-makedepends=('pkgconfig' 'sed')
+depends=("vim>=${pkgver}" 'python' 'libxt' 'desktop-file-utils' 'gtk2')
+makedepends=('pkgconfig' 'sed' 'perl')
install=${pkgname}.install
source=(ftp://ftp.vim.org/pub/vim/unix/vim-${_srcver}.tar.bz2 \
ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-extra.tar.gz \
ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-lang.tar.gz \
${pkgname}.desktop fetch_patches.sh)
+md5sums=('f0901284b338e448bfd79ccca0041254' '35e04482f07c57221c9a751aaa3b8dac' \
+ 'd8884786979e0e520c112faf2e176f05' '2be104c0372dd6dae19cb7968c03cd4f' \
+ 'df640c8196c480795fdda24c817e0f11')
build()
{
@@ -31,8 +34,8 @@ build()
./configure --prefix=/usr --localstatedir=/var/lib/vim --mandir=/usr/share/man \
--with-compiledby=ArchLinux --with-features=big \
--with-x=yes --disable-gpm --enable-gui=gtk2 \
- --enable-multibyte --enable-cscope \
- --enable-perlinterp --enable-pythoninterp
+ --enable-multibyte --enable-cscope --enable-netbeans \
+ --enable-perlinterp --enable-pythoninterp --disable-rubyinterp
make || return 1
# install everything first ...
make VIMRCLOC=/etc DESTDIR=${pkgdir} install
diff --git a/gvim/fetch_patches.sh b/gvim/fetch_patches.sh
index 41b8564..56ba47b 100644
--- a/gvim/fetch_patches.sh
+++ b/gvim/fetch_patches.sh
@@ -1,8 +1,8 @@
# the external logic for pulling in patches
get_patches() {
- _patchdir=${startdir}/src/patches
- cd ${startdir}/src/vim$(echo ${_srcver} | sed "s/\.//")
+ _patchdir=${srcdir}/patches
+ cd ${srcdir}/vim$(echo ${_srcver} | sed "s/\.//")
if [ -d ${_patchdir} ]; then
rm -rf ${_patchdir}
echo -e "\tremove patches from old build"
@@ -19,9 +19,10 @@ get_patches() {
downloads=0
for _line in $(/bin/cat MD5SUMS); do
+ _file=$(echo $_line | cut -d ' ' -f3)
+ [ ${_file##*.} == "gz" ] && continue
downloads=$((${downloads} + 1))
_md5=$(echo $_line | cut -d ' ' -f1)
- _file=$(echo $_line | cut -d ' ' -f3)
if [ -f ${SRCDEST}/vim-${_srcver}/${_file} ]; then
echo -e "\thaving patch file:${_file}"
cp ${SRCDEST}/vim-${_srcver}/${_file} ./
@@ -44,17 +45,21 @@ get_patches() {
done
########
-
- rm *.gz
-
+
if [ ${downloads} != ${_patchlevel} ]; then
- echo -e "Number of patches does not match the patchlevel!\nEdit the PKGBUILD accordingly!"
- # return 1
+ echo ""
+ echo -e "\t\tWARNING!"
+ echo "You are not building the latest available version! A newer patchlevel"
+ echo "seems to be available. Please edit the PKGBUILD and add the latest"
+ echo "${downloads} as pkgrel number!"
+ echo ""
+ sleep 10
fi
IFS=$_OLDIFS
rm MD5SUMS
cd ${startdir}/src/vim$(echo ${_srcver} | sed "s/\.//")
- for _patch in $(/bin/ls ${_patchdir}); do
+ for _patchnum in $(/usr/bin/seq 1 ${_patchlevel}); do
+ _patch=${_srcver}.$(printf "%03d" ${_patchnum})
patch -Np0 -i ${_patchdir}/${_patch} || return 1
done
rm -rf ${_patchdir}