summaryrefslogtreecommitdiffstats
path: root/highlight
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-07-12 01:19:41 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-07-12 01:19:41 +0200
commit1c24ee62ce885a56c4228b2082e1bf9147eb1ad7 (patch)
tree10f9106eeeb22b1dea04b2619c1250887a2f71ad /highlight
parent617e469881ff930a6048c9048afe312fa2efaeb1 (diff)
parent36c7799369c841bb566e3339f01fa699de883c9f (diff)
downloadaur-packages-1c24ee62ce885a56c4228b2082e1bf9147eb1ad7.tar.gz
aur-packages-1c24ee62ce885a56c4228b2082e1bf9147eb1ad7.tar.xz
Merge branch 'master' of ssh://karif/~flo/git/aur
Diffstat (limited to 'highlight')
-rw-r--r--highlight/PKGBUILD13
-rw-r--r--highlight/make.patch17
2 files changed, 25 insertions, 5 deletions
diff --git a/highlight/PKGBUILD b/highlight/PKGBUILD
index 332fe2c..136b3d1 100644
--- a/highlight/PKGBUILD
+++ b/highlight/PKGBUILD
@@ -1,20 +1,23 @@
# Contributor: Jan Fader <jan.fader@web.de>
pkgname=highlight
-pkgver=2.16
+pkgver=3.1
+pkgver2=beta
pkgrel=1
pkgdesc="Highlight converts sourcecode to HTML, XHTML, RTF, LaTeX, TeX, XML and terminal escape sequences with coloured syntax highlighting. Language definitions, colour themes and indentation schemes are customizable"
url="http://www.andre-simon.de/doku/highlight/highlight.html"
license=('GPL')
arch=('i686' 'x86_64')
+depends=('boost')
install=
-source=(http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2)
-md5sums=('08f1429a6db258ab1a7eecbb4e0d44b2')
+source=(http://www.andre-simon.de/zip/$pkgname-$pkgver-$pkgver2.tar.bz2 make.patch)
+md5sums=('477cd7d61a6a8f665b5bdda4d75ba40f' '070f85f21eebf7afd89ab2a8d83e08d2')
build() {
- cd "$startdir/src/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver-$pkgver2"
+ patch -i $srcdir/make.patch
make || return 1
- make DESTDIR="$startdir/pkg" install
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:
diff --git a/highlight/make.patch b/highlight/make.patch
new file mode 100644
index 0000000..845ef4e
--- /dev/null
+++ b/highlight/make.patch
@@ -0,0 +1,17 @@
+--- src/highlight-3.1-beta/makefile 2010-06-03 18:08:17.000000000 +0200
++++ makefile 2010-06-22 22:12:42.000000000 +0200
+@@ -66,10 +66,10 @@
+ ${MKDIR} ${DESTDIR}${doc_dir}
+ ${MKDIR} ${DESTDIR}${conf_dir}
+ ${MKDIR} ${DESTDIR}${examples_dir} \
+- ${DESTDIR}${examples_dir}web_plugins \
+- ${DESTDIR}${examples_dir}web_plugins/dokuwiki \
+- ${DESTDIR}${examples_dir}web_plugins/movabletype \
+- ${DESTDIR}${examples_dir}web_plugins/wordpress \
++ ${DESTDIR}${examples_dir}plugins \
++ ${DESTDIR}${examples_dir}plugins/dokuwiki \
++ ${DESTDIR}${examples_dir}plugins/movabletype \
++ ${DESTDIR}${examples_dir}plugins/wordpress \
+ ${DESTDIR}${examples_dir}swig
+ ${MKDIR} ${DESTDIR}${data_dir} \
+ ${DESTDIR}${data_dir}themes \