summaryrefslogtreecommitdiffstats
path: root/mac
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2011-01-16 18:14:29 +0100
committerFlorian Pritz <bluewind@xssn.at>2011-01-16 18:14:29 +0100
commitb7197bccd0bc74c2082c935937b6d947c3ae756d (patch)
tree0c9e16df97cc8e04a990f17b5833e06daed810b7 /mac
parentda5fab0c7718320707f4755f3a46a6bb25086435 (diff)
downloadaur-packages-b7197bccd0bc74c2082c935937b6d947c3ae756d.tar.gz
aur-packages-b7197bccd0bc74c2082c935937b6d947c3ae756d.tar.xz
mass changes
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'mac')
-rw-r--r--mac/PKGBUILD23
-rw-r--r--mac/gcc4_errors.patch26
2 files changed, 49 insertions, 0 deletions
diff --git a/mac/PKGBUILD b/mac/PKGBUILD
new file mode 100644
index 0000000..6c40c9c
--- /dev/null
+++ b/mac/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: stonecrest <stonecrest[at]gmail[dot]com>
+
+pkgname=mac
+pkgver=3.99u4b5
+pkgrel=4
+pkgdesc="APE codec and decompressor"
+arch=('any')
+url="http://supermmx.org/linux/mac"
+license=('unknown')
+depends=()
+makedepends=('gcc' 'yasm' 'gcc-libs')
+source=(http://freshgen.googlecode.com/files/mac-3.99-u4-b5.tar.gz
+ gcc4_errors.patch)
+md5sums=('75716b342e07deae58f56a2522362006'
+ '771c071831871fe8803d139a56515e86')
+
+build() {
+ cd ${srcdir}/$pkgname-3.99-u4-b5
+ patch -Np1 -i ${srcdir}/gcc4_errors.patch || return 1
+ ./configure --prefix=/usr --enable-assembly=yes
+ make || return 1
+ make DESTDIR=${pkgdir} install
+}
diff --git a/mac/gcc4_errors.patch b/mac/gcc4_errors.patch
new file mode 100644
index 0000000..f7a0898
--- /dev/null
+++ b/mac/gcc4_errors.patch
@@ -0,0 +1,26 @@
+--- mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp 2006-06-01 13:00:57.000000000 +0400
++++ mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp 2009-06-15 00:31:36.081731282 +0400
+@@ -63,10 +63,10 @@
+ if (pData != NULL)
+ {
+ // parse out the information
+- char * pHeader = strstr(pData, APE_LINK_HEADER);
+- char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
+- char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
+- char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
++ const char * pHeader = strstr(pData, APE_LINK_HEADER);
++ const char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
++ const char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
++ const char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
+
+ if (pHeader && pImageFile && pStartBlock && pFinishBlock)
+ {
+@@ -81,7 +81,7 @@
+
+ // get the path
+ char cImageFile[MAX_PATH + 1]; int nIndex = 0;
+- char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
++ const char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
+ while ((*pImageCharacter != 0) && (*pImageCharacter != '\r') && (*pImageCharacter != '\n'))
+ cImageFile[nIndex++] = *pImageCharacter++;
+ cImageFile[nIndex] = 0;