summaryrefslogtreecommitdiffstats
path: root/mktorrent
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-09 21:30:29 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-09 21:30:29 +0100
commit4475726ac1437afeafa6b212688ff913683a9872 (patch)
treedf062bcd82a4841e2a9db7c07baf633a42a93555 /mktorrent
parent1ca076ad98100f78fd72d9eb99652d064408d6f9 (diff)
downloadaur-packages-4475726ac1437afeafa6b212688ff913683a9872.tar.gz
aur-packages-4475726ac1437afeafa6b212688ff913683a9872.tar.xz
mass add
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'mktorrent')
-rw-r--r--mktorrent/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/mktorrent/PKGBUILD b/mktorrent/PKGBUILD
new file mode 100644
index 0000000..62c1e44
--- /dev/null
+++ b/mktorrent/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Emil Renner Berthing <esmil@users.sourceforge.net>
+
+pkgname=mktorrent
+pkgver=1.0
+pkgrel=1
+pkgdesc='Simple command line utility to create BitTorrent metainfo files'
+arch=('i686' 'x86_64')
+url='http://mktorrent.sourceforge.net/'
+license='GPL'
+depends=('openssl')
+source=("http://downloads.sourceforge.net/mktorrent/mktorrent-${pkgver}.tar.gz")
+md5sums=('0da00209da96a0dc39efbb6eb5b4d8ff')
+
+build() {
+ cd ${srcdir}/mktorrent-${pkgver}
+
+ if [ "${CARCH}" = 'i686' ]; then
+ make DESTDIR=${pkgdir} PREFIX=/usr \
+ USE_PTHREADS=1 USE_OPENSSL=1 USE_LONG_OPTIONS=1 USE_LARGE_FILES=1 \
+ install
+ else
+ make DESTDIR=${pkgdir} PREFIX=/usr \
+ USE_PTHREADS=1 USE_OPENSSL=1 USE_LONG_OPTIONS=1 \
+ install
+ fi
+}