summaryrefslogtreecommitdiffstats
path: root/mozplugger
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-05-24 22:02:28 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-05-24 22:03:10 +0200
commit76b5704f46d3e59e41ed5883d23dd0d4aa818f4c (patch)
treea5adf840adb3093276c1fcf6b27135cecd935462 /mozplugger
parentb37bf77aa7e3354edc3831f7c9038d77da00fec2 (diff)
downloadaur-packages-76b5704f46d3e59e41ed5883d23dd0d4aa818f4c.tar.gz
aur-packages-76b5704f46d3e59e41ed5883d23dd0d4aa818f4c.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'mozplugger')
-rw-r--r--mozplugger/PKGBUILD31
-rw-r--r--mozplugger/mozplugger.install15
2 files changed, 46 insertions, 0 deletions
diff --git a/mozplugger/PKGBUILD b/mozplugger/PKGBUILD
new file mode 100644
index 0000000..4111b07
--- /dev/null
+++ b/mozplugger/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
+# Maintainer: fs4000 <matthias_dienstbier[at]yahoo[dot]de>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Todd Musall <tmusall@comcast.net>
+
+pkgname=mozplugger
+pkgver=1.13.3
+pkgrel=1
+pkgdesc="A Mozilla & Firefox multimedia plugin."
+arch=('i686' 'x86_64')
+url="http://mozplugger.mozdev.org"
+license=('GPL')
+depends=('m4' 'libx11')
+backup=('etc/mozpluggerrc')
+install=$pkgname.install
+source=(http://mozplugger.mozdev.org/files/$pkgname-$pkgver.tar.gz)
+md5sums=('42d2ac76d8bf6902743323fefd1801ba')
+
+build() {
+ cd $pkgname-$pkgver
+ make linux || return 1
+ make install root="$pkgdir"
+
+# This is the install code used while being in [community]
+# install -Dm755 mozplugger.so $pkgdir/usr/lib/mozilla/plugins/mozplugger.so
+# install -Dm644 mozpluggerrc $pkgdir/etc/mozpluggerrc
+# install -Dm755 mozplugger-helper $pkgdir/usr/bin/mozplugger-helper
+# install -Dm755 mozplugger-controller $pkgdir/usr/bin/mozplugger-controller
+# install -Dm755 mozplugger-linker $pkgdir/usr/bin/mozplugger-linker
+# install -Dm644 mozplugger.7 $pkgdir/usr/share/man/man7/mozplugger.7
+}
diff --git a/mozplugger/mozplugger.install b/mozplugger/mozplugger.install
new file mode 100644
index 0000000..55125d7
--- /dev/null
+++ b/mozplugger/mozplugger.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "
+==> You may need to delete your local ~/.mozilla/firefox/pluginreg.dat
+==> file for mozplugger to be enabled correctly after you update it.
+==> (It will get regenerated).
+==> To add more helpers, edit /etc/mozpluggerrc.
+==> The window name can be obtained using the utility xprop(1x).
+==> Type "xprop WM_CLASS" and click on a window."
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: