summaryrefslogtreecommitdiffstats
path: root/mplayer-vdpau-nogui
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 00:51:51 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 00:51:51 +0200
commit168118db7c4b1fd03547440cc5359a6d1a2f4fd4 (patch)
tree6f2521b0d50d70a396dc969e803d0d11f8d33eeb /mplayer-vdpau-nogui
parent702a3d5b092feb07625958a31dc225863319a10e (diff)
downloadaur-packages-168118db7c4b1fd03547440cc5359a6d1a2f4fd4.tar.gz
aur-packages-168118db7c4b1fd03547440cc5359a6d1a2f4fd4.tar.xz
mass update
Diffstat (limited to 'mplayer-vdpau-nogui')
-rw-r--r--mplayer-vdpau-nogui/PKGBUILD44
-rw-r--r--mplayer-vdpau-nogui/no_segfault_configure.diff11
2 files changed, 55 insertions, 0 deletions
diff --git a/mplayer-vdpau-nogui/PKGBUILD b/mplayer-vdpau-nogui/PKGBUILD
new file mode 100644
index 0000000..985a5b8
--- /dev/null
+++ b/mplayer-vdpau-nogui/PKGBUILD
@@ -0,0 +1,44 @@
+#Contributor: Reiser <metal@pop3.ru>
+
+pkgname=mplayer-vdpau-nogui
+pkgver=29542
+pkgrel=1
+pkgdesc="Famous multimedia player, dev. version, without its GUI and support for nvidia VDPAU"
+arch=('i686' 'x86_64')
+url="http://www.mplayerhq.hu/"
+license=('GPL')
+depends=('ttf-dejavu' 'nvidia' 'opencore-amr' 'libdvdnav>=4.1.3' 'lame' 'xvidcore')
+makedepends=('subversion')
+conflicts=('mplayer')
+provides=(mplayer=$pkgver)
+source=('no_segfault_configure.diff')
+md5sums=(ed962f7642ffcf2411ec6465fdc8c132)
+
+_svntrunk=svn://svn.mplayerhq.hu/mplayer/trunk
+_svnmod=mplayer-vdpau
+
+build() {
+ cd $srcdir
+ svn co $_svntrunk $_svnmod
+ cp -R $_svnmod $_svnmod-build
+ cd $_svnmod-build
+ patch -p1 < ../no_segfault_configure.diff
+
+ ./configure --prefix=/usr --confdir=/etc/mplayer --disable-gui \
+ --disable-runtime-cpudetection --enable-largefiles --enable-menu \
+ --disable-libdv --disable-aa --disable-liblzo --disable-speex \
+ --disable-fribidi --disable-arts --disable-esd --disable-smb --enable-dvdnav \
+ --disable-openal --disable-faad-internal --disable-jack --disable-directfb \
+ --disable-musepack --enable-libopencore_amrnb --enable-libopencore_amrwb \
+ --enable-vdpau --disable-libbs2b
+
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+ install -m0644 etc/{codecs.conf,input.conf,example.conf} $pkgdir/etc/mplayer
+ install -d $pkgdir/usr/share/mplayer/
+ ln -s /usr/share/fonts/TTF/DejaVuSans.ttf $pkgdir/usr/share/mplayer/subfont.ttf
+
+ cd ../
+ rm -rf ./$_svnmod-build
+}
diff --git a/mplayer-vdpau-nogui/no_segfault_configure.diff b/mplayer-vdpau-nogui/no_segfault_configure.diff
new file mode 100644
index 0000000..2dd5fe4
--- /dev/null
+++ b/mplayer-vdpau-nogui/no_segfault_configure.diff
@@ -0,0 +1,11 @@
+--- a/configure.old 2008-11-15 23:27:59.000000000 +0100
++++ b/configure 2008-11-15 23:28:26.000000000 +0100
+@@ -79,7 +79,7 @@
+ }
+
+ tmp_run() {
+- "$TMPEXE" >> "$TMPLOG" 2>&1
++ :
+ }
+
+ # Display error message, flushes tempfile, exit