summaryrefslogtreecommitdiffstats
path: root/mplayer-vdpau-nogui
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-01 11:45:31 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-01 11:48:26 +0100
commit84f2ca8a80d6a9bc12020bcd21c836c74c5240da (patch)
treea56106f8c1540c99b51b5d769e90934cdabff793 /mplayer-vdpau-nogui
parent27a87d5d108490d90b6be4e0003bcd2f6320b3ce (diff)
downloadaur-packages-84f2ca8a80d6a9bc12020bcd21c836c74c5240da.tar.gz
aur-packages-84f2ca8a80d6a9bc12020bcd21c836c74c5240da.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'mplayer-vdpau-nogui')
-rw-r--r--mplayer-vdpau-nogui/PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/mplayer-vdpau-nogui/PKGBUILD b/mplayer-vdpau-nogui/PKGBUILD
index 4772b27..f519722 100644
--- a/mplayer-vdpau-nogui/PKGBUILD
+++ b/mplayer-vdpau-nogui/PKGBUILD
@@ -1,7 +1,7 @@
#Contributor: Reiser <metal@pop3.ru>
pkgname=mplayer-vdpau-nogui
-pkgver=29583
+pkgver=29794
pkgrel=1
pkgdesc="Famous multimedia player, dev. version, without its GUI and support for nvidia VDPAU"
arch=('i686' 'x86_64')
@@ -18,17 +18,29 @@ _svntrunk=svn://svn.mplayerhq.hu/mplayer/trunk
_svnmod=mplayer-vdpau
build() {
+
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
+
cd $srcdir
svn co $_svntrunk $_svnmod
cp -R $_svnmod $_svnmod-build
cd $_svnmod-build
patch -p1 < ../no_segfault_configure.diff
+# svn checkout svn://svn.ffmpeg.org/soc/wmapro wmapro
+# cp wmapro/wma* libavcodec
+# patch -p0 <wmapro/audioframesize.patch
+# patch -p0 <wmapro/mplayer.patch
+# patch -p0 <wmapro/wmapro_ffmpeg.patch
+#
+# cp -v wmapro/wma3dec.c wmapro/wma3data.h wmapro/wma3.h libavcodec
+
./configure --prefix=/usr --confdir=/etc/mplayer --disable-gui \
- --disable-runtime-cpudetection --enable-largefiles --enable-menu \
+ --enable-ossaudio --disable-alsa --disable-pulse --enable-pthreads \
+ --enable-runtime-cpudetection --enable-largefiles --enable-menu \
--disable-libdv --disable-aa --disable-liblzo --disable-speex \
--disable-fribidi --disable-arts --disable-esd --disable-smb --enable-dvdnav \
- --disable-openal --disable-faad-internal --disable-jack --disable-directfb \
+ --disable-openal --disable-faad-internal --disable-directfb \
--disable-musepack --enable-libopencore_amrnb --enable-libopencore_amrwb \
--enable-vdpau --disable-libbs2b