summaryrefslogtreecommitdiffstats
path: root/pacman-color
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-06 00:03:54 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-06 00:03:54 +0200
commitca8193d2ed3ccfb1b2bcb208a390eb4c4481a3a9 (patch)
tree6b6d0d91b0aa6817a5eb1bb06f7d9ea9a40e604d /pacman-color
parent65bf224cb276c6a1afb8c123fc81d316c57478fb (diff)
downloadaur-packages-ca8193d2ed3ccfb1b2bcb208a390eb4c4481a3a9.tar.gz
aur-packages-ca8193d2ed3ccfb1b2bcb208a390eb4c4481a3a9.tar.xz
add pacman-color
Diffstat (limited to 'pacman-color')
-rw-r--r--pacman-color/ChangeLog63
-rw-r--r--pacman-color/PKGBUILD34
-rw-r--r--pacman-color/color.conf45
-rw-r--r--pacman-color/pacman-color.install24
4 files changed, 166 insertions, 0 deletions
diff --git a/pacman-color/ChangeLog b/pacman-color/ChangeLog
new file mode 100644
index 0000000..9f90e44
--- /dev/null
+++ b/pacman-color/ChangeLog
@@ -0,0 +1,63 @@
+pacman-color 3.3.0-1
+- up to new version
+
+pacman-color 3.2.2-4
+- more safe callback function for delay messages
+
+pacman-color 3.2.2-3
+- little code cleanup
+- better suport for unicode (fix some issue with zh_CN translation)
+
+pacman-color 3.2.2-2
+- fix a memory leak
+
+pacman-color 3.2.2-1
+- clean and factorisation code
+- return to patch-base release (it is now more easier)
+
+pacman-color 3.2.1.b-1
+ news in 3.2.1.b
+ - fix version string in makefile, huh :)
+ - fix output "Optional Deps" in pakckage info
+
+pacman-color 3.2.1.a-1
+ news in 3.2.1.a
+ - up to new pacman's version
+ - fix a bug in Makefile
+
+pacman-color 3.2.0.a-1
+- up to new version
+ news in 3.2.0.a
+ - up to new pacman's version
+ - colors are defined in section [options]
+
+pacman-color 3.1.4.a-1
+- up to new version
+ news in 3.1.4.a
+ - up to new pacman's version
+
+pacman-color 3.1.3.a-1
+- up to new version
+ news in 3.1.3.a
+ - up to new pacman's version
+
+pacman-color 3.1.2.a-1
+- up to new version
+ news in 3.1.2.a
+ - up to new pacman's version
+
+pacman-color 3.1.1.b-1
+- up to new version
+ news in 3.1.1.b
+ - add comments in color.conf
+ - remove script with an alias
+ - pkg size in targets list is coloured
+ - default color for 'debug:' and size is dark gray
+ - --sync operation shows the size of packages in the 'remove:' list,
+ like in 'targets:' list (option ShowSize)
+ - --remove operation shows the size of packages and total removed size,
+ like --sync operation
+ - new ascii art in info about version
+
+pacman-color 3.1.1.a-1
+- initial release
diff --git a/pacman-color/PKGBUILD b/pacman-color/PKGBUILD
new file mode 100644
index 0000000..f72c1ce
--- /dev/null
+++ b/pacman-color/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: vogo <vojtech.gondzala@gmail.com>
+pkgname=pacman-color
+pkgver=3.3.0
+pkgrel=1
+pkgdesc="Command-line frontend for libalpm aka pacman with color patch"
+arch=('i686' 'x86_64')
+url="http://vogo.unas.cz/pacman-color.html"
+license=('GPL')
+depends=('pacman=3.3.0')
+makedepends=('patch')
+install="pacman-color.install"
+backup=('etc/pacman.d/color.conf')
+source=(ftp://ftp.archlinux.org/other/pacman/pacman-$pkgver.tar.gz
+ http://vogo.unas.cz/pacman-color/$pkgname-$pkgver-${pkgrel}_patch.tar.gz
+ color.conf)
+
+md5sums=('945b95633cc7340efb4d4564b463c6b1'
+ '4dbd382a9197a274bca39f03188ce699'
+ 'fd5087a5f6cf95ca0175ddb9fd257505')
+
+build() {
+ cd $startdir/src/pacman-$pkgver
+ patch -p1 -i ../pacman-color.patch || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-doc
+ make || return 1
+
+ # install pacman-color
+ install -Dm755 $startdir/src/pacman-$pkgver/src/pacman/.libs/pacman \
+ $startdir/pkg/usr/bin/pacman-color
+
+ # install color.conf
+ install -Dm644 $startdir/src/color.conf \
+ $startdir/pkg/etc/pacman.d/color.conf
+}
diff --git a/pacman-color/color.conf b/pacman-color/color.conf
new file mode 100644
index 0000000..2115753
--- /dev/null
+++ b/pacman-color/color.conf
@@ -0,0 +1,45 @@
+# Configuration for pacman-color
+# ------------------------------
+# in default are all colors "intensive",
+# it looks much better on black backround
+#
+# valid colors:
+# black
+# red
+# green
+# yellow
+# blue
+# magenta
+# cyan
+# white
+# gray
+# intensive red
+# intensive green
+# intensive yellow
+# intensive blue
+# intensive magenta
+# intensive cyan
+# intensive white
+# intensive foreground
+# none
+
+# error: prefix, fail, Remove (?):, MISSING
+#Red = intensive red
+
+# done, success, pkg version, Not Modified
+#Green = intensive green
+
+# warning: prefix, Targets (?):, MODIFIED
+#Yellow = intensive yellow
+
+# :: prefix, pkg group, counter in install proces
+#Blue = intensive blue
+
+# repo name, package file name
+#Magenta = intensive magenta
+
+# url
+#Cyan = intensive cyan
+
+# messages with :: prefix, titles, etc
+#White = intensive foreground
diff --git a/pacman-color/pacman-color.install b/pacman-color/pacman-color.install
new file mode 100644
index 0000000..e8fb3de
--- /dev/null
+++ b/pacman-color/pacman-color.install
@@ -0,0 +1,24 @@
+# arg 1: the new package version
+post_install() {
+ post_upgrade
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+cat <<-EOM
+ you can change colors in '/etc/pacman.d/color.conf'
+
+ homepage: http://vogo.unas.cz/pacman-color.html
+EOM
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $* \ No newline at end of file