summaryrefslogtreecommitdiffstats
path: root/parched-git
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-01-17 11:59:51 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-01-17 11:59:54 +0100
commitcae7b71196612d90c08c39ba2bdc8d0d974aa412 (patch)
tree8a293f8e7396a57bdddd40599d2caaa44ea935d8 /parched-git
parente318f0b35c97d42347d4784cb5706e0f69d06532 (diff)
downloadaur-packages-cae7b71196612d90c08c39ba2bdc8d0d974aa412.tar.gz
aur-packages-cae7b71196612d90c08c39ba2bdc8d0d974aa412.tar.xz
mass updates/adds
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'parched-git')
-rw-r--r--parched-git/LICENSE24
-rw-r--r--parched-git/PKGBUILD35
2 files changed, 59 insertions, 0 deletions
diff --git a/parched-git/LICENSE b/parched-git/LICENSE
new file mode 100644
index 0000000..787374a
--- /dev/null
+++ b/parched-git/LICENSE
@@ -0,0 +1,24 @@
+Copyright 1996-2002 Software in the Public Interest, Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+SOFTWARE IN THE PUBLIC INTEREST, INC. BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the name of Software in the Public
+Interest, Inc. shall not be used in advertising or otherwise to promote the
+sale, use or other dealings in this Software without prior written
+authorization from Software in the Public Interest, Inc.
diff --git a/parched-git/PKGBUILD b/parched-git/PKGBUILD
new file mode 100644
index 0000000..1ba775f
--- /dev/null
+++ b/parched-git/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Laszlo Papp <djszapi at archlinux dot us>
+
+pkgname=parched-git
+pkgver=20100107
+pkgrel=1
+pkgdesc="A Pacman package and PKGBUILD parser module"
+arch=('i686' 'x86_64')
+url="http://github.com/sebnow/parched"
+license=('MIT')
+depends=('git' 'python')
+source=(LICENSE)
+md5sums=('31eccf56949504b5ce33110068948cf2')
+
+_gitroot="git://github.com/sebnow/parched.git"
+_gitname="parched"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to the parched git repository..."
+
+ if [ -d "$srcdir/$_gitname" ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ cd $srcdir/$_gitname
+ python setup.py build || return 1
+ python setup.py install --root=$pkgdir --optimize=1 || return 1
+ install -D -m644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}