summaryrefslogtreecommitdiffstats
path: root/perl-calendar-simple
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2011-10-23 22:01:53 +0200
committerFlorian Pritz <bluewind@xinu.at>2011-10-23 22:02:18 +0200
commitebc82b27288df5c58194083ead4a6e6de7f52d21 (patch)
tree30d4e874cc19a03dfc62a0ee7c6c5e6c9756d4ec /perl-calendar-simple
parent44c6e7dfa4967843b05ee961fd243f655ed31717 (diff)
downloadaur-packages-ebc82b27288df5c58194083ead4a6e6de7f52d21.tar.gz
aur-packages-ebc82b27288df5c58194083ead4a6e6de7f52d21.tar.xz
mass update (again :( )
Signed-off-by: Florian Pritz <bluewind@xinu.at>
Diffstat (limited to 'perl-calendar-simple')
-rw-r--r--perl-calendar-simple/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/perl-calendar-simple/PKGBUILD b/perl-calendar-simple/PKGBUILD
new file mode 100644
index 0000000..9b167a5
--- /dev/null
+++ b/perl-calendar-simple/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: AUR Perl <aurperl@juster.info>
+# Generator : CPANPLUS::Dist::Arch 1.10
+pkgname='perl-calendar-simple'
+pkgver='1.21'
+pkgrel='1'
+pkgdesc="Perl extension to create simple calendars"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Calendar-Simple'
+source=('http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/Calendar-Simple-1.21.tar.gz')
+md5sums=('8fbfe46c0a25d036ca100460fcd00223')
+
+build() {
+ PERL=/usr/bin/perl
+ DIST_DIR="${srcdir}/Calendar-Simple-1.21"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ { cd "$DIST_DIR" &&
+ $PERL Makefile.PL &&
+ make &&
+ make test &&
+ make install;
+ } || return 1;
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}