summaryrefslogtreecommitdiffstats
path: root/perl-compress-zlib/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-03-01 20:44:17 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-03-01 20:44:17 +0100
commit194af840fa8a77f1e763b2089a3014aa2d56fb1d (patch)
treea18e74c2daaf7c1b3530b6acfd81f59dc6eb1404 /perl-compress-zlib/PKGBUILD
parent669802590369b3f606079f0c5192752bd97f0497 (diff)
downloadaur-packages-194af840fa8a77f1e763b2089a3014aa2d56fb1d.tar.gz
aur-packages-194af840fa8a77f1e763b2089a3014aa2d56fb1d.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'perl-compress-zlib/PKGBUILD')
-rw-r--r--perl-compress-zlib/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/perl-compress-zlib/PKGBUILD b/perl-compress-zlib/PKGBUILD
new file mode 100644
index 0000000..ed9d427
--- /dev/null
+++ b/perl-compress-zlib/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=perl-compress-zlib
+_realname=Compress-Zlib
+pkgver=2.015
+pkgrel=1
+pkgdesc="Perl interface to zlib compression library"
+arch=(i686 x86_64)
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+#http://search.cpan.org/CPAN/authors/id/P/PM/PMQS/Compress-Zlib-2.015.tar.gz
+source=(http://www.cpan.org/authors/id/P/PM/PMQS/${_realname}-${pkgver}.tar.gz)
+replaces=('compress-zlib')
+provides=('compress-zlib')
+md5sums=('689ba2cc399b019d0bf76a0575c32947')
+
+build() {
+ cd ${srcdir}/${_realname}-${pkgver}
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=${pkgdir} || return 1
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}