summaryrefslogtreecommitdiffstats
path: root/pypanel
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
committerFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
commit3232f9d90114778cb8d38cc1bc8477435dc65259 (patch)
tree0eb9ffafbe853c84b9ad6b808d86a00d44668392 /pypanel
downloadaur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.gz
aur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.xz
initial commit
Diffstat (limited to 'pypanel')
-rw-r--r--pypanel/PKGBUILD23
-rw-r--r--pypanel/pypanel.patch11
2 files changed, 34 insertions, 0 deletions
diff --git a/pypanel/PKGBUILD b/pypanel/PKGBUILD
new file mode 100644
index 0000000..ff8a13b
--- /dev/null
+++ b/pypanel/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD,v 1.4 2008/05/05 00:33:39 BaSh Exp $
+# Maintainer: Jeff Mickey <j@codemac.net>
+# Contributor: Mr Green
+# Contributor: Jens Persson <xerxes2@gmail.com>
+
+pkgname=pypanel
+pkgver=2.4
+pkgrel=4
+pkgdesc="A lightweight panel/taskbar for X11 window managers written in python"
+arch=('i686' 'x86_64')
+url="http://pypanel.sourceforge.net/"
+license=('GPL')
+depends=('python' 'x-server' 'python-xlib' 'imlib2')
+makedepends=('python')
+source=("http://downloads.sourceforge.net/sourceforge/pypanel/PyPanel-$pkgver.tar.gz" "pypanel.patch")
+md5sums=('f1f9a2ed80be72ab36e748833618daba'
+ '12c947292859eac45f0648586d707b73')
+
+build() {
+ cd $startdir/src/PyPanel-$pkgver
+ patch < $startdir/pypanel.patch
+ python setup.py install --root=$startdir/pkg || return 1
+}
diff --git a/pypanel/pypanel.patch b/pypanel/pypanel.patch
new file mode 100644
index 0000000..0f8c338
--- /dev/null
+++ b/pypanel/pypanel.patch
@@ -0,0 +1,11 @@
+--- pypanel 2005-06-27 01:24:43.000000000 +0200
++++ pypanel.new 2008-08-30 22:25:14.000000000 +0200
+@@ -609,7 +609,7 @@
+ def updatePanel(self, root, win, panel):
+ #---------------------------------------
+ """ Redraw the panel """
+- tasks = panel[TASKS].tasks # all tasks
++ tasks = 0 #panel[TASKS].tasks # all tasks
+ visible = [] # visible tasks
+ curr_x = 0
+ space = P_WIDTH