summaryrefslogtreecommitdiffstats
path: root/python-otr/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2011-07-24 12:07:51 +0200
committerFlorian Pritz <bluewind@xssn.at>2011-07-24 12:07:51 +0200
commitb8c33ee22e78f48f52bfde7328d20efe73493149 (patch)
treeaf5a3a56a5094facb1c00472c0b1a3be7478eca2 /python-otr/PKGBUILD
parent9c7f68c9ab1ed52a5c4c2cec57c71b15d2209f52 (diff)
parent34e8f8d7edc734b88753ff7cb0443f8489b02ee8 (diff)
downloadaur-packages-b8c33ee22e78f48f52bfde7328d20efe73493149.tar.gz
aur-packages-b8c33ee22e78f48f52bfde7328d20efe73493149.tar.xz
Merge branch 'master' of git://git.server-speed.net/~flo/git/aur
Diffstat (limited to 'python-otr/PKGBUILD')
-rw-r--r--python-otr/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/python-otr/PKGBUILD b/python-otr/PKGBUILD
new file mode 100644
index 0000000..2aaf0ea
--- /dev/null
+++ b/python-otr/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Andre Klitzing <aklitzing () online () de>
+
+pkgname=python-otr
+pkgver=0.2.1.1
+pkgrel=1
+pkgdesc="Simple python bindings for OTR"
+arch=('i686' 'x86_64')
+url="http://python-otr.pentabarf.de"
+license=('GPL')
+depends=('libotr>=3.2.0' 'python')
+makedepends=('swig')
+conflicts=('pyotr')
+replaces=('pyotr')
+source=(http://$pkgname.pentabarf.de/releases/$pkgname-$pkgver.tar.gz)
+md5sums=('e753e6516d611d0c37a3fc785fb29b21')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+# Great python3 rebuild
+for file in $(find . -name '*.py' -print); do
+sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' "${file}"
+sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' "${file}"
+done
+
+ python2 setup.py build || return 1
+ python2 setup.py install --prefix=/usr --root=$pkgdir || return 1
+}
+