summaryrefslogtreecommitdiffstats
path: root/python-otr/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2012-12-16 11:51:24 +0100
committerFlorian Pritz <bluewind@xinu.at>2012-12-16 11:51:24 +0100
commitc6000c9d9949b3326fb82f02431899ab6774b960 (patch)
tree2453cd564b0f382f3d8ccd893df8ebe2e9aeda71 /python-otr/PKGBUILD
parent453f0f12918af35bd8e1e5f049841360f37d62e4 (diff)
downloadaur-packages-c6000c9d9949b3326fb82f02431899ab6774b960.tar.gz
aur-packages-c6000c9d9949b3326fb82f02431899ab6774b960.tar.xz
big cleanup
Diffstat (limited to 'python-otr/PKGBUILD')
-rw-r--r--python-otr/PKGBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/python-otr/PKGBUILD b/python-otr/PKGBUILD
deleted file mode 100644
index 2aaf0ea..0000000
--- a/python-otr/PKGBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Andre Klitzing <aklitzing () online () de>
-
-pkgname=python-otr
-pkgver=0.2.1.1
-pkgrel=1
-pkgdesc="Simple python bindings for OTR"
-arch=('i686' 'x86_64')
-url="http://python-otr.pentabarf.de"
-license=('GPL')
-depends=('libotr>=3.2.0' 'python')
-makedepends=('swig')
-conflicts=('pyotr')
-replaces=('pyotr')
-source=(http://$pkgname.pentabarf.de/releases/$pkgname-$pkgver.tar.gz)
-md5sums=('e753e6516d611d0c37a3fc785fb29b21')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
-
-# Great python3 rebuild
-for file in $(find . -name '*.py' -print); do
-sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' "${file}"
-sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' "${file}"
-done
-
- python2 setup.py build || return 1
- python2 setup.py install --prefix=/usr --root=$pkgdir || return 1
-}
-