summaryrefslogtreecommitdiffstats
path: root/python-otr
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2011-01-16 18:14:29 +0100
committerFlorian Pritz <bluewind@xssn.at>2011-01-16 18:14:29 +0100
commitb7197bccd0bc74c2082c935937b6d947c3ae756d (patch)
tree0c9e16df97cc8e04a990f17b5833e06daed810b7 /python-otr
parentda5fab0c7718320707f4755f3a46a6bb25086435 (diff)
downloadaur-packages-b7197bccd0bc74c2082c935937b6d947c3ae756d.tar.gz
aur-packages-b7197bccd0bc74c2082c935937b6d947c3ae756d.tar.xz
mass changes
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'python-otr')
-rw-r--r--python-otr/PKGBUILD29
-rw-r--r--python-otr/namcap.log3
2 files changed, 32 insertions, 0 deletions
diff --git a/python-otr/PKGBUILD b/python-otr/PKGBUILD
new file mode 100644
index 0000000..2aaf0ea
--- /dev/null
+++ b/python-otr/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Andre Klitzing <aklitzing () online () de>
+
+pkgname=python-otr
+pkgver=0.2.1.1
+pkgrel=1
+pkgdesc="Simple python bindings for OTR"
+arch=('i686' 'x86_64')
+url="http://python-otr.pentabarf.de"
+license=('GPL')
+depends=('libotr>=3.2.0' 'python')
+makedepends=('swig')
+conflicts=('pyotr')
+replaces=('pyotr')
+source=(http://$pkgname.pentabarf.de/releases/$pkgname-$pkgver.tar.gz)
+md5sums=('e753e6516d611d0c37a3fc785fb29b21')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+# Great python3 rebuild
+for file in $(find . -name '*.py' -print); do
+sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' "${file}"
+sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' "${file}"
+done
+
+ python2 setup.py build || return 1
+ python2 setup.py install --prefix=/usr --root=$pkgdir || return 1
+}
+
diff --git a/python-otr/namcap.log b/python-otr/namcap.log
new file mode 100644
index 0000000..49a0e7f
--- /dev/null
+++ b/python-otr/namcap.log
@@ -0,0 +1,3 @@
+PKGBUILD (python-otr) W: Missing Maintainer tag
+python-otr E: Dependency detected and not included (python2) from files ['usr/lib/python2.7/site-packages/_otr.so']
+python-otr W: Dependency included and not needed ('python')