summaryrefslogtreecommitdiffstats
path: root/rkhunter
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-09 21:17:30 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-09 21:17:30 +0100
commit499ce2ef257e1424d403175f8a9e6951348ccbdd (patch)
tree3020dcd26d0bba14ac09fea45cce1e9bc0a1dca5 /rkhunter
parent833dcdb1ed487375152a5a66dda0be87f07a066e (diff)
downloadaur-packages-499ce2ef257e1424d403175f8a9e6951348ccbdd.tar.gz
aur-packages-499ce2ef257e1424d403175f8a9e6951348ccbdd.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'rkhunter')
-rw-r--r--rkhunter/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/rkhunter/PKGBUILD b/rkhunter/PKGBUILD
new file mode 100644
index 0000000..a23cdb4
--- /dev/null
+++ b/rkhunter/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=rkhunter
+pkgver=1.3.4
+pkgrel=2
+pkgdesc="An easy-to-use tool which checks machines running UNIX (clones) for the presence of rootkits and other unwanted tools."
+arch=('i686' 'x86_64')
+url="http://rkhunter.sourceforge.net/"
+license=('GPL')
+depends=('bash' 'perl' 'wget')
+backup=(etc/rkhunter.conf)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+
+md5sums=('31eaacc4d01ad138d1a4283f105088e6')
+
+build() {
+ cd $srcdir/${pkgname}-${pkgver}
+
+ install -d -m755 $pkgdir/usr
+
+# fix installer for x86_64
+ sed -i -e "s/lib64/lib/g" installer.sh
+
+# install to /usr
+ ./installer.sh --layout custom $pkgdir/usr --striproot $pkgdir --install || return 1
+
+# use /etc instead of /usr/etc
+ sed -i -e "s#/usr/etc/rkhunter.conf#/etc/rkhunter.conf#g" $pkgdir/usr/bin/rkhunter
+ mv $pkgdir/usr/etc $pkgdir/
+ mv $pkgdir/usr/var $pkgdir/
+
+# tmp dir path fix
+ sed -i -e "s#/usr/var/lib/rkhunter/db#/var/lib/rkhunter/db#g" \
+ $pkgdir/etc/rkhunter.conf
+ sed -i -e "s#/usr/var/lib/rkhunter/tmp#/var/lib/rkhunter/tmp#g" \
+ $pkgdir/etc/rkhunter.conf
+
+# cleanup
+ rm -f $pkgdir/var/lib/rkhunter/tmp/{group,passwd}
+
+# we trust in udev
+ sed -i 's|^#ALLOWHIDDENDIR=/dev/.udev$|ALLOWHIDDENDIR=/dev/.udev|' $pkgdir/etc/rkhunter.conf
+}