summaryrefslogtreecommitdiffstats
path: root/savage2
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-09 21:30:29 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-09 21:30:29 +0100
commit4475726ac1437afeafa6b212688ff913683a9872 (patch)
treedf062bcd82a4841e2a9db7c07baf633a42a93555 /savage2
parent1ca076ad98100f78fd72d9eb99652d064408d6f9 (diff)
downloadaur-packages-4475726ac1437afeafa6b212688ff913683a9872.tar.gz
aur-packages-4475726ac1437afeafa6b212688ff913683a9872.tar.xz
mass add
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'savage2')
-rw-r--r--savage2/PKGBUILD59
-rw-r--r--savage2/s2editor.desktop11
-rw-r--r--savage2/s2mviewer.desktop11
-rw-r--r--savage2/savage2.desktop11
-rw-r--r--savage2/savage2.install18
-rw-r--r--savage2/savage2.launcher6
6 files changed, 116 insertions, 0 deletions
diff --git a/savage2/PKGBUILD b/savage2/PKGBUILD
new file mode 100644
index 0000000..90ffa23
--- /dev/null
+++ b/savage2/PKGBUILD
@@ -0,0 +1,59 @@
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+# Contributor: Ali H. Caliskan <ali.h.caliskan@gmail.com>
+# Contributor: Xavier <shiningxc[at]gmail[dot]com>
+
+pkgname=savage2
+pkgver=2.1.0.1
+pkgrel=1
+pkgdesc="Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008."
+arch=('i686' 'x86_64')
+url='http://savage2.com/'
+license=('custom: "Savage 2"')
+depends=('curl' 'mesa' 'libjpeg6' 'libpng' 'libxml2' 'speex')
+makedepends=('unzip')
+install=savage2.install
+source=("http://dl.heroesofnewerth.com/Savage2Install-$pkgver-$CARCH.bin" \
+'savage2.launcher' 'savage2.desktop' 's2editor.desktop' 's2mviewer.desktop')
+md5sums=('1ff815b9e864862d6d2cf6c635278b80'
+ 'fb03853628775f66689852a4125044e8'
+ 'a6957bb87da35d58df86d84a6dca1479'
+ 'b082a33fd1a580d3c70d80bbbfb0bffe'
+ '177155e2c2c4e1382ce9b1343e26b5c7')
+[ "$CARCH" = "x86_64" ] && md5sums[0]='78a5df8adc008e2c7493bab9f66a3092'
+
+build() {
+ cd $srcdir
+
+ # Create Destination Directory
+ install -d $pkgdir/opt/savage2
+
+ # Extract Game Data from Installer
+ unzip -o $srcdir/Savage2Install-$pkgver-$CARCH.bin
+
+ # Install Savage 2 Data
+ cp -r $srcdir/data/* $pkgdir/opt/savage2
+
+ # Install Game Launcher
+ install -D -m 755 $srcdir/savage2.launcher \
+ $pkgdir/usr/bin/savage2
+
+ # Install Desktop File (Game Client)
+ install -D -m 644 $srcdir/savage2.desktop \
+ $pkgdir/usr/share/applications/savage2.desktop
+
+ # Install Desktop File (Map Editor)
+ install -D -m 644 $srcdir/s2editor.desktop \
+ $pkgdir/usr/share/applications/s2editor.desktop
+
+ # Install Desktop File (Model Viewer)
+ install -D -m 644 $srcdir/s2mviewer.desktop \
+ $pkgdir/usr/share/applications/s2mviewer.desktop
+
+ # Install Icon
+ install -D -m 644 $srcdir/data/s2icon.png \
+ $pkgdir/usr/share/pixmaps/savage2.png
+
+ # Install License
+ install -D -m 644 $srcdir/data/license.txt \
+ $pkgdir/usr/share/licenses/$pkgname/license.txt
+}
diff --git a/savage2/s2editor.desktop b/savage2/s2editor.desktop
new file mode 100644
index 0000000..542b862
--- /dev/null
+++ b/savage2/s2editor.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Savage 2 Map Editor
+GenericName=Savage 2 Map Editor
+Comment=Map Editor for Savage 2: A Tortured Soul
+Exec=/usr/bin/savage2 "PushMod editor; Set host_autoExec StartClient"
+Icon=/usr/share/pixmaps/savage2.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/savage2/s2mviewer.desktop b/savage2/s2mviewer.desktop
new file mode 100644
index 0000000..fda6815
--- /dev/null
+++ b/savage2/s2mviewer.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Savage 2 Model Viewer
+GenericName=Savage 2 Model Viewer
+Comment=Model Viewer for Savage 2: A Tortured Soul
+Exec=/usr/bin/savage2 "PushMod modelviewer; Set host_autoExec StartClient"
+Icon=/usr/share/pixmaps/savage2.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/savage2/savage2.desktop b/savage2/savage2.desktop
new file mode 100644
index 0000000..e4e6094
--- /dev/null
+++ b/savage2/savage2.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Savage 2
+GenericName=Savage 2
+Comment=Savage 2: A Tortured Soul
+Exec=/usr/bin/savage2
+Icon=/usr/share/pixmaps/savage2.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/savage2/savage2.install b/savage2/savage2.install
new file mode 100644
index 0000000..5182e85
--- /dev/null
+++ b/savage2/savage2.install
@@ -0,0 +1,18 @@
+post_install() {
+ # Update runpath
+ cd /opt/savage2
+ ./savage2_update.bin --update-runpath
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo "==> To completely remove Savage 2, you will need to manually remove"
+ echo "==> /opt/savage2/ as root"
+}
+
+op=$1
+shift
+$op $*
diff --git a/savage2/savage2.launcher b/savage2/savage2.launcher
new file mode 100644
index 0000000..2e09363
--- /dev/null
+++ b/savage2/savage2.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/savage2"
+./savage2.bin $*
+exit $?
+