summaryrefslogtreecommitdiffstats
path: root/spampd/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-03-17 15:35:18 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-03-17 15:37:03 +0100
commit0e572da1852de5d350bfa95885600ea21f7343a9 (patch)
tree77d347447c470beb43fb370b40fa885cfe2a8423 /spampd/PKGBUILD
parent1dffac4f0cca7bc2f6bdc044e2805edff5be1c87 (diff)
downloadaur-packages-0e572da1852de5d350bfa95885600ea21f7343a9.tar.gz
aur-packages-0e572da1852de5d350bfa95885600ea21f7343a9.tar.xz
add spampd
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'spampd/PKGBUILD')
-rw-r--r--spampd/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
new file mode 100644
index 0000000..7e9ee9e
--- /dev/null
+++ b/spampd/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Florian "Bluewind" Pritz <flo@xssn.at>
+pkgname=spampd
+pkgver=2.30
+pkgrel=1
+pkgdesc="Spamassassin Proxy Daemon"
+arch=('any')
+url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
+license=('GPL')
+groups=()
+depends=('perl' 'perl-net-server')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=(etc/conf.d/spampd)
+options=()
+install=spampd.install
+source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
+ rc-script rc-config)
+noextract=()
+md5sums=('742c6f2cb75db54e59d044a8ee40445f'
+ '769f8a73765a0e7d235c9909aeb7ede9'
+ '637c2d93f76ba90d217e2418af64c9ec')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+ install -Dm755 spampd "$pkgdir/usr/bin/spampd"
+ install -Dm755 "$srcdir/rc-script" "$pkgdir/etc/rc.d/spampd"
+ install -Dm644 "$srcdir/rc-config" "$pkgdir/etc/conf.d/spampd"
+ install -Dm644 spampd.8.gz "$pkgdir/usr/share/man/man8/spampd.8.gz"
+ install -m644 changelog.txt "$startdir/ChangeLog"
+}
+
+# vim:set ts=2 sw=2 et: