summaryrefslogtreecommitdiffstats
path: root/spampd
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-08-16 23:01:00 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-08-16 23:01:00 +0200
commitf220a7df9bc9b607415b7975fce94517b035fc08 (patch)
treed366e4196b790ac4006792a32ce02b5b91289e3e /spampd
parent81323da4d1b434e3d0351f878f7eabc2563d3044 (diff)
downloadaur-packages-f220a7df9bc9b607415b7975fce94517b035fc08.tar.gz
aur-packages-f220a7df9bc9b607415b7975fce94517b035fc08.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'spampd')
-rw-r--r--spampd/PKGBUILD8
-rw-r--r--spampd/rc-config2
-rwxr-xr-xspampd/rc-script8
3 files changed, 8 insertions, 10 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
index f9c7abd..9a60407 100644
--- a/spampd/PKGBUILD
+++ b/spampd/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Florian "Bluewind" Pritz <flo@xssn.at>
pkgname=spampd
pkgver=2.30
-pkgrel=2
+pkgrel=3
pkgdesc="Spamassassin Proxy Daemon"
arch=('any')
url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
@@ -11,9 +11,6 @@ backup=(etc/conf.d/spampd)
install=spampd.install
source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
rc-script rc-config)
-md5sums=('742c6f2cb75db54e59d044a8ee40445f'
- '769f8a73765a0e7d235c9909aeb7ede9'
- '637c2d93f76ba90d217e2418af64c9ec')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -27,3 +24,6 @@ build() {
}
# vim:set ts=2 sw=2 et:
+md5sums=('742c6f2cb75db54e59d044a8ee40445f'
+ 'da17b3904a63252931cfb5f02e6a089f'
+ 'f452cf5046abc218bffb1e951485d8f0')
diff --git a/spampd/rc-config b/spampd/rc-config
index 61d9b57..f80d59c 100644
--- a/spampd/rc-config
+++ b/spampd/rc-config
@@ -1,2 +1,2 @@
# for information see manpage or spampd --help
-ARGS="--port=10025 --relayhost=127.0.0.1:10026 --tagall --rh --user spampd"
+ARGS="--port=10025 --relayhost=127.0.0.1:10026 --tagall --rh --user spampd --group spampd --pid=/home/spampd/spampd.pid"
diff --git a/spampd/rc-script b/spampd/rc-script
index 364e064..7c4b059 100755
--- a/spampd/rc-script
+++ b/spampd/rc-script
@@ -4,11 +4,9 @@
. /etc/rc.d/functions
. /etc/conf.d/spampd
-PID=$(cat /var/run/spampd.pid)
-
start() {
stat_busy "Starting Spampd"
- /usr/bin/spampd $ARGS
+ su -l spampd -c "/usr/bin/spampd $ARGS"
if [ $? -gt 0 ]; then
stat_fail
else
@@ -19,11 +17,11 @@ start() {
stop() {
stat_busy "Stopping Spampd"
- kill $PID
+ kill $(cat /home/spampd/spampd.pid)
if [ $? -gt 0 ]; then
stat_fail
else
- rm_daemon postfix
+ rm_daemon spampd
stat_done
fi
}