summaryrefslogtreecommitdiffstats
path: root/stfl
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-05-05 14:03:15 +0200
committerFlorian Pritz <f-p@gmx.at>2009-05-05 14:03:15 +0200
commitaed08f01f8e6b0de458181975c14efe8b89c418f (patch)
tree3f73ca7d67c1098486ec780134d93a7888d0af0f /stfl
parentd0233c8e0b47beedff2c9ece475db86e1a6a9653 (diff)
downloadaur-packages-aed08f01f8e6b0de458181975c14efe8b89c418f.tar.gz
aur-packages-aed08f01f8e6b0de458181975c14efe8b89c418f.tar.xz
forgot to update some time
Diffstat (limited to 'stfl')
-rw-r--r--stfl/ChangeLog10
-rw-r--r--stfl/PKGBUILD20
-rw-r--r--stfl/stfl-archlinux.patch52
3 files changed, 82 insertions, 0 deletions
diff --git a/stfl/ChangeLog b/stfl/ChangeLog
new file mode 100644
index 0000000..d838703
--- /dev/null
+++ b/stfl/ChangeLog
@@ -0,0 +1,10 @@
+* 2009-05-02 by pfleidi
+ - update to 0.20
+* 2008-02-09 by hrist
+ - update to 0.18
+* 2008-01-04 by hrist
+ - fixed the make command invocation (thanks to byte for the hint)
+* 2007-09-28 by hrist
+ - removed the patch (thanks to xio for the hint)
+* 2007-06-01 by STiAT
+ - made package build (patchfile global_stfl.patch)
diff --git a/stfl/PKGBUILD b/stfl/PKGBUILD
new file mode 100644
index 0000000..ad962de
--- /dev/null
+++ b/stfl/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Sven Pfleiderer <pfleidi@roothausen.de>
+pkgname=stfl
+pkgver=0.20
+pkgrel=1
+pkgdesc="It's a library which implements a curses-based widget set for text terminals."
+url="http://clifford.at/stfl/"
+license=('GPL')
+depends=('ncurses')
+arch=('i686' 'x86_64')
+options=('!libtool')
+source=(http://clifford.at/stfl/$pkgname-$pkgver.tar.gz stfl-archlinux.patch)
+md5sums=('905e0b8f81fe1b5c95b8d78f56df966b' '075895965f877ac1718096760dcd1e3f')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -p0 < $startdir/stfl-archlinux.patch || return 1
+ make prefix=/usr Makefile.deps || return 1
+ make prefix=/usr || return 1
+ make prefix=/usr DESTDIR=$startdir/pkg install
+}
diff --git a/stfl/stfl-archlinux.patch b/stfl/stfl-archlinux.patch
new file mode 100644
index 0000000..9161308
--- /dev/null
+++ b/stfl/stfl-archlinux.patch
@@ -0,0 +1,52 @@
+diff -Naur ./Makefile.cfg ../stfl-0.19-patched/Makefile.cfg
+--- ./Makefile.cfg 2007-09-20 01:24:14.000000000 +0200
++++ ../stfl-0.19-patched/Makefile.cfg 2008-09-16 02:05:58.000000000 +0200
+@@ -18,11 +18,11 @@
+ # MA 02110-1301 USA
+ #
+
+-export prefix ?= /usr/local
++export prefix ?= /usr
+ export DESTDIR ?= /
+
+ ifneq ($(shell spl-config --cflags 2>/dev/null),)
+-FOUND_SPL = 1
++FOUND_SPL = 0
+ else
+ FOUND_SPL = 0
+ endif
+@@ -34,19 +34,19 @@
+ endif
+
+ ifneq ($(shell perl -le 'print 1' 2>/dev/null),)
+-FOUND_PERL5 = 1
++FOUND_PERL5 = 0
+ else
+ FOUND_PERL5 = 0
+ endif
+
+ ifneq ($(shell python -c 'print 1' 2>/dev/null),)
+-FOUND_PYTHON = 1
++FOUND_PYTHON = 0
+ else
+ FOUND_PYTHON = 0
+ endif
+
+ ifneq ($(shell ruby -e 'puts 1' 2>/dev/null),)
+-FOUND_RUBY = 1
++FOUND_RUBY = 0
+ else
+ FOUND_RUBY = 0
+ endif
+diff -Naur ./stfl_internals.h ../stfl-0.19-patched/stfl_internals.h
+--- ./stfl_internals.h 2008-05-06 11:44:36.000000000 +0200
++++ ../stfl-0.19-patched/stfl_internals.h 2008-09-16 02:08:04.000000000 +0200
+@@ -28,7 +28,7 @@
+ #endif
+
+ #include "stfl.h"
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #include <pthread.h>
+
+ struct stfl_widget_type;