summaryrefslogtreecommitdiffstats
path: root/tcpxtract
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2011-01-16 18:39:41 +0100
committerFlorian Pritz <bluewind@xssn.at>2011-01-16 18:39:41 +0100
commit1caa1d5eb39e6d1b0bf96af4be1e095b31495305 (patch)
treee8a316c6168770f95125263fa9a3d196fa6d74c2 /tcpxtract
parentb7197bccd0bc74c2082c935937b6d947c3ae756d (diff)
downloadaur-packages-1caa1d5eb39e6d1b0bf96af4be1e095b31495305.tar.gz
aur-packages-1caa1d5eb39e6d1b0bf96af4be1e095b31495305.tar.xz
mass changes
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'tcpxtract')
-rw-r--r--tcpxtract/PKGBUILD27
-rw-r--r--tcpxtract/conf_default_path.patch12
2 files changed, 39 insertions, 0 deletions
diff --git a/tcpxtract/PKGBUILD b/tcpxtract/PKGBUILD
new file mode 100644
index 0000000..fc57fc7
--- /dev/null
+++ b/tcpxtract/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael P <ptchinster@archlinux.us>
+# Contributor: Christoph Siegenthaler <csi@gmx.ch>
+# Contributor: Wael Nasreddine <gandalf@siemens-mobiles.org>
+
+pkgname=tcpxtract
+pkgver=1.0.1
+pkgrel=3
+pkgdesc="A tool for extracting files from network traffic"
+url="http://tcpxtract.sourceforge.net"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libpcap')
+source=(http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz \
+conf_default_path.patch)
+md5sums=('1d8fe172d4590c33a157798e08dc0ccd' 'c7964f1e9c1315ae2d2b94c2bd06b4b7')
+
+build()
+{
+ cd $startdir/src/$pkgname-$pkgver
+ # Applying conf_default_path patch
+ patch -Np0 -i $startdir/src/conf_default_path.patch || return 1
+
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+}
+
diff --git a/tcpxtract/conf_default_path.patch b/tcpxtract/conf_default_path.patch
new file mode 100644
index 0000000..a5c5e66
--- /dev/null
+++ b/tcpxtract/conf_default_path.patch
@@ -0,0 +1,12 @@
+--- tcpxtract.c.old 2006-03-10 02:10:06.000000000 +0100
++++ tcpxtract.c 2006-03-10 02:10:23.000000000 +0100
+@@ -48,7 +48,7 @@
+ #include "search.h"
+
+ #ifndef DEFAULT_CONFIG_FILE
+-#define DEFAULT_CONFIG_FILE "/usr/local/etc/tcpxtract.conf"
++#define DEFAULT_CONFIG_FILE "/etc/tcpxtract.conf"
+ #endif
+
+ extern FILE *yyin; /* the lex/yacc input file */
+