summaryrefslogtreecommitdiffstats
path: root/thunar-notrash/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-06-21 13:24:22 +0200
committerFlorian Pritz <f-p@gmx.at>2009-06-21 13:24:22 +0200
commiteac2e3cc7d9edbfe42aa571cf4e530cf9d67ee2c (patch)
tree617cfcba7b4d7435c1f9ce48f26825e49690922e /thunar-notrash/PKGBUILD
parent488d3624be68a1655fc8b40241f514e52855d18b (diff)
downloadaur-packages-eac2e3cc7d9edbfe42aa571cf4e530cf9d67ee2c.tar.gz
aur-packages-eac2e3cc7d9edbfe42aa571cf4e530cf9d67ee2c.tar.xz
new thunar with Ability_to_disable_trash_on_Thunar.patch
Diffstat (limited to 'thunar-notrash/PKGBUILD')
-rw-r--r--thunar-notrash/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
new file mode 100644
index 0000000..a0f7f13
--- /dev/null
+++ b/thunar-notrash/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: tobias <tobias funnychar archlinux.org>
+# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+
+pkgname=thunar-notrash
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="new modern file manager for Xfce with patch to disable trash"
+arch=(i686 x86_64)
+license=('GPL2' 'LGPL2')
+url="http://thunar.xfce.org"
+groups=('xfce4')
+depends=('desktop-file-utils' 'libexif>=0.6.17' 'xfce4-panel>=4.6.1' 'hicolor-icon-theme' 'fam')
+makedepends=('intltool' 'pkgconfig')
+optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://www.xfce.org/archive/xfce-4.6.1/src/Thunar-${pkgver}.tar.bz2 Ability_to_disable_trash_on_Thunar.patch
+)
+
+build() {
+ cd ${srcdir}/Thunar-${pkgver}
+ patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --disable-static \
+ --disable-gnome-thumbnailers --enable-exif --enable-pcre
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ sed -i 's:x-directory/gnome-default-handler;::' \
+ ${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
+}
+md5sums=('218373aa45d74b6ba8c69c4d5af3bb19'
+ '55816882bbeac5bb1153f0b195a220d7')
+sha256sums=('7a2b6b493463756bbc9c54144fab2f2163bc84f0896b4c06fd225d11025a210d'
+ 'e235ac3f5559d685051bb747b348238a925de32653e8e8c9b8b89c1e0bb56a67')