summaryrefslogtreecommitdiffstats
path: root/thunderbird3
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-29 22:03:33 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-29 22:03:33 +0100
commit6f48dae43b82aa4b02d1ef21ab39f2d27f5905f7 (patch)
treedcb733535f39867cf39631e1ee91cc5956889aec /thunderbird3
parent8a3bf2cce64bbc453847a8dfc758c570820bf3b6 (diff)
downloadaur-packages-6f48dae43b82aa4b02d1ef21ab39f2d27f5905f7.tar.gz
aur-packages-6f48dae43b82aa4b02d1ef21ab39f2d27f5905f7.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'thunderbird3')
-rw-r--r--thunderbird3/PKGBUILD21
-rw-r--r--thunderbird3/default_locale.patch4
2 files changed, 13 insertions, 12 deletions
diff --git a/thunderbird3/PKGBUILD b/thunderbird3/PKGBUILD
index 4e1a659..0301f91 100644
--- a/thunderbird3/PKGBUILD
+++ b/thunderbird3/PKGBUILD
@@ -1,8 +1,9 @@
# Contibutor: Andreas Schönfelder <passtschu at freenet dot de>
pkgname=thunderbird3
-pkgver=3.0b4
-pkgrel=5
+pkgver=3.0rc1
+_basever=${pkgver/rc*/}
+pkgrel=3
pkgdesc="Standalone Mail/News reader (installs besides thunderbird2)"
arch=('i686' 'x86_64')
license=('MPL' 'GPL')
@@ -14,15 +15,15 @@ source=(ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${pkgver}/sou
mozconfig
thunderbird3.desktop
default_locale.patch)
-md5sums=('0f7c7cdfebd8948b7e3fe835773b072d'
+md5sums=('49028d9de4c4e167d469bbd4c6665b8c'
'8a3b273574d76f6cb3a255afce84e00c'
'da268f4dbf6fbb8efa13221f39d9fb32'
- '39fe15f99264dc1b6776059de87dfa88')
+ '25b6fe16ac24cd5c852213e5c1adb272')
build() {
cd "${srcdir}"
- cp "${srcdir}/mozconfig" comm-central/.mozconfig
- cd comm-central/
+ cp "${srcdir}/mozconfig" comm-1.9.1/.mozconfig
+ cd comm-1.9.1/
patch -Np1 -i "${srcdir}/default_locale.patch" || return 1
@@ -44,13 +45,13 @@ build() {
mv "${pkgdir}/usr/bin/thunderbird"{,3}
install -m755 -d "${pkgdir}/usr/share/applications"
install -m755 -d "${pkgdir}/usr/share/pixmaps"
- install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${pkgdir}/usr/share/pixmaps/thunderbird3.png"
+ install -m644 "${srcdir}/comm-1.9.1/other-licenses/branding/thunderbird/mailicon48.png" "${pkgdir}/usr/share/pixmaps/thunderbird3.png"
#Is this a bug??? What happened to default.xpm?!
- convert "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm"
+ convert "${srcdir}/comm-1.9.1/other-licenses/branding/thunderbird/"{mailicon48.png,default.xpm}
- install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm" \
- "${pkgdir}/usr/lib/thunderbird-${pkgver}/icons/" || return 1
+ install -m644 "${srcdir}/comm-1.9.1/other-licenses/branding/thunderbird/default.xpm" \
+ "${pkgdir}/usr/lib/thunderbird-${_basever}/icons/" || return 1
install -m644 "${srcdir}/thunderbird3.desktop" "${pkgdir}/usr/share/applications/"
rm -f ${pkgdir}/usr/lib/pkgconfig/thunderbird-ns{s,pr}.pc
diff --git a/thunderbird3/default_locale.patch b/thunderbird3/default_locale.patch
index 6b903cd..b9f4a5c 100644
--- a/thunderbird3/default_locale.patch
+++ b/thunderbird3/default_locale.patch
@@ -1,5 +1,5 @@
---- comm-central/mozilla/modules/libpref/src/init/all.js 2009-10-11 02:12:44.000000000 +0200
-+++ comm-central/mozilla/modules/libpref/src/init/all.js 2009-09-16 02:56:45.000000000 +0200
+--- comm-1.9.1/mozilla/modules/libpref/src/init/all.js 2009-10-11 02:12:44.000000000 +0200
++++ comm-1.9.1/mozilla/modules/libpref/src/init/all.js 2009-09-16 02:56:45.000000000 +0200
@@ -890,7 +890,7 @@
pref("intl.charset.detector", "chrome://global/locale/intl.properties");
pref("intl.charset.default", "chrome://global-platform/locale/intl.properties");