summaryrefslogtreecommitdiffstats
path: root/todotxt
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-09-03 00:37:22 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-09-03 00:37:22 +0200
commit5c68a85ffc09af00379d481c751c10c7e932b6fc (patch)
tree0b85fb4dc63cf4ca23efe961e3fbba5c4c79e076 /todotxt
parenta97364f54ca1b9017ca2cff73d1353b7895d3281 (diff)
downloadaur-packages-5c68a85ffc09af00379d481c751c10c7e932b6fc.tar.gz
aur-packages-5c68a85ffc09af00379d481c751c10c7e932b6fc.tar.xz
new packages
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'todotxt')
-rw-r--r--todotxt/PKGBUILD22
-rw-r--r--todotxt/todotxt.install17
2 files changed, 39 insertions, 0 deletions
diff --git a/todotxt/PKGBUILD b/todotxt/PKGBUILD
new file mode 100644
index 0000000..6ad0720
--- /dev/null
+++ b/todotxt/PKGBUILD
@@ -0,0 +1,22 @@
+# lifehacker.com's todo.sh script for maintaining a todo.txt file
+
+# Contributor: David Rosenstrauch <darose@darose.net>
+
+pkgname=todotxt
+_pkgname=todo.txt_cli
+pkgver=2.4
+pkgrel=1
+pkgdesc="lifehacker.com's todo.sh script for maintaining a todo.txt file"
+url="http://ginatrapani.github.com/todo.txt-cli/"
+depends=('bash')
+install=$pkgname.install
+source=(http://cloud.github.com/downloads/ginatrapani/todo.txt-cli/$_pkgname-$pkgver.tar.gz)
+md5sums=('74a9fa7d9c4270b6d1439ff3eee59774')
+arch=('i686' 'x86_64')
+license="GPL"
+
+build() {
+ cd $startdir/src/$_pkgname-$pkgver
+ install -D -m644 todo.cfg $startdir/pkg/usr/share/$pkgname/todo.cfg
+ install -D -m755 todo.sh $startdir/pkg/usr/bin/todo.sh
+}
diff --git a/todotxt/todotxt.install b/todotxt/todotxt.install
new file mode 100644
index 0000000..745117a
--- /dev/null
+++ b/todotxt/todotxt.install
@@ -0,0 +1,17 @@
+# arg 1: the new package version
+post_install() {
+ echo
+ echo "Please copy the file /usr/share/todotxt/todo.cfg to ~/.todo.cfg"
+ echo "and then edit the TODO_DIR path in that file to your desired todo data directory."
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo "Please note that the config file has changed from ~/.todo to ~/.todo.cfg,"
+ echo "and the config file contents have changed slightly since the previous release."
+ echo
+ echo "Please copy the file /usr/share/todotxt/todo.cfg to ~/.todo.cfg"
+ echo "and then edit the TODO_DIR path in that file to your desired todo data directory."
+ echo
+}