summaryrefslogtreecommitdiffstats
path: root/vhba-module
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-06-18 19:18:48 +0200
committerFlorian Pritz <f-p@gmx.at>2009-06-18 19:18:48 +0200
commit488d3624be68a1655fc8b40241f514e52855d18b (patch)
tree92b5edbd9e5193c188cca3dd7b6e92ae562312b3 /vhba-module
parentf15be7756cf924b6b116655846804d45d971581e (diff)
downloadaur-packages-488d3624be68a1655fc8b40241f514e52855d18b.tar.gz
aur-packages-488d3624be68a1655fc8b40241f514e52855d18b.tar.xz
update
Diffstat (limited to 'vhba-module')
-rw-r--r--vhba-module/PKGBUILD21
-rw-r--r--vhba-module/vhba-module.install22
2 files changed, 43 insertions, 0 deletions
diff --git a/vhba-module/PKGBUILD b/vhba-module/PKGBUILD
new file mode 100644
index 0000000..5a291ca
--- /dev/null
+++ b/vhba-module/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD,v 1.5 2009/04/10 17:11:27 partition Exp $
+# Maintainer: Mateusz Herych <heniekk@gmail.com>
+# Contributor: Charles Lindsay <charles@chaoslizard.org>
+
+pkgname=vhba-module
+pkgver=1.2.1
+pkgrel=3
+pkgdesc="Kernel module that emulates SCSI devices"
+arch=('i686' 'x86_64')
+url="http://cdemu.sourceforge.net/"
+license=('GPL2')
+depends=('kernel26>=2.6.30' 'kernel26<2.6.31')
+install=vhba-module.install
+source=(http://downloads.sourceforge.net/cdemu/$pkgname-$pkgver.tar.bz2)
+md5sums=('a3b6ad798f2b72ef599df797ef79e5ec')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ make -j1 KDIR=/usr/src/linux-`uname -r` || return 1
+ install -D vhba.ko $startdir/pkg/lib/modules/`uname -r`/extra/vhba.ko || return 1
+}
diff --git a/vhba-module/vhba-module.install b/vhba-module/vhba-module.install
new file mode 100644
index 0000000..eddff76
--- /dev/null
+++ b/vhba-module/vhba-module.install
@@ -0,0 +1,22 @@
+# Copied/modified from frandom.install
+
+# arg 1: the new package version
+# arg 2: the old package version
+
+post_install () {
+ echo ">> Place 'vhba' in MODULES= in /etc/rc.conf to enable vhba on system boot."
+ echo ">> This module needs to be recompiled for every kernel version upgrade."
+ depmod -a
+}
+
+pre_remove () {
+ rmmod vhba 2> /dev/null
+}
+
+post_remove () {
+ depmod -a
+}
+
+op=$1
+shift
+$op $*