summaryrefslogtreecommitdiffstats
path: root/vi/fetch_patches.sh.diff
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
committerFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
commit3232f9d90114778cb8d38cc1bc8477435dc65259 (patch)
tree0eb9ffafbe853c84b9ad6b808d86a00d44668392 /vi/fetch_patches.sh.diff
downloadaur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.gz
aur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.xz
initial commit
Diffstat (limited to 'vi/fetch_patches.sh.diff')
-rw-r--r--vi/fetch_patches.sh.diff22
1 files changed, 22 insertions, 0 deletions
diff --git a/vi/fetch_patches.sh.diff b/vi/fetch_patches.sh.diff
new file mode 100644
index 0000000..f08d5f5
--- /dev/null
+++ b/vi/fetch_patches.sh.diff
@@ -0,0 +1,22 @@
+--- fetch_patches.sh.orig 2009-02-15 19:34:42.000000000 +0100
++++ fetch_patches.sh 2009-02-15 19:38:06.000000000 +0100
+@@ -44,16 +44,12 @@
+ done
+
+ ########
+-
+- if [ ${downloads} != ${_patchlevel} ]; then
+- echo -e "Number of patches does not match the patchlevel!\nEdit the PKGBUILD accordingly!"
+- return 1
+- fi
++
+ IFS=$_OLDIFS
+ rm MD5SUMS
+ cd ${startdir}/src/vim$(echo ${_srcver} | sed "s/\.//")
+- for _patch in $(/bin/ls ${_patchdir}); do
+- patch -Np0 -i ${_patchdir}/${_patch} || return 1
++ for _patchnum in $(seq -w 1 ${_patchlevel} ); do
++ patch -Np0 -i ${_patchdir}/${_srcver}.${_patchnum} || return 1
+ done
+ rm -rf ${_patchdir}
+ return 0