summaryrefslogtreecommitdiffstats
path: root/vim
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-03-01 20:37:34 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-03-01 20:39:39 +0100
commit351991ce3e10dfae9cf57e7cf79fcca9b01c585b (patch)
treeb04cbcb9316474b71c8ba8570661cacee07dcb2d /vim
parentfb7ca9fcebda89c0f78dbc8200e35c4dd5d7c71d (diff)
downloadaur-packages-351991ce3e10dfae9cf57e7cf79fcca9b01c585b.tar.gz
aur-packages-351991ce3e10dfae9cf57e7cf79fcca9b01c585b.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'vim')
-rw-r--r--vim/PKGBUILD27
-rw-r--r--vim/vimrc6
2 files changed, 17 insertions, 16 deletions
diff --git a/vim/PKGBUILD b/vim/PKGBUILD
index d879d73..746c917 100644
--- a/vim/PKGBUILD
+++ b/vim/PKGBUILD
@@ -1,18 +1,17 @@
-# $Id$
+# $Id: PKGBUILD 68412 2010-02-12 20:04:30Z dgriffiths $
# Maintainer: tobias [ tobias at archlinux org ]
pkgname=vim
_srcver=7.2
-_patchlevel=267
+_patchlevel=359
pkgver=${_srcver}.${_patchlevel}
pkgrel=1
pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
arch=(i686 x86_64)
license=('custom:vim')
url="http://www.vim.org"
-depends=('gpm' 'coreutils' 'python')
-makedepends=('wget' 'sed' 'grep' 'gettext' 'perl')
-optdepends=('perl: the runtime provides a few useful perl scripts')
+depends=('gpm' 'coreutils' 'perl')
+makedepends=('wget' 'sed' 'grep' 'gettext')
backup=(etc/vimrc)
install=${pkgname}.install
# we need the extra-stuff to get all patches applied smoothly
@@ -20,6 +19,10 @@ source=(ftp://ftp.vim.org/pub/vim/unix/vim-${_srcver}.tar.bz2 \
ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-extra.tar.gz \
ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-lang.tar.gz \
fetch_patches.sh fetch_runtime.sh vimrc archlinux.vim)
+md5sums=('f0901284b338e448bfd79ccca0041254' '35e04482f07c57221c9a751aaa3b8dac' \
+ 'd8884786979e0e520c112faf2e176f05' '6d7e8d7868e8bfaa9a5880cd9c439320' \
+ '45c1c3c6aff7de0d8fc2a9d8cd5cec7d' '3f42c68545b5b1afb2e9a5b2731ef063' \
+ '10353a61aadc3f276692d0e17db1478e')
build()
{
@@ -28,6 +31,7 @@ build()
. ${srcdir}/fetch_patches.sh
. ${srcdir}/fetch_runtime.sh
get_patches || return 1
+
cd ${srcdir}/${_versiondir}
sed -i 's|^.*\(#define SYS_.*VIMRC_FILE.*"\) .*$|\1|' src/feature.h
sed -i 's|^.*\(#define VIMRC_FILE.*"\) .*$|\1|' src/feature.h
@@ -36,7 +40,7 @@ build()
--with-compiledby=ArchLinux --with-features=big \
--enable-gpm --enable-acl --with-x=no --disable-gui \
--enable-multibyte --enable-cscope \
- --enable-perlinterp --enable-pythoninterp
+ --enable-perlinterp
#--with-global-runtime=/usr/share/vim --with-vim-name=vim \
make || return 1
make VIMRCLOC=/etc DESTDIR=${pkgdir} install
@@ -57,6 +61,10 @@ build()
rm -f evim.1 # this does not make sense in the console version
done
+ # fix FS#17216
+ sed -i 's|messages,/var|messages,/var/log/messages.log,/var|' \
+ ${pkgdir}/usr/share/vim/vim72/filetype.vim
+
_runtimedir="${pkgdir}/usr/share/vim/${_versiondir}/"
update_runtime
cd ${srcdir}/${_versiondir}
@@ -67,10 +75,3 @@ build()
cd ${pkgdir}/usr/share/licenses/vim
ln -s ../../vim/${_versiondir}/doc/uganda.txt license.txt
}
-md5sums=('f0901284b338e448bfd79ccca0041254'
- '35e04482f07c57221c9a751aaa3b8dac'
- 'd8884786979e0e520c112faf2e176f05'
- '6d7e8d7868e8bfaa9a5880cd9c439320'
- '45c1c3c6aff7de0d8fc2a9d8cd5cec7d'
- '98a6065e21cba417870a66b78e9f0210'
- '10353a61aadc3f276692d0e17db1478e')
diff --git a/vim/vimrc b/vim/vimrc
index 627d028..f292bd5 100644
--- a/vim/vimrc
+++ b/vim/vimrc
@@ -10,7 +10,7 @@
" properly set to work with the Vim-related packages available in Debian.
runtime! archlinux.vim
-
-" For more option refer to /usr/share/vim/vim72/vimrc_example.vim or the vim
-" manual
+" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
+" Or better yet, read /usr/share/vim/vim72/vimrc_example.vim or the vim manual
+" and configure vim to your own liking!