summaryrefslogtreecommitdiffstats
path: root/vim
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-05-05 14:03:15 +0200
committerFlorian Pritz <f-p@gmx.at>2009-05-05 14:03:15 +0200
commitaed08f01f8e6b0de458181975c14efe8b89c418f (patch)
tree3f73ca7d67c1098486ec780134d93a7888d0af0f /vim
parentd0233c8e0b47beedff2c9ece475db86e1a6a9653 (diff)
downloadaur-packages-aed08f01f8e6b0de458181975c14efe8b89c418f.tar.gz
aur-packages-aed08f01f8e6b0de458181975c14efe8b89c418f.tar.xz
forgot to update some time
Diffstat (limited to 'vim')
-rw-r--r--vim/PKGBUILD73
-rw-r--r--vim/vim.install37
2 files changed, 54 insertions, 56 deletions
diff --git a/vim/PKGBUILD b/vim/PKGBUILD
index 6831c1c..715ba02 100644
--- a/vim/PKGBUILD
+++ b/vim/PKGBUILD
@@ -3,67 +3,66 @@
pkgname=vim
_srcver=7.2
-_patchlevel=132
+_patchlevel=166
pkgver=${_srcver}.${_patchlevel}
-pkgrel=1.1
-pkgdesc="a highly configurable, improved version of the vi text editor"
+pkgrel=1
+pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
arch=(i686 x86_64)
license=('custom:vim')
url="http://www.vim.org"
-depends=("vi>=${pkgver}" 'perl' 'acl' 'gpm>=1.20.4' 'libxt' 'python')
-makedepends=('wget' 'sed' 'grep')
+groups=('base')
+depends=('gpm' 'coreutils')
+makedepends=('wget' 'sed' 'grep' 'gettext' 'perl')
+optdepends=('perl: the runtime provides a view useful perl scripts')
backup=(etc/vimrc)
install=${pkgname}.install
# we need the extra-stuff to get all patches applied smoothly
source=(ftp://ftp.vim.org/pub/vim/unix/vim-${_srcver}.tar.bz2 \
ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-extra.tar.gz \
ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-lang.tar.gz \
- fetch_patches.sh)
+ fetch_patches.sh fetch_runtime.sh)
build()
{
+ _versiondir="vim"$(echo ${_srcver} | sed "s/\.//")
# pull in patches from vim.org (or the src cache alternatively)
- . ${startdir}/src/fetch_patches.sh
+ . ${srcdir}/fetch_patches.sh
+ . ${srcdir}/fetch_runtime.sh
get_patches || return 1
- cd ${startdir}/src/vim$(echo ${_srcver} | sed "s/\.//")
+ cd ${srcdir}/${_versiondir}
sed -i 's|^.*\(#define SYS_.*VIMRC_FILE.*"\) .*$|\1|' src/feature.h
+ sed -i 's|^.*\(#define VIMRC_FILE.*"\) .*$|\1|' src/feature.h
# build party
./configure --prefix=/usr --localstatedir=/var/lib/vim --mandir=/usr/share/man \
--with-compiledby=ArchLinux --with-features=big \
- --with-x=yes --disable-gui \
- --with-global-runtime=/usr/share/vim --with-vim-name=vim \
+ --enable-gpm --enable-acl --with-x=no --disable-gui \
--enable-multibyte --enable-cscope \
- --enable-perlinterp --enable-pythoninterp
+ --enable-perlinterp
+ #--with-global-runtime=/usr/share/vim --with-vim-name=vim \
make || return 1
- make VIMRCLOC=/etc DESTDIR=${startdir}/pkg VIMRTDIR= install
- cd ${startdir}/pkg/usr/bin
- rm -f ex view rview xxd vimtutor
- ln -s vitutor vimtutor
+ make VIMRCLOC=/etc DESTDIR=${pkgdir} install
+ cd ${pkgdir}/usr/bin
+ rm ex view # provided by (n)vi in core
+ mv vim vim-normal # we create a vim-symlink on post_install
+ ln -sf vim-normal vim
+ # ... make g* related symlinks point directly to the actual binary
+ ln -sf vim-normal rview
+ ln -sf vim-normal rvim
+ ln -sf vim-normal vimdiff
- # delete the manpages/symlinks provided by vi package
- find ${startdir}/pkg/usr/share/man -type d -name 'man1' 2> /dev/null | \
+ # delete some manpages
+ find ${pkgdir}/usr/share/man -type d -name 'man1' 2> /dev/null | \
while read mandir; do
cd ${mandir}
- mv vimdiff.1 vimdiff.org
- rm -f *.1
- ln -s rvi.1.gz rvim.1.gz
- ln -s vi.1.gz vim.1.gz
- ln -s vitutor.1.gz vimtutor.1.gz
- mv vimdiff.org vimdiff.1
+ rm -f ex.1 view.1 # provided by (n)vi
+ rm -f evim.1 # this does not make sense in the console version
done
- # kill the nobackup parts
- sed -i '/vms/,+4 d' ${startdir}/pkg/usr/share/vim/vimrc_example.vim
- install -Dm644 ${startdir}/pkg/usr/share/vim/vimrc_example.vim \
- ${startdir}/pkg/etc/vimrc
- # clean all settings and controls - served by vi package
- rm -rf ${startdir}/pkg/usr/share/vim
+ _runtimedir="${pkgdir}/usr/share/vim/${_versiondir}/"
+ update_runtime
+ install -Dm644 ${_runtimedir}/vimrc_example.vim \
+ ${pkgdir}/etc/vimrc
+ install -dm755 ${pkgdir}/usr/share/licenses/vim
+ cd ${pkgdir}/usr/share/licenses/vim
+ ln -s ../../vim/${_versiondir}/doc/uganda.txt license.txt
}
-md5sums=('f0901284b338e448bfd79ccca0041254'
- '35e04482f07c57221c9a751aaa3b8dac'
- 'd8884786979e0e520c112faf2e176f05'
- 'f16f81339ea02b6e1a736264861b7fad')
-sha256sums=('914db0f2205ebd6f02878295ec2506036ea7500399db112c61a01491cd9a1d86'
- '20894ac79672160bfc4f1d2f9f9775b34d944762d655307a91ca96d358faa04d'
- '11607f539a4518b550bf1606b7d3a6f36c1ffdf566c058e7d94bced78034cd5b'
- 'ca1318de5f37712afa532e87e0a201ad4dadcfe6d3b1382d571ea4c621bd07ed')
diff --git a/vim/vim.install b/vim/vim.install
index 1d46e19..0666b3b 100644
--- a/vim/vim.install
+++ b/vim/vim.install
@@ -1,37 +1,36 @@
post_install() {
- # if we have an existing gvim installation - relocate binaries and symlinks
- if [ -f usr/bin/vim ] ; then
+ # if gvim is installed make vim a symlink to vim-big
+ if [ -f usr/bin/vim-big ] ; then
cd usr/bin
- rm -f view rview
- ln -s vim view
- ln -s vim rview
+ rm -f vim
+ ln -sf vim-big vim
cd ${OLDPWD}
- echo "Create vim related symlinks..."
+ echo "Create gvim related symlinks..."
fi
- echo -n "Updating vim help tags..."
- usr/bin/vim --noplugins -u NONE -U NONE \
+ echo -n "Updating vi help tags..."
+ usr/bin/vi --noplugins -u NONE -U NONE \
--cmd ":helptags usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
echo "done."
}
-pre_remove() {
- cd usr/bin
- rm -f view rview
- if [ -f usr/bin/vi ] ; then
- ln -s vi view
- ln -s vi rview
- echo "Create vi related symlinks..."
+post_remove() {
+ # By all dependencies in the world, that shall never happen, because
+ # gvim depends on vim ... but then there is always pacman -Rd ...
+
+ # if gvim is installed make vim a symlink to vim-big
+ if [ -f usr/bin/vim-big ] ; then
+ cd usr/bin
+ rm -f vim
+ ln -sf vim-big vim
+ cd ${OLDPWD}
+ echo "Create gvim related symlinks..."
fi
- cd ${OLDPWD}
}
post_upgrade() {
post_install $1
}
-pre_upgrade() {
- pre_remove $2
-}
op=$1
shift