summaryrefslogtreecommitdiffstats
path: root/w3watch-git
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-09-03 00:37:22 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-09-03 00:37:22 +0200
commit5c68a85ffc09af00379d481c751c10c7e932b6fc (patch)
tree0b85fb4dc63cf4ca23efe961e3fbba5c4c79e076 /w3watch-git
parenta97364f54ca1b9017ca2cff73d1353b7895d3281 (diff)
downloadaur-packages-5c68a85ffc09af00379d481c751c10c7e932b6fc.tar.gz
aur-packages-5c68a85ffc09af00379d481c751c10c7e932b6fc.tar.xz
new packages
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'w3watch-git')
-rw-r--r--w3watch-git/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/w3watch-git/PKGBUILD b/w3watch-git/PKGBUILD
new file mode 100644
index 0000000..6c376dc
--- /dev/null
+++ b/w3watch-git/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=w3watch-git
+pkgver=20090829
+pkgrel=1
+pkgdesc='Watch the web and get notified on updates'
+arch=('any')
+url='http://git.archlinux.de/w3watch/'
+depends=('bash' 'lynx' 'awk' 'diffutils' 'coreutils' 'grep')
+license=('GPL')
+
+_gitroot='http://git.archlinux.de/~pierre/w3watch.git'
+_gitname='w3watch'
+
+build() {
+ cd ${srcdir}
+ msg 'Connecting to GIT server....'
+
+ if [ -d $_gitname ] ; then
+ pushd $_gitname && git pull origin
+ msg 'The local files are updated.'
+ popd
+ else
+ git clone $_gitroot
+ fi
+
+ msg 'GIT checkout done or server timeout'
+ msg 'Starting make...'
+ install -D -m755 "${_gitname}/w3watch" \
+ "${pkgdir}/usr/bin/w3watch"
+ install -D -m644 "${_gitname}/config.sample" \
+ "${pkgdir}/usr/share/doc/w3watch/config.sample"
+}