summaryrefslogtreecommitdiffstats
path: root/warsow
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-05-08 15:04:47 +0200
committerFlorian Pritz <f-p@gmx.at>2009-05-08 15:04:47 +0200
commit06805f308765f6c08f66bcba64d256683b83a4a2 (patch)
treee278b90e7e87d9bcccb488169869eda43f4b8683 /warsow
parentb327b6a3f2bf9eef43655f79ee79d4865c2edbe2 (diff)
downloadaur-packages-06805f308765f6c08f66bcba64d256683b83a4a2.tar.gz
aur-packages-06805f308765f6c08f66bcba64d256683b83a4a2.tar.xz
mass update
Diffstat (limited to 'warsow')
-rw-r--r--warsow/PKGBUILD68
-rw-r--r--warsow/warsow.desktop11
-rw-r--r--warsow/warsow.launcher5
-rw-r--r--warsow/wsw-server.launcher5
-rw-r--r--warsow/wswtv-server.launcher5
5 files changed, 94 insertions, 0 deletions
diff --git a/warsow/PKGBUILD b/warsow/PKGBUILD
new file mode 100644
index 0000000..cddbd62
--- /dev/null
+++ b/warsow/PKGBUILD
@@ -0,0 +1,68 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=warsow
+pkgver=0.42
+pkgrel=2
+pkgdesc="Free online multiplayer competitive FPS based on the Qfusion engine."
+url="http://www.warsow.net/"
+license=('GPL' 'custom:Warsow Content License')
+arch=('i686' 'x86_64')
+depends=('sdl' 'curl' 'libxxf86dga' 'libjpeg' 'libvorbis' 'libxxf86vm' 'libxinerama')
+makedepends=('mesa' 'openal' 'unzip' 'hd2u')
+source=('warsow.desktop' 'warsow.launcher' 'wsw-server.launcher' 'wswtv-server.launcher' \
+"http://www.iqclan.com/mirror/0.42/warsow_${pkgver}_unified.zip" \
+"https://launchpad.net/warsow/0.4/0.42/+download/warsow_${pkgver}_sdk.zip")
+md5sums=('f9bf60c80820237f7097c4e50a9582cd'
+ 'ec00081d81ad9802a8ca42fc2eac5498'
+ 'f73e10c26197178df71b941b10bf83d7'
+ 'd7e4a69835bbcf801e58307e9d6b951e'
+ 'cba5fe9b8af01b378e685959098fa84f'
+ '94c9bb2a48ac6f2687b38809e003f3b9')
+
+build() {
+ cd $srcdir/warsow_${pkgver}_unified
+
+ # Create Destination Directories
+ install -d $pkgdir/opt/warsow/
+
+ # Delete Pre-Built Binaries/Libraries
+ rm {warsow,warsow.i386,warsow.x86_64,warsow_x86.exe,warsow_x64.exe,wsw_portable_x86.exe} wsw_server* wswtv_server* libs/*
+
+ # Move Data to Destination Directory
+ cp -r $srcdir/warsow_${pkgver}_unified/basewsw $pkgdir/opt/warsow
+
+ # Compile Warsow
+ cd $srcdir/warsow_${pkgver}_src/source/
+ make || return 1
+
+ # Move Compiled Data to Destination Directory
+ cp -r $srcdir/warsow_${pkgver}_src/source/release/* \
+ $pkgdir/opt/warsow
+
+ # Fix File Format on Created Scripts
+ /usr/bin/dos2unix --d2u $pkgdir/opt/warsow/{warsow,wsw_server,wswtv_server}
+
+ # Install Custom License: Warsow Content License
+ install -D -m 0644 $srcdir/docs/license.txt \
+ $pkgdir/usr/share/licenses/${pkgname}/license.txt
+
+ # Install Client Game Launcher
+ install -D -m 0755 $srcdir/warsow.launcher \
+ $pkgdir/usr/bin/warsow
+
+ # Install Server Game Launcher
+ install -D -m 0755 $srcdir/wsw-server.launcher \
+ $pkgdir/usr/bin/wsw-server
+
+ # Install WSWTV Server Launcher
+ install -D -m 0755 $srcdir/wswtv-server.launcher \
+ $pkgdir/usr/bin/wswtv-server
+
+ # Install Client Desktop Shortcut
+ install -D -m 0644 $srcdir/warsow.desktop \
+ $pkgdir/usr/share/applications/warsow.desktop
+
+ # Install Icon
+ install -D -m 0644 $srcdir/warsow_${pkgver}_src/source/win32/warsow.ico \
+ $pkgdir/usr/share/pixmaps/warsow.ico
+}
diff --git a/warsow/warsow.desktop b/warsow/warsow.desktop
new file mode 100644
index 0000000..839e13e
--- /dev/null
+++ b/warsow/warsow.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Warsow
+GenericName=Warsow
+Comment=Online Multiplayer Competitive FPS
+Icon=/usr/share/pixmaps/warsow.ico
+Exec=/usr/bin/warsow
+Terminal=false
+Type=Application
+Categories=Application;Game
+StartupNotify=true
diff --git a/warsow/warsow.launcher b/warsow/warsow.launcher
new file mode 100644
index 0000000..64dac41
--- /dev/null
+++ b/warsow/warsow.launcher
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd "/opt/warsow"
+./warsow $*
+exit $?
diff --git a/warsow/wsw-server.launcher b/warsow/wsw-server.launcher
new file mode 100644
index 0000000..5035253
--- /dev/null
+++ b/warsow/wsw-server.launcher
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd "/opt/warsow"
+./wsw_server $*
+exit $?
diff --git a/warsow/wswtv-server.launcher b/warsow/wswtv-server.launcher
new file mode 100644
index 0000000..10f70a2
--- /dev/null
+++ b/warsow/wswtv-server.launcher
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd "/opt/warsow"
+./wswtv_server $*
+exit $?