summaryrefslogtreecommitdiffstats
path: root/weechat-git
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-05 11:56:01 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-05 11:56:01 +0200
commit65bf224cb276c6a1afb8c123fc81d316c57478fb (patch)
tree4fa9f459ffdcfe979d865e875dd07ff252fe1972 /weechat-git
parentc4da78deb0d8eb6c9e2b9163bba3382a501c9747 (diff)
downloadaur-packages-65bf224cb276c6a1afb8c123fc81d316c57478fb.tar.gz
aur-packages-65bf224cb276c6a1afb8c123fc81d316c57478fb.tar.xz
add weechat
Diffstat (limited to 'weechat-git')
-rw-r--r--weechat-git/PKGBUILD54
-rw-r--r--weechat-git/weechatgit.install11
2 files changed, 65 insertions, 0 deletions
diff --git a/weechat-git/PKGBUILD b/weechat-git/PKGBUILD
new file mode 100644
index 0000000..fd6eaec
--- /dev/null
+++ b/weechat-git/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Licia Todd <tigrmesh at aol dot com>
+# Contributor: Tim Zebulla <amon at faumrahrer dot de>
+
+pkgname=weechat-git
+pkgver=20090613
+pkgrel=1
+install=('weechatgit.install')
+pkgdesc="Fast, light & extensible IRC client (curses UI)"
+arch=('i686' 'x86_64')
+url="http://weechat.flashtux.org"
+depends=('perl' 'python>=2.5' 'gnutls' 'lua' 'aspell' 'iksemel' 'ruby<1.9')
+makedepends=('git' 'cmake')
+optdepends=('tcl: tcl scripting support')
+options=(!strip)
+license=('GPL3')
+source=()
+md5sums=()
+
+_gitroot="git://git.sv.gnu.org/weechat.git"
+_gitrepo="weechat"
+
+build(){
+ cd $startdir/src
+
+ msg ""
+ msg "Connecting to GIT server..."
+
+ if [ ! -d $startdir/src/$_gitrepo ]; then
+ msg "First time connected - cloning repo, this may take a while..."
+ git clone $_gitroot || return 1
+ else
+ cd $startdir/src/$_gitrepo
+ msg "Updating files..."
+ git pull || return 1
+ fi
+
+ msg "Starting build process..."
+
+ cp -r $startdir/src/$_gitrepo $startdir/src/$_gitrepo-build && cd $startdir/src/$_gitrepo-build
+
+# Installs to /usr/local so people can run both stable and devel versions
+# at the same time. Otherwise, change it to /usr
+
+ cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
+
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ rm -r $startdir/src/$_gitrepo-build
+
+}
+
+# note - to disable an option, use -DDISABLE_JABBER=ON
+# this should change soon, and will be -DENABLE_JABBER=OFF
+# also, you can see the configure options with ccmake, then just -DOPTIONHERE=ON/OFF
diff --git a/weechat-git/weechatgit.install b/weechat-git/weechatgit.install
new file mode 100644
index 0000000..f68d294
--- /dev/null
+++ b/weechat-git/weechatgit.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "------------------------------------------------------------------------------"
+ echo "Warning!"
+ echo "It's recommended to use another WeeChat home for testing this version."
+ echo "For example:"
+ echo "/usr/local/bin/weechat-curses --dir /tmp/weechat"
+ echo ""
+ echo "You've just built weechat from GIT."
+ echo "This is a development version and may therefore be unstable."
+ echo "------------------------------------------------------------------------------"
+}