summaryrefslogtreecommitdiffstats
path: root/wireshark-cli/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-05-17 12:04:10 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-05-17 12:04:10 +0200
commit545b0b7de32c86264d4ec1eb7b7610e4c1c85946 (patch)
tree9ad399ce5176aee3c98f216f54a12a3e6d5290c6 /wireshark-cli/PKGBUILD
parent8dc1d552c0bab7b72371c3a1529e365410c7548c (diff)
parentac57415603ea60e9af632e70827dffa22cfff584 (diff)
downloadaur-packages-545b0b7de32c86264d4ec1eb7b7610e4c1c85946.tar.gz
aur-packages-545b0b7de32c86264d4ec1eb7b7610e4c1c85946.tar.xz
Merge branch 'master' of git://git.server-speed.net/~flo/git/aur
Diffstat (limited to 'wireshark-cli/PKGBUILD')
-rw-r--r--wireshark-cli/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/wireshark-cli/PKGBUILD b/wireshark-cli/PKGBUILD
new file mode 100644
index 0000000..22b26ad
--- /dev/null
+++ b/wireshark-cli/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Maintainer: Florian "Bluewind" Pritz <flo@xssn.at>
+
+pkgname=wireshark-cli
+pkgver=1.2.7
+pkgrel=1
+pkgdesc="A free network protocol analyzer for Unix/Linux and Windows - no GUI"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('heimdal>=1.3.1' 'libpcap>=1.0.0' 'bash' 'gnutls>=2.4.1' 'libcap>=2.16')
+makedepends=('bison' 'flex')
+url="http://www.wireshark.org/"
+replaces=('ethereal')
+conflicts=('wireshark')
+options=(!libtool)
+source=(http://www.wireshark.org/download/src/wireshark-${pkgver}.tar.gz wireshark-1.1.2--as-needed.patch)
+
+build() {
+ cd ${srcdir}/wireshark-${pkgver}
+ export CFLAGS="-fno-unit-at-a-time ${CFLAGS}"
+
+ patch -Np1 -i $srcdir/wireshark-1.1.2--as-needed.patch || return 1
+ autoreconf -f -i || return 1
+
+ ./configure --prefix=/usr --with-ssl --disable-wireshark --disable-gtktest || return 1
+ make all || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}
+md5sums=('19e358386f7a07d0d225895588b6da6d'
+ 'cc87d7eb31f256df751b3371b1c426e9')
+sha1sums=('068e27540f56f4dec384422fb6258909b0426d6e'
+ '7a743a42542fa59423870a0205e8ed7aa6bde70e')