summaryrefslogtreecommitdiffstats
path: root/0ad
diff options
context:
space:
mode:
Diffstat (limited to '0ad')
-rw-r--r--0ad/0ad-editor.desktop10
-rw-r--r--0ad/0ad-editor.sh3
-rw-r--r--0ad/0ad.desktop8
-rw-r--r--0ad/0ad.install21
-rw-r--r--0ad/0ad.pngbin32959 -> 0 bytes
-rw-r--r--0ad/0ad.sh3
-rw-r--r--0ad/PKGBUILD65
7 files changed, 0 insertions, 110 deletions
diff --git a/0ad/0ad-editor.desktop b/0ad/0ad-editor.desktop
deleted file mode 100644
index cded424..0000000
--- a/0ad/0ad-editor.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Categories=Application;Game;
-Name=0 A.D. Editor
-Name[es]=Editor de 0 A.D.
-Name[gl]=Editor do 0 A.D.
-Icon=0ad
-Exec=0ad-editor
-Terminal=false
-Type=Application
diff --git a/0ad/0ad-editor.sh b/0ad/0ad-editor.sh
deleted file mode 100644
index 3568b28..0000000
--- a/0ad/0ad-editor.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd /opt/0ad/system
-./pyrogenesis -editor
diff --git a/0ad/0ad.desktop b/0ad/0ad.desktop
deleted file mode 100644
index 0f527f3..0000000
--- a/0ad/0ad.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Categories=Application;Game;
-Name=0 A.D.
-Icon=0ad
-Exec=0ad
-Terminal=false
-Type=Application
diff --git a/0ad/0ad.install b/0ad/0ad.install
deleted file mode 100644
index bdc8043..0000000
--- a/0ad/0ad.install
+++ /dev/null
@@ -1,21 +0,0 @@
-# arg 1: the new package version
-post_install() {
-cat << EOF
-Note:
-==> In order to play the game, execute it as follows:
-==> 0ad
-==> You can also run the game editor with this command:
-==> 0ad-editor
-==> Have fun!
-EOF
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install $1
-}
-
-op=$1
-shift
-$op $* \ No newline at end of file
diff --git a/0ad/0ad.png b/0ad/0ad.png
deleted file mode 100644
index 5708568..0000000
--- a/0ad/0ad.png
+++ /dev/null
Binary files differ
diff --git a/0ad/0ad.sh b/0ad/0ad.sh
deleted file mode 100644
index 56ff4d8..0000000
--- a/0ad/0ad.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd /opt/0ad/system
-./pyrogenesis $*
diff --git a/0ad/PKGBUILD b/0ad/PKGBUILD
deleted file mode 100644
index e2fca24..0000000
--- a/0ad/PKGBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Maintainer: t3ddy <t3ddy1988 "at" gmail {dot} com>
-# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
-
-pkgname=0ad
-pkgver=alpha_3
-_pkgver=r08832-alpha
-pkgrel=1
-pkgdesc="Cross-platform, 3D and historically-based real-time strategy game"
-arch=('i686' 'x86_64')
-url="http://wildfiregames.com/0ad"
-license=('GPL2' 'CCPL')
-depends=('binutils' 'boost' 'crypto++' 'devil' 'enet-old' 'fam' 'libogg' 'libpng' 'libvorbis' 'libxml2' 'mesa' 'nasm' 'openal' 'python' 'sdl' 'wxgtk' 'zip' 'zlib')
-makedepends=('cmake')
-conflicts=('0ad-svn' '0ad-ppa-wfg')
-provides=('0ad')
-source=("http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz"
- "http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-data.tar.xz"
- "${pkgname}.install"
- "${pkgname}.sh"
- "${pkgname}-editor.sh"
- "${pkgname}.desktop"
- "${pkgname}-editor.desktop"
- "${pkgname}.png")
-md5sums=('b9df52751596633d9aab4cc3b253cb82'
- '38abc29fc714946ed17ac86ac67fb614'
- '92575ff82bd29369b7b0ee0ce307b39e'
- '0a8abdb0fc32af6d48ea235c46be5b7c'
- '1a54a2b4ab72424d14ffc42a01925ff3'
- 'e56b164613ab929fbce76c83b766c6e9'
- '51f83e2fd2f22764dbf775689aa155a4'
- '51559438e79c0eb8576b98213a5d92d1')
-
-build(){
- cd "${srcdir}/${pkgname}-${_pkgver}/build/workspaces"
- ./update-workspaces.sh
-
- cd ${srcdir}/${pkgname}-${_pkgver}/build/workspaces/gcc
-
- # Official recomendations about -j parameter.
- if [[ $CARCH = 'x86_64' ]]
- then
- CONFIG=Release make -j3
- else
- CONFIG=Release make -j2
- fi
-}
-
-package(){
- install -d ${pkgdir}/opt/0ad
- cp -r ${srcdir}/${pkgname}-${_pkgver}/binaries/* ${pkgdir}/opt/0ad
-
- # Removing useless stuff.
- # This might change between releases:
- rm -r ${pkgdir}/opt/0ad/system/*r
- rm -r ${pkgdir}/opt/0ad/system/*.a
- rm -r ${pkgdir}/opt/0ad/system/*t
- rm -r ${pkgdir}/opt/0ad/system/*debug.so
-
- install -D -m755 ${srcdir}/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
- install -D -m755 ${srcdir}/${pkgname}-editor.sh ${pkgdir}/usr/bin/${pkgname}-editor
-
- install -D -m 0644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m 0644 "${srcdir}/${pkgname}-editor.desktop" "${pkgdir}/usr/share/applications/${pkgname}-editor.desktop"
- install -D -m 0644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
-} \ No newline at end of file