summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cdrtools/PKGBUILD39
-rw-r--r--cdrtools/cdrtools.install7
-rw-r--r--extract/PKGBUILD6
-rw-r--r--ompload/PKGBUILD17
-rw-r--r--ompload/ompload151
-rw-r--r--oss-mercurial/PKGBUILD4
-rw-r--r--pacgraph/PKGBUILD20
-rw-r--r--tint2-svn/PKGBUILD41
-rw-r--r--vidalia/PKGBUILD25
-rw-r--r--vidalia/arch_menuicon.patch7
-rw-r--r--vidalia/vidalia.pngbin0 -> 3620 bytes
11 files changed, 311 insertions, 6 deletions
diff --git a/cdrtools/PKGBUILD b/cdrtools/PKGBUILD
new file mode 100644
index 0000000..cf9f55c
--- /dev/null
+++ b/cdrtools/PKGBUILD
@@ -0,0 +1,39 @@
+# Former contributor: Tuxbubling <tuxbubling@jabber.fr>, alejandronova
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=cdrtools
+pkgver=2.01.01a60
+pkgrel=1
+pkgdesc="Original cdrtools, supporting CD, DVD and BluRay burning"
+arch=('i686' 'x86_64')
+url="http://cdrecord.berlios.de/private/cdrecord.html"
+license=('CDDL')
+depends=('acl')
+conflicts=('cdrkit')
+provides=('cdrkit')
+backup=('etc/default/cdrecord' 'etc/default/rscsi')
+install=cdrtools.install
+source=(ftp://ftp.berlios.de/pub/cdrecord/alpha/cdrtools-$pkgver.tar.gz \
+ ftp://ftp.berlios.de/pub/smake/alpha/smake-1.2a41.tar.gz)
+md5sums=('62a2c475d3efefb1792f5ca20dfbb557'
+ '1442b147193800e27246ac6d000ba890')
+
+build() {
+ cd "$srcdir"/smake-1.2/psmake
+ ./MAKE-all
+ cd ..
+ ./psmake/smake
+
+ cd "$srcdir"/cdrtools-${pkgver%%a*}
+ sed -i 's|/opt/schily|/usr|g' DEFAULTS/Defaults.linux
+ sed -i 's|DEFINSGRP=.*|DEFINSGRP=root|' DEFAULTS/Defaults.linux
+
+ "$srcdir"/smake-1.2/smake/OBJ/*-linux-*/smake || return 1
+ "$srcdir"/smake-1.2/smake/OBJ/*-linux-*/smake INS_BASE="$pkgdir"/usr INS_RBASE="$pkgdir" install
+ mv "$pkgdir"/usr/man "$pkgdir"/usr/share/
+ rm -rf "$pkgdir"/usr/include
+ rm -rf "$pkgdir"/usr/lib
+ find "$pkgdir" -type d -perm 775 -exec chmod 755 '{}' ';'
+ find "$pkgdir" -type f -perm 4711 -exec chmod 755 '{}' ';'
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cdrtools/cdrtools.install b/cdrtools/cdrtools.install
new file mode 100644
index 0000000..b2a4e20
--- /dev/null
+++ b/cdrtools/cdrtools.install
@@ -0,0 +1,7 @@
+
+post_install() {
+ echo "If other users than root should be allowed to execute rscsi"
+ echo "they need an entry in /etc/default/rscsi"
+ echo "If you do not change that entry, you should create a user rscsi."
+}
+
diff --git a/extract/PKGBUILD b/extract/PKGBUILD
index e6c037e..fc7e669 100644
--- a/extract/PKGBUILD
+++ b/extract/PKGBUILD
@@ -1,12 +1,12 @@
# Contributor: Florian Pritz <f-p@gmx.at>
pkgname=extract
-pkgver=0.2.2
+pkgver=0.2.2.1
pkgrel=1
pkgdesc="Script to extract multiple archives"
arch=('i686' 'x86_64')
url="http://flo.server-speed.net"
-license=('GPLv3')
+license=('WTFPLv2')
depends=('gzip' 'tar' 'p7zip' 'unrar' 'unzip' 'bzip2' 'file')
source=("http://flo.server-speed.net/stuff/mirror/$pkgname/$pkgname-$pkgver.tar.gz")
@@ -19,5 +19,3 @@ build() {
}
# vim:set ts=2 sw=2 et:
-md5sums=('d502f3f0a2b3c2b90ed23d0f0a3870c6')
-sha256sums=('c327061244c5696d1b9eb23aba48d7a8b1f382862e851af603438dff71839d2d')
diff --git a/ompload/PKGBUILD b/ompload/PKGBUILD
new file mode 100644
index 0000000..96969b6
--- /dev/null
+++ b/ompload/PKGBUILD
@@ -0,0 +1,17 @@
+#Maintainer: FallenWizard <fallenwiz@gmail.com>
+
+pkgname=ompload
+pkgver=20090529
+pkgrel=1
+pkgdesc="Script to upload files to omploader.org"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('ruby>=1.8' 'curl')
+url="http://omploader.org"
+source=(${pkgname})
+md5sums=('184394e71161d7c41401a6c42d78f5e6')
+
+build() {
+ cd ${startdir}/src
+ install -D -m755 ${pkgname} ${startdir}/pkg/usr/bin/${pkgname}
+}
diff --git a/ompload/ompload b/ompload/ompload
new file mode 100644
index 0000000..d639f3c
--- /dev/null
+++ b/ompload/ompload
@@ -0,0 +1,151 @@
+#!/usr/bin/env ruby
+#
+# Copyright 2007-2009 David Shakaryan <omp@gentoo.org>
+# Copyright 2007-2009 Brenden Matthews <brenden@rty.ca>
+#
+# Distributed under the terms of the GNU General Public License v3
+#
+
+require 'tempfile'
+
+argv = Array.new
+
+quiet = false
+url_only = false
+help = false
+skip = false
+filename = 'pasta'
+
+$stdin.fcntl(4, File::NONBLOCK)
+stdin = $stdin.read if !$stdin.eof
+unless stdin.nil?
+ argv << ''
+end
+
+ARGV.each_index do |i|
+ if skip
+ skip = false
+ next
+ end
+ if ARGV[i] =~ /-q|--quiet/
+ quiet = true
+ elsif ARGV[i] =~ /-u|--url/
+ url_only = true
+ elsif ARGV[i] =~ /-h|--help/
+ help = true
+ elsif ARGV[i] =~ /-f|--filename/
+ filename = ARGV[i + 1]
+ skip = true
+ else
+ argv << ARGV[i]
+ end
+end
+
+nocurl = false
+curl = %x{curl --version 2> /dev/null}
+if curl.empty?
+ nocurl = true
+ $stderr.puts 'Error: curl missing or not in path. Cannot continue.'
+ $stderr.puts
+end
+
+if (ARGV.size < 1 and (stdin.nil? or stdin.empty?)) or help or nocurl
+ $stderr.puts 'Usage: ompload [-h|--help] [options] [file(s)]'
+ $stderr.puts ' -q, --quiet Only output errors and warnings'
+ $stderr.puts ' -u, --url Only output URL when finished'
+ $stderr.puts ' -f, --filename Filename to use when posting data'
+ $stderr.puts ' from stdin'
+ $stderr.puts
+ $stderr.puts ' You can supply a list of files or data via stdin (or both)'
+ $stderr.puts
+ $stderr.puts ' This script requires a copy of cURL in the path.'
+ Process.exit
+end
+
+errors = 0
+
+wait = 5
+
+Url = 'http://omploader.org/'
+Max_size = 2**30
+
+used_stdin = false
+first = true
+
+argv.each do |arg|
+
+ if stdin.nil? and !used_stdin and !File.file?(arg)
+ $stderr.puts "Invalid argument '#{arg}': file does not exist (or is not a regular file)."
+ errors += 1
+ next
+ elsif File.size(arg) > Max_size
+ $stderr.puts "Error omploading '#{arg}': file exceeds " + (Max_size).to_s + " bytes (size was " + File.size(arg).to_s + ")."
+ errors += 1
+ next
+ end
+
+ if !first
+ # try not to hammer the server
+ puts 'Sleeping for ' + wait.to_s + 's' if !quiet and !url_only
+ sleep(wait)
+ else
+ first = false
+ end
+
+ tmp = Tempfile.new(filename)
+ if !stdin.nil? and !used_stdin
+ # upload from stdin
+ puts "Progress for '#{arg}'" if !quiet and !url_only
+ if quiet or url_only
+ p = IO.popen("curl -s -F 'file1=@-;filename=\"#{filename}\"' #{Url}upload -o '#{tmp.path}'", "w+")
+ else
+ p = IO.popen("curl -# -F 'file1=@-;filename=\"#{filename}\"' #{Url}upload -o '#{tmp.path}'", "w+")
+ end
+ p.puts stdin
+ p.close_write
+ Process.wait
+ used_stdin = true
+ else
+ # upload file
+ puts "Progress for '#{arg}'" if !quiet and !url_only
+ # escape quotes
+ tmp_path = arg.gsub('"', '\"')
+ if quiet or url_only
+ %x{curl -s -F file1=@"#{tmp_path}" #{Url}upload -o '#{tmp.path}'}
+ else
+ %x{curl -# -F file1=@"#{tmp_path}" #{Url}upload -o '#{tmp.path}'}
+ end
+ end
+ if !File.size?(tmp.path)
+ $stderr.puts "Error omploading '#{arg}'"
+ errors += 1
+ next
+ end
+ output = IO.read(tmp.path)
+
+ # parse for an ID
+ if output =~ /View file: <a href="v([A-Za-z0-9+\/]+)">/
+ id = $1
+ puts "Omploaded '#{arg}' to #{Url}v#{id}" if !quiet
+ wait = 5
+ elsif output =~ /Slow down there, cowboy\./
+ wait += 60
+ argv << arg
+ $stderr.puts "Got throttled when trying to ompload '#{arg}'"
+ $stderr.puts "Increasing wait and attempting to continue..."
+ errors += 1
+ else
+ $stderr.puts "Error omploading '#{arg}'"
+ errors += 1
+ end
+
+end
+
+if !quiet and !url_only
+ if errors < 1
+ puts "Success."
+ else
+ puts "Finished with #{errors} errors."
+ end
+end
+
diff --git a/oss-mercurial/PKGBUILD b/oss-mercurial/PKGBUILD
index daea34a..ff4a285 100644
--- a/oss-mercurial/PKGBUILD
+++ b/oss-mercurial/PKGBUILD
@@ -1,7 +1,7 @@
# This is a modified version of the oss pkg in community
pkgname="oss-mercurial"
-pkgver="4.1"
-pkgrel=3
+pkgver="4.2"
+pkgrel=1
pkgdesc="Open Sound System UNIX audio architecture"
arch=('i686' 'x86_64')
url="http://developer.opensound.com/"
diff --git a/pacgraph/PKGBUILD b/pacgraph/PKGBUILD
new file mode 100644
index 0000000..b8abf98
--- /dev/null
+++ b/pacgraph/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Kyle Keen <keenerd@gmail.com>
+pkgname=pacgraph
+pkgver=20090527
+pkgrel=1
+pkgdesc="Draws a graph of installed packages. Good for finding bloat."
+arch=('i686' 'x86_64')
+url="http://kmkeen.com/pacgraph/"
+license=('GPL')
+depends=('python')
+makedepends=()
+optdepends=('inkscape' 'imagemagick' 'svg2png')
+source=(http://kmkeen.com/pacgraph/$pkgname-$pkgver.tar.gz)
+md5sums=('e92a215d79fc11cb914ab24e229e083d')
+
+build() {
+ cd $startdir/src/$pkgname
+ mkdir -p $pkgdir/usr/bin/
+ cp pacgraph $pkgdir/usr/bin/
+}
+
diff --git a/tint2-svn/PKGBUILD b/tint2-svn/PKGBUILD
new file mode 100644
index 0000000..650757e
--- /dev/null
+++ b/tint2-svn/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: zoulnix <z[o]ulnix.borkedduck.c[o]m>
+pkgname=tint2-svn
+pkgver=78
+pkgrel=1
+pkgdesc="A basic, good-looking task manager for WMs."
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/tint2/"
+license=('GPL')
+depends=('libxinerama' 'libxrandr' 'pango' 'imlib2')
+makedepends=('gcc' 'make' 'pkgconfig' 'subversion')
+provides=('tint2')
+conflicts=('tint2' 'tint' 'ttm')
+source=()
+md5sums=('')
+
+_svnmod="tint2"
+_svntrunk="http://tint2.googlecode.com/svn/trunk"
+
+build() {
+ cd ${srcdir}
+
+ #####
+ msg "Getting sources..."
+ if [ -d ${_svnmod}/.svn ]; then
+ (cd ${_svnmod} && svn up -r ${pkgver})
+ else
+ svn co ${_svntrunk} --config-dir ./ -r ${pkgver} ${_svnmod}
+ cd ${_svnmod}
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+ #####
+
+ cd ${srcdir}/${_svnmod}/src
+ sed -i -e 's:CFLAGS= -O2::' Makefile || return 1
+
+ make clean || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+} \ No newline at end of file
diff --git a/vidalia/PKGBUILD b/vidalia/PKGBUILD
new file mode 100644
index 0000000..2e4ecfe
--- /dev/null
+++ b/vidalia/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Rorschach <r0rschach@lavabit.com>
+
+pkgname=vidalia
+pkgver=0.1.13
+pkgrel=1
+pkgdesc="Controller GUI for Tor"
+url="http://vidalia-project.net"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('qt>=4.2.0' )
+makedepends=('cmake>=2.4.0')
+source=(http://vidalia-project.net/dist/$pkgname-$pkgver.tar.gz arch_menuicon.patch vidalia.png)
+md5sums=('b0fcd0a9c30b1ed545981fa7d8ac7d71' '81faa5d013409090f0eed9aa2b0f5fed' '5ec703cf17d75f880b2494495a5d2a58')
+
+build() {
+ [ -f /etc/profile.d/qt4.sh ] && source /etc/profile.d/qt4.sh
+
+ patch -p0 < ../arch_menuicon.patch
+ cd $pkgname-$pkgver
+ cmake -D CMAKE_INSTALL_PREFIX=/usr .
+ make || return 1
+ make DESTDIR=$pkgdir install
+ install -Dm644 doc/vidalia.1.in $pkgdir/usr/share/man/man1/vidalia.1
+ install -Dm644 $srcdir/vidalia.png $pkgdir/usr/share/pixmaps/vidalia.png
+}
diff --git a/vidalia/arch_menuicon.patch b/vidalia/arch_menuicon.patch
new file mode 100644
index 0000000..e79718b
--- /dev/null
+++ b/vidalia/arch_menuicon.patch
@@ -0,0 +1,7 @@
+--- vidalia-0.1.13/src/vidalia/vidalia.desktop.old 2009-01-01 16:19:01.000000000 +0100
++++ vidalia-0.1.13/src/vidalia/vidalia.desktop 2009-01-01 16:20:13.000000000 +0100
+@@ -6,3 +6,4 @@
+ GenericName=Tor GUI
+ Terminal=false
+ Categories=Qt;Network;
++Version=0.1.13
diff --git a/vidalia/vidalia.png b/vidalia/vidalia.png
new file mode 100644
index 0000000..bc9a198
--- /dev/null
+++ b/vidalia/vidalia.png
Binary files differ