summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--spampd/PKGBUILD10
-rw-r--r--spampd/fix-pod.patch42
-rw-r--r--spampd/perl-5.18-fixes.patch42
-rw-r--r--spampd/untaint-pidfile.patch28
4 files changed, 46 insertions, 76 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
index 84e4950..7fe927a 100644
--- a/spampd/PKGBUILD
+++ b/spampd/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Florian "Bluewind" Pritz <flo@xssn.at>
pkgname=spampd
pkgver=2.30
-pkgrel=8
+pkgrel=9
pkgdesc="Spamassassin Proxy Daemon"
arch=('any')
url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
@@ -9,17 +9,15 @@ license=('GPL')
depends=('perl' 'perl-net-server' 'spamassassin')
install=spampd.install
source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
- spampd.service untaint-pidfile.patch fix-pod.patch)
+ spampd.service perl-5.18-fixes.patch)
md5sums=('742c6f2cb75db54e59d044a8ee40445f'
'f29bea0766c07a18f6dc0a496a79e0ac'
- '41f9dc41a42f3b82fdeadfe8943ee0a3'
- 'cb5832fd21d3a8aa7fbe188d79c04147')
+ '55ea1067be9e70c60b708d355b085a0a')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 -i "$srcdir/untaint-pidfile.patch"
- patch -p1 -i "$srcdir/fix-pod.patch"
+ patch -p1 -i "$srcdir/perl-5.18-fixes.patch"
}
build() {
diff --git a/spampd/fix-pod.patch b/spampd/fix-pod.patch
deleted file mode 100644
index c3b343a..0000000
--- a/spampd/fix-pod.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-commit 7b409a8f7132bd731fad017e13ad1229a09a37b7
-Author: Florian Pritz <bluewind@xinu.at>
-Date: Tue May 28 20:42:30 2013 +0200
-
- fix text before =item after =over
-
- Signed-off-by: Florian Pritz <bluewind@xinu.at>
----
- spampd | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/spampd b/spampd
-index 53161d9..fca23e4 100644
---- a/spampd
-+++ b/spampd
-@@ -1149,10 +1149,10 @@ L<http://www.WorldDesign.com/index.cfm/rd/mta/spampd.htm>.
-
- =head1 Requires
-
--=over 5
--
- Perl modules:
-
-+=over 5
-+
- =item B<Mail::SpamAssassin>
-
- =item B<Net::Server::PreForkSimple>
-@@ -1480,11 +1480,11 @@ Prints usage information.
-
- =head2 Deprecated Options
-
--=over 5
--
- The following options are no longer used but still accepted for backwards
- compatibility with prevoius I<spampd> versions:
-
-+=over 5
-+
- =item B<--dead-letters>
-
- =item B<--heloname>
diff --git a/spampd/perl-5.18-fixes.patch b/spampd/perl-5.18-fixes.patch
new file mode 100644
index 0000000..9b4637b
--- /dev/null
+++ b/spampd/perl-5.18-fixes.patch
@@ -0,0 +1,42 @@
+diff --git a/spampd b/spampd
+index 7b1f234..2798d50 100644
+--- a/spampd
++++ b/spampd
+@@ -937,6 +937,10 @@ if ( !$options{logsock} ) {
+ };
+ }
+
++# untaint some args to prevent errors in other modules
++($pidfile) = ($pidfile =~ /^(.+)$/);
++($relayhost) = ($relayhost =~ /^(.+)$/);
++($relayport) = ($relayport =~ /^(.+)$/);
+
+ my $server = bless {
+ server => {host => $host,
+@@ -1147,10 +1151,10 @@ L<http://www.WorldDesign.com/index.cfm/rd/mta/spampd.htm>.
+
+ =head1 Requires
+
+-=over 5
+-
+ Perl modules:
+
++=over 5
++
+ =item B<Mail::SpamAssassin>
+
+ =item B<Net::Server::PreForkSimple>
+@@ -1478,11 +1482,11 @@ Prints usage information.
+
+ =head2 Deprecated Options
+
+-=over 5
+-
+ The following options are no longer used but still accepted for backwards
+ compatibility with prevoius I<spampd> versions:
+
++=over 5
++
+ =item B<--dead-letters>
+
+ =item B<--heloname>
diff --git a/spampd/untaint-pidfile.patch b/spampd/untaint-pidfile.patch
deleted file mode 100644
index cd93ad0..0000000
--- a/spampd/untaint-pidfile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-commit 662d82ec2badc34f4de561021ea714afe1e1bddc
-Author: Florian Pritz <bluewind@xinu.at>
-Date: Tue May 28 20:20:44 2013 +0200
-
- untaint $pidfile to prevent errors when opening it
-
- For some reason that worked before perl 5.18, but I don't care enough
- to figure out why. Since we trust the CLI args untaining anything
- should be ok.
-
- Signed-off-by: Florian Pritz <bluewind@xinu.at>
----
- spampd | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/spampd.pl b/spampd.pl
-index 7b1f234..53161d9 100644
---- a/spampd
-+++ b/spampd
-@@ -937,6 +937,8 @@ if ( !$options{logsock} ) {
- };
- }
-
-+# untaint pidfile
-+($pidfile) = ($pidfile =~ /^(.+)$/);
-
- my $server = bless {
- server => {host => $host,