summaryrefslogtreecommitdiffstats
path: root/ack/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'ack/PKGBUILD')
-rw-r--r--ack/PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/ack/PKGBUILD b/ack/PKGBUILD
index 5fe7b01..4472bae 100644
--- a/ack/PKGBUILD
+++ b/ack/PKGBUILD
@@ -1,16 +1,25 @@
-# Maintainer: Michael S. Walker <barrucadu@localhost>
-pkgname=ack
-pkgver=1.90
-pkgrel=1
-pkgdesc="A tool like grep, aimed at programmers with large trees of heterogeneous source code."
-url="http://ack.googlecode.com"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('perl')
-source=(http://ack.googlecode.com/svn/tags/$pkgver/$pkgname)
-md5sums=('d15d059166beff6103d2401aa2d783c7')
+# Maintainer: TDY <tdy@gmx.com>
+# Contributor: Michael S. Walker <barrucadu@localhost>
+
+pkgname=ack
+pkgver=1.92
+pkgrel=1
+pkgdesc="A Perl-based grep replacement, aimed at programmers with large trees of heterogeneous source code"
+arch=('any')
+url="http://betterthangrep.com/"
+license=('GPL' 'PerlArtistic')
+depends=('perl-file-next')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/$pkgname-$pkgver.tar.gz)
+md5sums=('c25b5a16d0a27386a75c91d531b86cea')
build() {
- cd $startdir/src
- install -D -m755 ack ${pkgdir}/usr/bin/ack
-} \ No newline at end of file
+ cd "$srcdir/$pkgname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}