summaryrefslogtreecommitdiffstats
path: root/apcupsd-cli/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'apcupsd-cli/PKGBUILD')
-rw-r--r--apcupsd-cli/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/apcupsd-cli/PKGBUILD b/apcupsd-cli/PKGBUILD
new file mode 100644
index 0000000..ba47f08
--- /dev/null
+++ b/apcupsd-cli/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 8842 2010-01-21 22:55:25Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Todd Musall <tmusall@comcast.net>
+
+pkgname=apcupsd-cli
+_orig=apcupsd
+pkgver=3.14.8
+pkgrel=1
+pkgdesc="Apcupsd version without GUI and webinterface"
+arch=(i686 x86_64)
+url="http://www.apcupsd.org"
+license=('GPL')
+depends=('gcc-libs')
+makedepends=('pkgconfig')
+conflicts=('apcupsd')
+backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
+ etc/apcupsd/multimon.conf)
+source=(http://downloads.sourceforge.net/apcupsd/$_orig-$pkgver.tar.gz \
+ apcupsd)
+md5sums=('cd17f0a903dc2220e55ed54e242359d2'
+ '5eae3c4d921eeb81798a0250fe3dd111')
+
+build() {
+ cd $startdir/src/$_orig-$pkgver
+ ./configure --prefix=/usr --libexecdir=/usr/lib/$_orig \
+ --enable-usb --enable-net \
+ --with-upstype=usb --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --enable-pthreads
+
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+
+ install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
+ chmod 755 $startdir/pkg/sbin/*
+}