summaryrefslogtreecommitdiffstats
path: root/brother-dcp9010cn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'brother-dcp9010cn/PKGBUILD')
-rw-r--r--brother-dcp9010cn/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/brother-dcp9010cn/PKGBUILD b/brother-dcp9010cn/PKGBUILD
new file mode 100644
index 0000000..ef5e351
--- /dev/null
+++ b/brother-dcp9010cn/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Pavel Benak <pavel.benak@uhk.cz>
+
+pkgname=brother-dcp9010cn
+pkgver=1.1.1
+pkgrel=4
+pkgdesc="Brother cups and lpd driver for DCP-9010CN"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom')mm
+if [ "$(uname -m)" = "x86_64" ]
+then
+ depends=('lib32-glibc' 'psutils')
+else
+ depends=('psutils')
+fi
+noextract=(DCP7010.ppd.gz)
+
+source=(
+http://www.brother.com/pub/bsc/linux/dlf/dcp9010cncupswrapper-$pkgver-$pkgrel.i386.deb
+http://www.brother.com/pub/bsc/linux/dlf/dcp9010cnlpr-$pkgver-$pkgrel.i386.deb
+brlpdwrapperdcp9010cn
+)
+
+md5sums=('f8fbdc819c5ed1d54fdfe0da24e2939d'
+ '6b24a542b9d2f755d43cf0e6c91101ad'
+ '3ba6c4dd55eb15f918741f4ad102570f')
+
+build()
+{
+ mkdir -p $startdir/src/unpack || return 1
+ for i in $startdir/src/*.deb
+ do
+ cd $startdir/src/unpack
+ ar -x $i || return 1
+ cd $startdir/pkg
+ bsdtar xf $startdir/src/unpack/data.tar.gz || return 1
+ done
+
+ cd $startdir/src
+ install -d -m755 $startdir/pkg/usr/share/cups/model || return 1
+ install -d -m755 $startdir/pkg/usr/lib/cups/filter || return 1
+ install -D -m644 $startdir/pkg/usr/local/Brother/Printer/dcp9010cn/cupswrapper/dcp9010cn.ppd $startdir/pkg/usr/share/cups/model || return 1
+ install -D -m755 brlpdwrapperdcp9010cn $startdir/pkg/usr/lib/cups/filter || return 1
+}